Starblade not working

Has anyone tried Starblade and gotten it to work? I tried a few different ROM sets and can’t seem to get it working, even with what is supposed to be a compatible set. I tried the various MAME versions in Lakka.

I’m using a Raspberry Pi 4 with Lakka 4.2.

Having the right romset doesn’t guarantee a game will work in MAME, in fact most MAME games won’t work properly or at all. Supposedly there is a warning when you try to boot a non-working MAME game, but i believe the libretro cores are disabling it, which is a very very bad idea imho.

Idk which version of MAME you tried, but fyi the older the version the less likely a game will work properly or at all, so you should try the current version, supposedly this game is playable with minor gfx issues in it.

Yes. This is a game that has worked on other platforms (like my computer). I tried every version that is available in Lakka - MAME 2003 Plus, 2010, 2015, Current.

It might be some kind of bug specific to arm platforms then. What’s happening exactly when you boot the game on your pi4 ?

I wouldn’t trust a Raspberry setup to run demanding MAME games with 3D graphics.

Game does works fine on my Windows setup, both in standalone and RA core, for the record. I’m using version 0.240 roms/standalone and a 0.239 RA core.

If you got a grey screen, you may need additional roms (namcoc67 & namcoc68). Tested with Lakka 4.2 and current mame. I needed to test with standalone Mame to identify additional roms. This was also on the Generic PC rather than Raspberry Pi.