Stuck at Boot/Blank Screen with Lakka on Intel NUC 8i7BEH


#1

I could not get Lakka to run from USB, nor install to HDD. Everything I did failed stuck at the Lakka flower then display goes blank.

I tried Lakka versions 2.1, 2.1.1, 2.2, etc and finally landed on the Lakka-Generic.x86_64-3.0-devel-20180703104709-2fb13c2 build (its the only version that seemed to ‘auto load’ the correct resolution at the Lakka flower boot) - so seemed promising, but still no luck.

Then, I found this link, and followed @gouchi 's codes and got into Lakka!

Try to boot in text mode: live textmode Then launch RA with: DRAW_USE_LLVM=0 retroarch -v

Now, what do I do from here? What file(s) do I need to edit to be able to install Lakka to the HDD, and have it boot into Lakka like normal?


#2

Out of curiousity, have you turned off secureboot and intel txe (trust execution engine) in bios?

Ok looked up some bios images

Trust platform TPM = off
Allow 3th party uefi driver = on
Secure boot = off

Try with this settings


#3

Thank you for the reply, however still no difference. Anything else I can troubleshoot?

I did have… Secure Boot = Off

I changed… Allow 3rd Party UEFI Driver = On and Intel Platform Trust = Off

Basically what happens is, I get to the Lakka flower, I see one line of text generate in the top left corner of the screen (looks like the version build # or something - it flashes quick), then the display goes blank, and nothing I can do further but restart the PC.

What exactly does the “DRAW_USE_LLVM=0 retroarch -v” code bypass? As that’s the only way I can get Lakka to run - off of the USB live mode.

I did have Lakka installed and running fine on my Asus EeePC setup - so it must be something not compatible with this Intel NUC 8 version hardware… are you running an Intel NUC 8?


#4

… continues here https://github.com/libretro/Lakka-LibreELEC/issues/486#issuecomment-456125449

and

here Autostart.sh Proper Coding