Stuck in kiosk mode, no settings available to change

Raspberry Pi 4, using Lakka 2.3.2. I set kiosk mode, but now I only have the Main Menu (load core, load content, etc.). The second row, settings, is gone. Complicating things, it’s not connecting to WiFi, so using Putty for cmd line edits isn’t working. Do I have any options other than re-installing from scratch?

If you can mount your storage on another machine, you should be able to access the config file in ~/.config/retroarch/retroarch.cfg. Other than that, reinstallation is probably the only way to go.

As an update: after a few reboots it reconnected to WiFi, so I was able to access it over SSH with Putty. I reset the config files and that took care of it. Hope this may help someone.

1 Like

I found out that setting Kiosk mode without a password means you have no means of disabling it from Lakka unless you you mount it on a pc. I personally love using Linux Mint to do so or even a Raspberry Pi os will allow you to open up the files if you open them up as root. when you get open up retroarch.cfg search kiosk and it will be faster to find it within all that code.

I have also made the fatal mistake of enabling “Kiosk Mode” without setting a password first :(. I am able to edit retroarch.cfg via SSH and SAMBA to add a password or disable (set to false) but these changes are not kept on reboot. Any ideas without having to delete this file and setting up again? Btw, I’m using Fedora to access this file.

:slight_smile:

You need to stop the retroarch process before you can make any changes to the cfg file or they will get wiped out on exit/reboot.

1 Like

Thanks for the quick reply hunterk. Any ideas how to achieve this? What is the service name?

:slight_smile:

EDIT: I’ve managed to get in and add a password.

Anyone in a similar position with network access, the following may work for you.

  1. [email protected][lakka ip address]. View ip address from Lakka (information, network information)
  2. Enter root password (root)
  3. systemctl stop retroarch
  4. Edit retroarch.cfg (see path above) and set kiosk_mode_enable = “false” or kiosk_mode_password = “[new password]”
  5. Reboot

Note: Above access via Linux.

:slight_smile:

1 Like