The dreaded audio issue

Hello everyone. First post here. Sorry to beat a dead horse as I have seen this topic come up many times, but I have been unable to resolve it.

I recently set up the latest build of Lakka on a Raspberry PI 3 system. Honestly I love the interface and greatly prefer it over Retropie. The problem is thus far I have been completely unable to get my sound to work. I have tried basically all the little tricks that I’ve come across. I know on the latest build of Lakka you are able to change the audio device in the menu, my problem is the only options I have are basically null, sys:default ALSA and ALSA. I see no options for anything related to HDMI. I read about the whole certain TV’s having issues with audio and HDMI and to edit the config.txt file to show HDMI_DRIVE=2. This still hasn’t solved my problem. I’m not actually running my HDMI cable straight into my television, but through an ONKYO receiver. I don’t see why this would make a difference, but I tried it straight into the TV as well and still have no audio.

I also downloaded Putty on my Windows 10 computer and used SSH in the terminal to check out the aplay -L options. Every time I see someone else who’s posted a log of this they seem to have this big huge list of audio options and many things which say HDMI. I don’t get anything like this. Again basically all I see are the same audio options mentioned above (null, alsa, etc). I am really at a loss as to what to do. I feel like it’s probably something simple I am overlooking, but I have spent hours upon hours setting up games on this among other tweaks and having no sound is a real bummer.

Any help would be greatly appreciated.

Thanks very much.


You tried with nightly from 4th August?

Hi Gouchi,

No actually i was running this build…


I will try out the nightly you mentioned and see if it works any better. Will let you know. Thanks!

Hi -

New to the forum and new to Lakka. I’m having the exact same issue with a Raspberry Pi 3. No HDMI audio available via GUI or in aplay. I’ve tried both Retropie and Recalbox, and can get audio on both. It’s only Lakka that is having the issue. I’m using the latest v2.0 build - any thoughts?

Update Additional technical details: This is a brand new Rpi3 and a fresh installation of Lakka v2. I’ve tried all the recommended retroarch.cfg updates, but still no audio. I’ve also tried using the other audio drivers through the Advanced Menu of the GUI, but results are the same. Results of aplay -L are:

Null Discard all samples (playback) or generate zero samples (capture) default:CARD=ALSA bcm2835 ALSA, bcm2835 ALSA Default Audio Device sysdefault:CARD=ALSA bcm2835 ALSA, bcm2835 ALSA Default Audio Device

Update I also tried using the retroarch.cfg from the latest Retropie distro for Rpi3. Still no audio from Lakka, even though that same Retropie distro produces audio without issue.

SOLUTION I was able to finally resolve the audio issue, but it required adding “hdmi_drive=2” and “hdmi_force_edid_audio=1” to the /flash/config.txt file. I also uncommented the hdmi_force line. Not sure if it was one or all of these changes that worked (hdmi_drive=2 alone didn’t work), but for now I have audio.

I’ve researched all over and tried everything but can’t get my raspberry pi zero to output audio through anything but hdmi. Tired nightly also, without that it could not work with the composite lcd 3.5 inch monitor I’m trying to use to make it into a custom umpc. I tired altering the config.txt many times. I tried what is in this thread and also to change the device to hw:0,0 along with it but it still does not work. Switching with right and left keys does not work when trying to choose the device. I’d make a thread of my own over this but I’m not approved.

Also, I could not get the win7 computer I use to connect to it via ssh no matter how I tried using putty and such.

I’ve had this zero for several years but did not want to buy a more expensive pi until I got it working and I’ve yet to do so with the goal of moving on from android devices. For the past month or so I tried soldering a circuit to the thing to get sound to work and tried a bluetooth headset and also more than one sound card via usb. None worked out so far.

Do I really have to get the win7’s ssh working just to select audio via the gpio pins or the usb? My computer has me locked out of the bios boot order so I can’t use a live linux for it.


It works now randomly but this broke the gba.

Hey Just a thought. Have you tried SSH via Windows Powershell? It comes pre installed in 7 SP1 and up.

Same thing for RPI 3 inital audio setup. in some earlier builds I had to restart RA because the option was not allowing me to cycle through it.

I can’t use it generally. The pi zero broke it when I got a nightly version, now missing from downloads, and with another PC it has no wifi nor bluetooth nor wired connection to my working pc so I don’t see how I could remote control it with the SSH file nor anything similar to that.

The whole network demanding thing is why Lakka appeals to me in the first place after all with how I use a computer.

@full-pixel As for the Pi zero, If you use a Linux Distro, you can mount the partitioned microSd card and do some copy and pasting with files, unlike other OS’s that do not support EXT4 file systems. Even if you dont have any Linux OS installed on a PC/Laptop you can run them off of a USB without needing to install Linux.

Full Desktop showing Lakka OS being mounted via a USB Micro SD card Reader you can see the config files that you can edit in the file manager window