This new script runs perfectly in LibreElec and not in Lakka (solved)


#1

This new script (thanks SwedishGojira) runs perfectly in LibreElec and not in Lakka… why?

#!/bin/bash

rm Favorites.txt

touch Favorites.txt
chmod 777 Favorites.txt

for tagfile in *.tag; do
  romlist="$(echo $tagfile|cut -f1 -d '.')"
  while read line; do
    title="${line/$'\r'/}"
    grep "^${title};" "${romlist}.txt" >> Favorites.txt
    echo "${tagfile}"
    echo "${title}"
    echo "${romlist}.txt"
  done < "${tagfile}"
done

wc -l Favorites.txt

It also works perfectly in raspbian… its amazing!!!

Copying the romlists to /storage folder, in lakka, you can check the operation of the script, by ssh.

Romlists folder (with the script “fav.sh”):

(https://drive.google.com/open?id=13-LUJMbHDMuFzq62A8mS3jT1P8JHdasA)


#2

This script works as-is for me in Lakka, but first I had to convert your *.tag files to have unix line endings. One way is to use dos2unix:

dos2unix *.tag


#3

Why did you start another thread for this script? Just stay in one topic please.


#4

I’m sorry, I did it because the question is not the same. I had not tried LibreElec before. It will not happen again, my apologies.


#5

That is the solution. Thank you very much Metchebe. I did not know that dos2unix existed … Thank you both for your invaluable help.

The truth is that Lakka, with Attract-Mode frontend, is more colorful. I’m glad I succeeded.

And after testing it in retropie, batocera and raspbian lite, I can guarantee that where retroarch and attract mode work best is in Lakka. In a raspberry pi 3B +, of course…