Trouble using Lakka on Intel NUC (no sound via HDMI, no SSH)

OK, so I have a DN2820FYK NUC. My problem is that sound is coming out of the headphone jack as opposed to the HDMI out. I found this thread,, and was going to start working through the steps in it but cannot SSH into the box. Putty gives me a connection refused error.

I have made sure I am using the correct IP address. I can browse the shares using windows explorer but no SSH. I have installed Lakka saying yes to the enable SSH server prompt and also ignoring it, there is no change. I have tried both the latest stable and latest nightly image. Lakka-Generic.x86_64-devel-20150307205641-r20834-ge8d52d6.img.gz Lakka-Generic.x86_64-devel-20150522184504-r21017-gbddeb8b.img.gz

I even used a port scanner and it only shows port 445 open on my Lakka’s IP address. This would make sense because I can browse the shares.

I have even tried to change the command line options in the bootloader to make sure “SSH” is in the arguments but mashing TAB like a madman did not do anything and it booted into the GUI normally.

Does anyone have any ideas on where to go from here?

1 Like


When your system boots, hit the tab key. This will allow you to edit the kernel arguments.

You should have a word “ssh” in the line.

If not, add it and it will fix your problem.

If you already have ssh on the line, this mean that your filesystem may be corrupted. It almost never happens on PC, but it’s the only reason I can see.

So, to fix this, you have two choices:

  • reinstall lakka


  • plug a keyboard, add “tty retroarch=0” when hitting tab, boot, wait 10 seconds, hit ctrl+alt+f3 or alt+f3, login as root, remove the folders .cache and .config, and reboot
1 Like

Hi, I have a Intel NUC too,

The option “ssh” in the kernel arguments fix the command line access problem.

About the audio, you should edit this file and select the correct audio_device: .config/retroarch/retroarch.cfg

Look at the documentation here: and here:

1 Like

I did it!! this is the FIX for the audio HDMI on TV

  1. Enter via SSH with user:root and password:root
  2. systemctl stop retroarch
  3. nano /storage/.config/retroarch/retroarch.cfg
  4. set in line audio_device this: “hdmi:CARD=PCH,DEV=0”
  5. systemctl start retroarch
  6. reboot

Enjoy! :wink: