UEFI boot on Beelink Z83 (Win 10)


Hi everyone,

I recently bought a Beelink Z83 mini pc with Windows 10 to install Lakka, but the Bios is so basic that I cannont boot from usb. I tried use plop but it didn’t work at all (I had an error message with the installation).

The only other proposition in the Bios is the UEFI boot, so my question is: where can I found an UEFI lakka image to resolve my problem ?

(I don’t know if it’s a 32 or 64 bit UEFI) do I have to compilling myself, how can I do that ? Does the installation process still the same as classic usb boot ?

I saw this post on github : https://github.com/libretro/Lakka/issues/389 but it didn’t help me at all.

Thanks in advance for the help :slight_smile:


Well one place to start is to check what Windows 10 version is installed, Windows typically will be installed to match the UEFI regardless of the rest of the hardware. So If Windows is 32 bit, then the UEFI is most likely 32 bit. If it is 64 bit then the UEFI is 64, does that make sense?


I’m sorry I forgot to precise this in my post ^^, it is a 64 bit version of windows, so the UEFI does if I understand.



You can check with this Lakka uefi 64 bits version.


It works !! First I put it on a usb stick with UNetbootin and boot from a 3.0 port and it didn’t work : the usb showed on the boot list but nothing happened when booting from it. Now I’ve use win32Diskmanager, start from the 2.0 usb port and it works (the flower appears), Thank you so much !!