Ultimarc Mini-PAC and MAME

Has anyone got this to work with MAME 2010? I’ve tried everything I can think of and I can’t get player 2 to work. In game mode, Lakka recognizes two controllers and in keyboard mode, it recognizes the keyboard.

However, MAME won’t accept the input for player 2 in game mode. None of the buttons work in the MAME configuration menu (but some of them work in-game).

There’s a dumb bug/error in MAME2010 that was preventing a couple of P2’s inputs from working. It was fixed recently but there hasn’t been a new Lakka release to incorporate it yet. In the short term, you should try using MAME2003 or FBNeo if possible. I think there may also be a way to copy in the updated core through the overlay filesystem(?) but I’m not sure on that.

Thanks. That’s really frustrating, having spent so much time on it. The results made no sense. It must be in the MAME 2010 from Libretro because I tried RetroPie too and had the same issues.

Here’s the commit that fixed it, btw:

Note: it’s only buttons 5 and 6. The other inputs should be fine, AFAIK