Unable to Boot on PC

I’m completely new to Lakka and very new to Linux, so I’m hoping someone can help me out with getting my new computer up and running. I built a new computer, intending it to be a dedicated retro gaming box.

Install on a new HD from a USB drive worked easy, but I’ve been completely unable to do anything from there. I’ve finally managed to boot live from the USB with SSH so that I can get the error logs, but I’ve been unable to advance past the Lakka splash screen in either environment.

Here’s some logs!

Lakka (official): 2.2.2 (Generic.x86_64)
Lakka:~ # systemctl stop retroarch.service ; retroarch -v
[INFO] RetroArch 1.7.6 (Git ed5bd80)
[INFO] === Build =======================================
[INFO] CPU Model Name: Intel(R) Pentium(R) Gold G5400 CPU @ 3.70GHz
Capabilities: MMX MMXEXT SSE1 SSE2 SSE3 SSSE3 SSE4 SSE4.2 AES
Built: Mar 10 2019
[INFO] Version: 1.7.6
[INFO] Git: ed5bd80
[INFO] =================================================
[INFO] Environ SET_PIXEL_FORMAT: RGB565.
[INFO] Redirecting save file to "/storage/savefiles/.srm".
[INFO] Redirecting savestate to "/storage/savestates/.state".
[INFO] Version of libretro API: 1
[INFO] Compiled against API: 1
[INFO] [Audio]: Set audio input rate to: 30000.00 Hz.
[INFO] [Video]: Video @ fullscreen
[INFO] [Video]: Starting threaded video driver ...
[ERROR] [KMS]: Couldn't find a suitable DRM device.
[INFO] [GL]: Found GL context: null
[INFO] [GL]: Detecting screen resolution 320x240.
[INFO] [GL]: Vendor: (null), Renderer: (null).
[INFO] [GL]: Version: (null).
Segmentation fault (core dumped)

  00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:3e90]
        Subsystem: ASRock Incorporation Device [1849:3e90]
00:14.0 USB controller [0c03]: Intel Corporation Device [8086:a2af]
        Subsystem: ASRock Incorporation Device [1849:a2af]

Lakka:~ # aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=PCH
    HDA Intel PCH, Generic Analog
    Default Audio Device
sysdefault:CARD=PCH
    HDA Intel PCH, Generic Analog
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Analog
    Front speakers
surround21:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Analog
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Digital
    IEC958 (S/PDIF) Digital Audio Output
hdmi:CARD=PCH,DEV=0
    HDA Intel PCH, HDMI 0
    HDMI Audio Output
hdmi:CARD=PCH,DEV=1
    HDA Intel PCH, HDMI 1
    HDMI Audio Output
hdmi:CARD=PCH,DEV=2
    HDA Intel PCH, HDMI 2
    HDMI Audio Output

Lakka:~ # lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 1b1c:1d04 Corsair
Bus 001 Device 005: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 004: ID 0781:5575 SanDisk Corp. Cruzer Glide
Bus 001 Device 002: ID 8087:0a2b Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Any help someone could give me would be very much appreciated.

1 Like

This suggests that it can’t find your GPU. You said it works fine with the USB live environment?

Have you tried turning your computer off and on again? Also if you just built the computer, and the hard drive is new, you could always clear everything off your hard drive and start over.

It won’t launch past the splash screen at all. I don’t have a video card, just the integrated graphics Intel UHD 610.

That’s because the UHD 610 integrated graphics aren’t compatible. Yet anyway. Hunter was right. If you got an old graphics card lying around, or you could try one of the experimental builds that is designed to work with the Nvidia cards and see if that can bypass your segmentation fault. I doubt it, but it’s worth a shot.

Well, that’s super disappointing. I don’t know how I missed that information. Of course, maybe I’m an idiot, because I can’t even find the other builds anywhere on the site. Could someone point me in the right direction?

I don’t have an old graphics card, so if I can’t get an experimental builds to work, I guess I might as well just get Windows and install Retroarch. Honestly, I don’t really have the money for either option right now.

Thanks for your help.