Unable to boot - Stuck on flower screen


#1

I just grabbed an Intel NUC with a J5005 Pentium Silver CPU. I’ve tried both the latest official 2.1 release and the latest nightly builds of Lakka. Both builds work fine on my old Celeron NUC, but neither boot into Retroarch with the new NUC. Log below

Lakka (official): devel-20181002000707-r28220-g34ec56d (Generic.x86_64) Lakka:~ # systemctl stop retroarch.service ; retroarch -v [INFO] RetroArch 1.7.4 (Git 1155e11)
[INFO] === Build ======================================= Capabilities: MMX MMXEXT SSE1 SSE2 SSE3 SSSE3 SSE4 SSE4.2 AES Built: Sep 9 2018 [INFO] Version: 1.7.4
[INFO] Git: 1155e11
[INFO] ================================================= 
[INFO] Environ SET_PIXEL_FORMAT: RGB565. [INFO] Redirecting save file to "/storage/savefiles/.srm". [INFO] Redirecting savestate to "/storage/savestates/.state".
[INFO] Version of libretro API: 1
[INFO] Compiled against API: 1
[INFO] [Audio]: Set audio input rate to: 29970.03 Hz.
[INFO] [Video]: Video @ fullscreen [INFO]
[Video]: Starting threaded video driver ...
[ERROR] [KMS]: Couldn't find a suitable DRM device.
[INFO] [GL]: Found GL context: null
[INFO] [GL]: Detecting screen resolution 320x240.
[INFO] [GL]: Vendor: (null), Renderer: (null).
[INFO] [GL]: Version: (null). Segmentation fault (core dumped)

#2
[INFO] [GL]: Detecting screen resolution 320x240.
[INFO] [GL]: Vendor: (null), Renderer: (null).
[INFO] [GL]: Version: (null).

This is a problem. It means it’s not finding a video driver at all.


#3

I had a funny feeling. I’ve been digging around and it seems there might be some issues with the UHD 605 iGPU. Is there any way to force a driver?


#4

Internets suggest that you might be able to get coffeelake graphics working by booting your kernel with:

i915.alpha_support=1

I don’t know how/if you can do such a thing in lakka, but hopefully that gets you pointed in the right direction.


#5

Thanks for the heads up. By any way do you know if Lakka works with Gemini Lake and/or UHD 600? If all else fails I might have to get a different unit. Looking at a Celeron J4005 and can’t find any info on its compatibility with Lakka.


#6

I’m afraid I don’t know. Perhaps @gouchi has some guidance.


#7

@Frankenburger please provide graphic card log and try to use our nightly builds if you reproduce the issue.

Thank you.


#8

Hi. I’m trying to boot from USB on an old Netbook. Samsung N150 Plus. Currently running Windows 7 32bit, atom 450/GMA 3150, and 2G ram. Has anyone had any luck booting off of this weaker hardware? I will eventually get rid of windows as I only want to run Lakka on here.

Also, I’m primarily interested in Arcade and early console emulation so if it won’t run N64 games or higher I’m cool with that.

Any tips will be greatly appreciated.


#9

@Scott please provide Lakka system and graphic card logs and try to use our nightly builds if you reproduce the issue.

Thank you.


#10

Adding i915.alpha_support=1 to the bootloader config helped me with this issue. I have an Intel J5005-ITX with the same UHD 605 iGPU. This must enable the alpha video drivers - but it worked!!