Unable to save parameter changes in crt-pi shader?

Hi, I am using Lakka 3.3 on Raspberry Pi 4 and I don’t understand how to globally save a shader (crt-pi) with some parameter changes (the cushion effect at zero). I do this:

  • open a content
  • from the quick menu load the crt-pi shader, change the horizontal and vertical curvature parameters to zero and apply the changes
  • from the shader menu save as a new preset with the “stand-alone” option (I can’t remember the exact definition) as “crt-pi-flat”
  • then save also the shader as a global option.

Whenever I open a new content, the crt-pi shader is loaded but always with the cushion effect active, which I am forced to set to zero at each game. Also, if I try to load my “crt-pi-flat” preset it tells me that an error has occurred.

Am I doing a wrong procedure or is it a bug? Thank you so much.

P.S. as a video driver I am using Vulkan.

That procedure seems like it should work. Does it act any differently if you don’t do the “stand-alone” option?

also, can you get a log of when you try and fail to load that custom preset?

Thank you for your feedback. Even if I have enabled the “stand-alone” option, it seems that my new shader preset refers always to:

shader0 = crt/shaders/crt-pi.slang

So maybe it is a path problem, or the “stand-alone” option not working properly. I have set logging to debug level and the write-to-file option, but after the error I can’t find any log file in the logs folder. I’ll check again resetting Retroarch first.

Ops, fixed it! It was my fault: I had a shader core option (with an unmodified crt-pi) that was overriding my global option. Pardon me!

1 Like

np, glad you got it sorted!

I have another problem, not related to the topic title but maybe again I’m doing something wrong.

Since I’m using a HDMI to DVI adapter, in config.txt I have added the option hdmi_ignore_edid_audio = 1

But I can’t hear anything from the analogue jack. I’ve also tried hdmi_drive = 1 without luck. Thank you.

I don’t see any way to force using the analog audio jack via config.txt. I think you’d need to change the audio device at runtime within lakka itself: http://www.lakka.tv/doc/Audio-settings/

EDIT: this seems good, too: https://raspberrypi.stackexchange.com/questions/68024/audio-over-speaker-jack-in-lakka

Audio fixed! (first method) Thank you SO MUCH!!!


@hunterk I’d like to update LAKKA via online updater from 3.3 to 3.4. Will my retroarch.cfg (and thus also the audio source configuration) be kept? Thank you.

1 Like

AFAIK, yes. The in-app updater shouldn’t erase your configs.