Unable to upgrade. What is RPi2.RPi4?

I have Lakka installed on a RPI4, which shows the version as Lakka (official): 2.3.2 RPi2.RPi4.arm.

I tried to do the online upgrade to Lakka 3.0 (via the menu). It failed to find any images; it just shows an error.

Next, I tried finding a build to download and I see:

  1. Why are there two RPi4 builds?
  2. What is RPi2.RPi4? Is it RPi2.arm?

I tried RPi4.aarch64 and RPi4.arm. Both of those are incompatible, according to the installed Lakka.

That looks like the old stable version. I myself had used that for a while over a year ago but then it got surpassed by the progress of nightlies. I was told that I should update to the nightly builds from other users. I was using a RPI 4 4gb unit when I had that.

RPI4.aarch64 is the 64 bit version of Lakka OS for the Raspberry Pi 4. I cant comment on the stability and experience of it. I’ve seen comments that it was still a WIP (Work In Progress)

You can do what I did, I did a clean install of the new Lakka 3.0 stable version for the RPI4 assuming that you are using a RPI4 as your hardware.

Before I did my clean install I backed up my saves and thumbnails. As for My roms I keep them on a External Harddrive as a master copy when I only copy from when I need to. Kinda like a archive copy.

Edit: I wasn’t specific, I couldn’t upgrade from there so I had to do a clean install.

I tried a clean install (to another card) with 3.0 aarch64 and I still get an error when trying to use “Upgrade”. The network isn’t an issue - SSH, downloading artwork and other features work.

I’d still like to know what “RPi2.RPi4” means and if it’s still being built.

This is one of the responses for that rpi2_rpi4 stable 2.3.2 version “Version 2.3.2 is the last version on v2.x branch and is not destined to get any more updates”

Thanks @Joystick2600. At least that confirms the “RPi2.RPi4” branch is a dead-end.

So, anyone know why I am getting the error when trying to use Upgrade? It never gets a list of upgrade options.

I tried again, today and I was able to get a list. From there, I upgraded to the new 3.1 image.

I guess the problem was something on the server. It is fixed now!