USB controllers getting input delay/elongation intermittently

I’m using

  • RPI 4 2GB
  • an external USB HDD full of ROMs (no power-port so it’s drawing from the Pi’s power)
  • 3 USB-wireless “Logitech Cordless Precision PS3” game controllers (they work as standard DirectInput devices).
  • The main Lakka RPI4 image on the download page

Intermittently I’m getting input delay or elongation or just what feels like totally random bits of “your controller is stuck”. These controllers worked fine on my old Pi3b+/Retropie setup, but on that setup I was not using the HDD.

Has anybody seen this before? My current theory is that the HDD is flooding the USB port and starving the USB controllers, but I don’t want to rearchitect my whole ROM setup to test it, especially since the problem is intermittent and difficult to reproduce. Or am I running out of power? There’s no warnings or indicators about that.

RPis should show a lightning bolt icon in the corner if they’re running out of voltage. Really, I think the only way to troubleshoot your issue is to try taking a ROM and putting it on internal storage to see if the problem persists.

Yeah, I know the voltage complaint - I’m using the official power-supply and I don’t have the voltage bolt. I was thinking more a wattage problem, not a voltage one - not sure if that can get starved powering those 4 USB peripherals.

Anyhow, you’re probably right - move the roms to the microSD and try it there.

Following up on this if anybody hits the same problem: Yes, switching away from the external HDD fixed it. Behavior was pretty consistent. If I ran a game stored locally, everything was fine. If I did anything that caused the HDD to spin up, all controller behavior going forwards was flaky. I’m assuming it was a power thing.

Again, so I can see it when/if this happens again:

Is there any diagnostic info related to USB wattage available in LAKKA? wattage, not voltage (the Pi Lightning Bolt).

I think need moar powah. Need to find a spare powered USB hub to plug into this thing.

Not that I know of, no.