Vic-20 and Plus4 don't work on Raspberry pi 4 with Lakka

I use lakka for raspberry pi 4, but I have never been able to make the core work for vic-20 or for plus4, in any release, the only core of the “vice” group that works is x64, the rest is wrong. Is there a way to make xvic or xplus4 work? Thanks,…

It happens to me too. I don’t understand why they are included in the respberry distribution if they don’t work. The C128 doesn’t work either, as you say only the C64. I have only read your message now but if in the meantime you have found something I am interested.

What does not work about them?

Looks like Lakka uses a git commit from July, so not massively old, but still plenty of things have improved after that.

The only working core is c64. All the other commodore cores: vic-20, C16, C128 crash at the launch of any program, but they crash even if launched standalone with core launcher. I tried to add some files to the system/vice folder, even if they are not expressly required (kernal, basic etc) but the cores crash immediately. In other versions of retroarch (android and pc the ones I tried) the cores work normally. I have read posts of users who have working cores with retropie but it seems strange to me given the libretro architecture. Speaking of 8 bit cores also fused for the spectrum works but does not save in game or savestate.

Some minutes ago I launch retroarch with verbose option and when I run vic 20 core it show:

retroarch: symbol lookup error: /tmp/cores/ undefined symbol: vic20ui_init_early

Hmmm, that sounds like the build script isn’t doing proper make clean between different machines, so certain shared files will be at the first build, which is x64.

And there is no need for any of the system files anymore. Everything essential has been baked in the core for a while.

I tried to do an experiment on my raspberry with latest lakka. I downloaded this three cores from this page: / /

I created a backup of the three distributed cores and then substituted with the nightly ones in this folder: /tmp/cores

And everything works perfectly!


After some tests replacing the vic 20, the plus 4 and fuse with the night version works, but do not replace the c64 core because it will give a seg fault result even if you restore the original backup. So I repeat: don’t replace the core /tmp/cores/ or it won’t work anymore.