Vsync not working with Windows 10 1809 (Newest Update)


Vsync only work with picture errors (large slices in the picture) after installing the newest Windows Version (1809 - October Update) with the newest nvidia drivers. I use the Nvidia Geforce 1080 Ti with Intel 8700k.

On all Retroarch versions :frowning:

Please fix it

1 Like

Ok, after a 2 day search I finally found the problem by myself: the new high dpi setting mode from windows 10 1809 (october update) destroys the vsync mode in retroarch (at fullscreen). the way is to change the setting in the right-click menu of the retroarch.exe:

go to compatitibliy -> change high dpi mode settings -> overwrite dpi settings -> change it to system advanced

be sure to activate scaling to aspect ratio (with display) in your nvidia control panel (default settings) - otherwise it won’t be fullscreen.


you simply deactivate your dpi settings in the windows display settings menu and set it to 100%: go to desktop -> right klick -> display settings -> scaling -> set it to 100% (unusable for a 4k monitor because everything is far too tiny at 100%)

What a fucking mess -> thx to microsoft and the retroarch team for not supporting

(If you only have a lower 1080p Monitor, it won’t effect you at all. It effect you only if you activate in example 150% dpi at 4k in Windows 10 1809. The problem is very specific … )

hopefully some developer will see this monologue topic and decide to fix retroarch in the future. In 1 year, 3 years - who knows

@microsoft: you add 1 good feature in your updates and destroy 4 essential ones

1 Like

Thanks for posting your solution.

Dunno why you’re so salty at us. We can’t know every single configuration quirk on everyone’s system, especially when, as you mentioned, this is something MS fucked up in a recent update.

sure Microsoft fucked it up (like always) - but no one here at this forum responded after 29 days :-/ And this bug is hot

The October update was pulled since it was deleting some peoples documents, so I think very few have it yet.

Hi, I have also experienced this weird black screen tearing and parts missing that you have described and I’ve narrowed it down to an nVidia driver update. The last nVidia driver that works properly for me with Retroarch’s OpenGL driver is 411.70. Anything after that including the most recent 416.94 results in the same problem. I’ve tried using other Retroarch video drivers (API’s) and the problem seems to be limited to the OpenGL driver. I’m stuck on the OpenGL Driver because of the extensive period of time I’ve spent tweaking the Analog Shader Pack v2 *.cgp shader files to look just perfect.

I’ve tried your workaround where you suggest using the dpi overrides but to me that is unfeasible because RetroArch ends up looking extremely low res when I try that. The low res also messes up the scanlines and other shaders which is exactly what I’m trying to preserve.

The problem is very easily reproduced if anyone else needs to see it for themselves.

I’m running a dual nVidia Geforce GTX 1070Ti SLI setup with an Intel Core i7-5775c with 32GB DDR3 RAM on an LG 4K OLED TV.

Now its fixed (for me). No workaround needet anymore *Update -not working again

(with newest nvidia drivers 416.94 + newest windows 1809 update kbs + newest intel drivers + newest windows store updates -> updated gamebar + newest x64 retroarch nightly & cores)

SLI is another thing - can’t help u with that. You can try to reset Windows/ reinstall it or simply deactivate your dpi settings to the default 100% (I know, it hurts).

oh and you can try to activate the msi mode to your graphic cards through the registry. on a single card it brings wonders to any lag problems - perhaps it would be even better on a SLI-setup:

The most important registry tweak is MSI-mode. This improves responsiveness by allowing faster communication between CPU and GPU. To switch to MSI-mode, follow the steps below.

  • Here’re the instructions for the regedit step - Device manager / [your graphics card] / Properties / Details / Property: Hardware IDs / [Top value] HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI***\Device Parameters\Interrupt Management\ Create Key Folder, named: “MessageSignaledInterruptProperties” New DWORD 32-bit, named: “MSISupported” Set value to 1.

and I also recommend to deactivate the High Precision Event Timer in the bios setting of your mainboard, because its an older/sloppier mechanic than the newer software-event timer integrated in windows 10:

bios -> High Precision Event Timer -> set it to off


system -> device manager -> system devices -> High Precision Event Timer -> disable

and again not working… I hate this - and I don’t know why

only my workaroung works. WTF??? It came just randomly, out of nowhere

@Cyber do you use windowed fullscreen mode in retroarch? if so - thats explain why u have a lower resolution with my workaround

1 Like

@Silverbreaker Yes, I use Windowed Fullscreen mode in retroarch. I also tried disabling Windowed Fullscreen mode while trying your workaround and was elated when I saw the Retroarch UI return to its normal resolution, however this elation was short lived as once I went in game, the shader effects looked exactly the same as when Windowed Fullscreen mode was turned off. So for me the best workaround is to stick to 411.70 for now. NVIDIA is probably doing something differently with their newer drivers, possibly related to the new RTX cards that triggered this regression in RetroArch. If the RetroArch devs get on it, maybe they might be able to better understand the cause and see if they can implement a workaround on RetroArch’s side because it seems like waiting for nVidia to fix this might be a lesson in futility. I’m hoping for the best but with each nVidia driver update I try, same old same old. I think I have to take a look at the release notes for the driver after 411.70 or maybe someone could peruse the registry to look for differences in settings between the 2 drivers. Have any devs or anyone else been able to reproduce this issue? Is it just us alone? Maybe we can also try submitting this as a bug report to nVidia.

@Cyber do you use a tool like diskcleaner?

@Silverbreaker not really just the built-in Windows Disk Cleanup. I used to use CCleaner but it messed up some stuff once so I don’t bother with it anymore. Also my Windows installation is fairly recent. My Windows got messed up soon after the first buggy October Update was released so I ended up doing a clean install.

@Silverbreaker They’re also talking about this issue here:

Hopefully the threads can be merged.

I have transferd my shadersettings to slang and switched to vulkan (there are some alternatives to not available slang shader versions). It cost me one day but what will you do. Gl is clearly bugy now - vulkan on the other hand is very stable and fast (less lag). This solution works the best (for me).

@Silverbreaker This is the perfect workaround with no side effects (so far)!

You can go back to using OpenGL and have everything setup just like you had it before and use the latest nVIDIA drivers with this new workaround for the issue!

Download nVIDIA Profile Inspector

Then change OGL Buffer-Flipping Mode from OGL FORCE BLIT OFF to OGL FORCE BLIT ON. Don’t forget to click Apply Changes!

1 Like

nice workaround man! but I stick with vulkan - my shaders are now even better, less lag and it’s more future proved with slang shaders … oh and I can use now the hw psx core

Since , This is the only post that people are helping. I getting black screen after upgrade my HTPC ( I just added a Geforce 1060 6GB) .

Any thoughts ?

Black screen all cores with OpenGL after add NVidia GPU and 4K TV

If no one answers you it’s because no one has any answers to give. It doesn’t mean you should start invading other unrelated threads.

I am not invading “ master of genius “ ! Maybe my issue has some relationship . Simple If you don’t want help , please stay away from my comments!

First off, I don’t appreciate the attitude.

You might not have noticed that I run these forums, so I’ll just give you a warning about the “master of genius” bit, but necroing threads with unrelated posts is frowned upon everywhere.

If you can’t act with civility and obey basic forum etiquette, I’ll have to ban your account.