Which controller for Lakka?

After finding out my generic brand bluetooth controller is not supported by Lakka, I am now looking for a PS3/4 or XBOX controller as recommended.

My question is: will non-Sony brand PS3 controller work, or do I need an actual Sony brand dual shock?

I’m trying to do this as cheaply as I can (don’t want to spend $60 for a PS4 or XBOX wireless controller). I see numerous PS3 wireless controllers that aren’t actually “Sony” brand (but they are better priced).

I use a Wii U Pro Controller and love it.

I think it depends on what device you’re running Lakka on. I’ve used generic PS3 controllers on Lakka (x86) and they worked just fine. I’ve tried them on Lakka for an S905 box and they don’t work (https://github.com/libretro/Lakka-LibreELEC/issues/277). It would be nice if there was a list of known working controllers somewhere for each platform.

My system is running on a RPi 3

Well, I am happy to report that generic PS3 controller does indeed work on Lakka running on my RPI3. It was $29.99 at Walmart and works perfectly fine.

It uses a small USB dongle (I assume that’s for using with a PC as it is supposed to work on both PS3 and a PC). I plugged the dongle into my Pi, turned on the controller and it worked instantly. All the buttons were programmed correctly too.

If anyone is interested, the controller model is the “Afterglow” by a company called “PDP.”


In my humble opinion a Hori Pokken pro pad or a hacked PSP with a custom firmware and FuSa gamepad are the best ideas for retro gaming gamepads, the first has fightpad quality buttons and a good D-Pad while the former has a great D-Pad, good face buttons and amazing shoulder buttons

This is my setup and as you may see I am using a Raspberry Pi as well

Controllers compatible with Lakka: https://github.com/libretro/retroarch-joypad-autoconfig/tree/master/udev

Taken from Input Settings page here: http://www.lakka.tv/doc/Input-settings/

And of course, if you’re using a Raspberry Pi 3 and want to pair via Bluetooth: http://www.lakka.tv/doc/8Bitdo-Wireless-Controller/ – It’s for the 8bitDo wireless controllers, but the principle is the same for the Bluetooth controller listed in the top link.

@Shockwave thanks for that info, here are the configs for my two favorite controllers, wich I allready sent to the Lakka devs via mail


Be aware that the list might not be fullly accurate (especially, I feel, for USB adapters). I have the Mayflash Gamecube to USB adapter which is in the list but it’s not configured out of the box. See this topic for more information : Mayflash gamecube to USB adapter supported?

It is maybe pssible to use this

on Lakka?

If you don’t want to mess around, get a genuine Sony Dualshock3. There are plenty out there second-hand :slight_smile:

I use two different non sony branded ps3 controllers. They work reasonably well but the difference that I notice is that the menu button doesn’t work right away without mapping it as a menu button. One is a Rock Candy wireless controller (uses a dongle) and the other is a aPower branded ps3 tournament controller (really long USB wire on this sucker) The only gripes I have with these is that the rock candy doesn’t have any rumble and the USB one isn’t supported for rumble purposes in games that actually rumble. Either way though they are pretty accurate, especially the tournament controller.

Hi, i bought a couple of ps3 afterglow at walmart too. But they keep disconnecting every once in a while. Are these Bluetooth? I thought they worked over 2.4 GHz. Can i use them without the dongle if I’m using an hp chromebox that has Bluetooth built in? Thanks in advance for your help

I am getting along quite well with a Logitech RumblePad 2. It has a USB dongle on a long-ish cord with an LED in it.

Interestingly enough the LED blinks in time with Network activity on my MXQ HD18Q.

I’ve always just used a PS3 controller (Dualshock 3) and I’ve never experienced problems.

Hello i have a

QUMOX 2.4GHz wireless gamepad joystick joypad game controller for PC (doesn’t support win10) : Video Games it works but it seems it’s not mapped by default, how to do it?