Windows Nightly discussion thread


#241

ah, yep, here’s your problem: RetroArch [INFO] :: [GL]: Vendor: Microsoft Corporation, Renderer: GDI Generic.

You’ll need to install a proper driver, if one exists for your GPU. Make sure you have directx 9.0c installed from the web installer, as well.


#242

I’m running the windows 8.1 drivers. D3D gives me a black screen, yellow writing, and no cores start. But it does open.


#243

Are you sure that’s the problem?

Here’s the pastebin from 1.3.6, same machine. same retroarch.cfg.

http://pastebin.com/TYkPXZNt


#244

hmmm multi display laptop? 1.4.0 is running \.\DISPLAY1. and 1.3.6 running on \.\DISPLAY4. which seems to have detected suitable drivers.


#245

I noticed that!

But no, single screen laptop, (which only has VGA out) so I only use the inbuilt screen. I have had vga monitors hooked up to it at some stage to test, but nothing atm.

Ok, so, I went and deleted that (hidden) other display driver, and now 1.4.0 uses \.\DISPLAY4

but still crashes!

http://pastebin.com/tpbPJ94b


#246

are you just using the nightly releases for 1.4.x? try using that Retroarch.7z file instead to have full package and try running again… if it still detects you have GDI drivers, then its probable it cant run on your system.


#247

I got the retroarch.7z full package yes. And I tried from a new directory, with no retroarch.cfg or core-settings file. (Other than the defaults in the 7z) Same problem.

(Full packages and latest cores for both x86 and x64)


#248

ok, i dont have much to say. retroarch has evolved into 1.4.x and does not like legacy drivers in windows 10


#249

uh… you don’t have any driver other than MS basic display driver just install your proper GPU drivers.


#250

Right. Except.

The problem is, I do have drivers installed, and 1.3.6 uses it, but 1.4.0 doesn’t. Look at the 1.3.6 pastebin RetroArch [INFO] :: [GL]: Vendor: Intel, Renderer: Intel® HD Graphics. RetroArch [INFO] :: [GL]: Version: 2.1.0 - Build 8.15.10.2993.

1.4.0 pastebin RetroArch [INFO] :: [GL]: Vendor: Microsoft Corporation, Renderer: GDI Generic. RetroArch [INFO] :: [GL]: Version: 1.1.0.

Same drivers.

If 1.4.0 doesn’t work, it doesn’t work.


#251

Hi

In 1.4.1 (including latest nightly), my keyboard media keys for volume control do weird things in RA. Afaict theyre not assigned to anything in RA, so they should let me control sound voluem right ? But vol up is taking a screenshot (key for that is set to “NULL” in cfg), vol down (NULL as well) select next shader preset…

Thanks


#252

I am running latest RetroArch 1.4.1 on Windows 10 64-bit and I can’t load any content, it just says failed to load file: invalid argument. 1.3.6 simply crashes for me when loadng contents. Cores load and work just fine. Any ideas?


#253

The current MAME mainline and MAME 2014 cores are immediately crashing for me after loading any rom, with 1.41.

All other cores I’ve tested are working correctly (FBA, Nestopia, Snes9x, Genesis GX, Mednafen PSX, PC Engine, etc.). Debug log looks normal to me.

Definitely using the correct romsets (as well as trying multiple others). Tried nightly1.41 and stable 1.40 with the same results… MAME cores used to work fine on this machine until recently.

Windows 7 32-bit, Core i5, Intel HD Graphics.


#254

mame and mame 2014 should be working from last commits, since im using them a lot lately for some other tests. probably clear up you cfg files, some remaps etc.

else post logs so other can see what is going on…

(and i am using a lower gpu version than you so gpu should not be an issue with these cores)


#255

Hi, I have downloaded a full fresh nightly 1.41 + current cores, using default .cfg, and still run into crashing with MAME (same roms load perfectly with FBA).

Windows error reporting shows the MAME core as the source of the fault (e.g. mame2014_libretro.dll)

Here is the RetroArch log:

http://pastebin.com/vVMYMP7F


#256

my mistake… mame2014 seems to be broken… try using ume2014 instead if you really want to use the 2014 series of mame, else the newer mame_libretro(mame without number) which is version 0.182 should also work.

EDIT: turns out i was using an older build of mame2014 core from a previous test. you should probably redownload the core and make sure it did download correctly or just manually download it from buildbot repo.


#257

@Wertz Thank you for testing on your side.

I have downloaded the latest MAME cores (2014 and 1.82) via updater and also manually from the repo, and I’m still experiencing a crash on rom loading.

Not sure what else I can try at this point, as I mentioned MAME was working fine on my machine until recently, and all the other cores are working fine for me :frowning:


#258

test with ume2014, it should still work (thats mess+mame for 2014) if for some reasons that still will not work, something else is wrong

btw, what is the current processor(or cpu) you are using? the drivers are quite old( gawd i hope this is not pre-core series cpu)

else, try updating gpu drivers.


#259

Tried UME2014, it crashes as well.

I wonder in what way the MAME related cores are different from all the other cores? Especially considering the latest FBA runs perfectly for me.

The cpu is core i5 2.67 Ghz, so there should be no issue there. Intel GPU drivers are the last released for my system; they are older, but have been running MAME just fine up until now.


#260

ok if this is i5, then i dont think this is the latest driver version:

RetroArch [INFO] :: [GL]: Vendor: Intel, Renderer: Intel® HD Graphics. RetroArch [INFO] :: [GL]: Version: 2.1.0 - Build 8.15.10.2622.

get new ones directly from Intel and make sure its for the right microarchitecture (sandy bridge, ivy bridge, etc etc).

report back after driver update with new logs but use retroarch_debug instead of regular retroarch