Windows Nightly discussion thread


#261

There is something up with intel IGP and windows

BTW I think I finally fixed logging. If verbose is enabled it will open a console window. If it’s not it won’t. If you set verbose and add --log-file it will log to the file without opening a window, and if you run from a cmd it will use that cmd as a log.


#262

Thanks @radius, my problem seems to be a bit different in that I can load RetroArch properly, it’s just the MAME core giving me issues. It could be that the issue is just manifesting differently on my system though.

@wertz I did try updating with drivers directly from Intel’s site which were slightly newer (but still 4 years old, my core i5 is 1st gen mobile), and still no luck.


#263

are you by any chance using windows 10? if so then you are affected by that post of radius, else you are affected in a different way-specifically of the way the new 1.4.1 queries opengl features of gpu

setting retroarch video driver to d3d should help this if you wanna stay and use 1.4.1, else have to wait for this to be fixed or just use 1.3.6


#264

Some users report. Crash on windows 32bit for mame 0.182 maybe the pb is also on 2014.But i don’t have a 32b versio to test and debug.so i need a proper debug log (i mean debuger backtrace) before i can look at.


#265

I’m on Windows 7 32 bit, and I do get the crash in MAME 0.182 as well.

I see enough information here to believe that this is an actual issue and not just something wrong with my machine, so for now I’ll just wait to see if this gets resolved.

I’d be willing to help test if that would be useful.


#266

Please, please change the Mouse-Cursor-behavior of retroarch! If I come from launchbox, the cursor is every time visible in the game. Only if I press the Hide-Cursor-Hot-Key (F11), the mouse cursor disappears. It annoys the shit out of me - every time.


#267

I had the exact problem and made a thread about this some time ago, bumping it for some time. So i don’t think it’s a priority for the devs.

Your only chance to get rid of this is using RocketLauncher. Instead of loading the cores directly from launchbox, you can set them up in Rocketlauncher and then load that from Launchbox instead.

So instead of Launchbox - Cores, you add one more link in the chain so it becomes Launcbox - Rocketlauncher - Cores.

That’s because Rocketlauncher has a “hide mouse cursor” option. That’s how i did it and i got rid of the cursor.

Honestly, i don’t understand how this isn’t an issue for RetroArch itself. It should be easy to fix but then again, what do i know.


#268

I’m not experiencing any mouse pointer issues on the current build for Windows 64-bit. There was an issue a while back with the system mouse pointer appearing in fullscreen but Twinaphex pushed a fix for that and I have not seen it happen since then.


#269

I still have this problem but not with all cores. MESS 2015 and a MAME core from around the same period have this problem though. I’m not sure about newer or older versions. So it depends on the cores or their version. I got it fixed with Rocketlauncher.


#270

Mouse pointer is visible only if you enable and use overlays.


#271

Nope, it’s visible even when they are disabled in those particular cores.


#272

I don’t use overlays…


#273

MAME cores might still be using the system mouse pointer somehow, since they are shallow ports that still have much of the functionality of the standalone application built in.


#274

Can someone tell me what the correct way of updating RA is? I usually only update once every few months but I’m never sure which files to overwrite and which ones to keep for my settings. I’m guessing that even some of the config files may contain new settings so didn’t want to assume that I could just ignore them. Also, what about files that are no longer needed on newer versions like old dependencies?

P.S. I can’t seem to create a new Topic. Is that a new user restriction? :smiley:


#275

Yes, new users aren’t allowed to make new topics unless they’ve spent at least 10 minutes reading other forum threads. This is to encourage people to search for existing threads that answer their questions instead of asking the same questions over and over.

All you typically need to do is download the latest date-stamped nightly file (which is a much smaller download than the full one that includes all of the libs) and overwrite your retroarch.exe and retroarch_debug.exe files with the ones from the archive. However, sometimes we have to update the buildbot’s toolchain, which can introduce new/different dependencies. In that case, you can either also download the “redist” package that contains all of the required libs or you can download the full package and just move your config files and directories and playlists over to the new installation (you should be able to just copy the subdirectories [e.g., screenshots, playlists, etc.] from your existing RetroArch installation into the new one, merging and replacing any duplicate directories and files).


#276

Thanks @hunterk.

“just move your config files and directories and playlists over to the new installation”

I guess that’s the bit I’m asking for specifics on. What are the actual files and directories that contain my user info, controller, core and shader settings? As you said, ALL subdirectories?

Thanks for your help.


#277

Yeah, grab all of the subdirectories, e.g. assets, autoconfig, branding, cheats, etc., and then from the main directory, copy over retroarch.cfg and retroarch-core-options.cfg and, if you want to bring over your histories, get the content_image_history.lpl, content_music_history.lpl, content_video_history.lpl and content_history.lpl.


#278

Any progress on this issue?

I just tried 1.5 stable and I’m still getting crashes with MAME cores, as explained in my posts above. Is there any testing I can do to help resolve this?


#279

He needs a debugger backtrace. You’ll need to download gdb (there are Windows builds in 64- and 32-bit flavors) and then put it in your RetroArch directory. Open a command window and type: gdb retroarch.exe and then at the gdb prompt, type: run --menu --verbose Then run through the steps to reproduce your crash. With gdb, it won’t actually crash, it’ll just freeze, at which point you should go back to the command window and type: bt this should give you a backtrace that you can copy/paste to somewhere like pastebin and then post a link here with an @ to r-type to get his attention.


#280

@hunterk Ok, following your instructions above and then starting MAME within RetroArch still produces a crash; and the stack seems to be empty after closing the error dialogue (I couldn’t type into the command window while the error dialogue was open).

Here are the final lines from the command window (following the regular RetroArch output):

warning: Invalid parameter passed to C runtime function.

[New Thread 5584.0xfa0] [Inferior 1 (process 5584) exited with code 03] (gdb) bt No stack.

I’m happy to try to test this further, feel free let me know if there is a better place to continue than this thread.