Windows Nightly discussion thread


#281

An update to the above, using the MSVC build from @bparker solves this issue for me.

(For anyone wanting this build it is now inluded in the nightlies).


#282

hello, please fix the ‘mouse cursor will not disappear’-bug in cores such as genesis_plus_gx_libretro (Its not in all cores). And its even permanent after the start of retroarch (without even using a frontend like launchbox)!

it annoys really really bad!!


#283

Dolphin Core: I have tried different games and in all of them the same thing happens to me.

Video Driver: gl No sound/No video. The application window is frozen

Video Driver: Vulkan The sound is heard but the application window is frozen.

RetroArch nightly version 09/04/2017 08:40 Windows 10 (15063.14)/i7 4771 3.50Ghz/GTX 780M/24GB Ram/SSD 250GB


#284

retroarch need to fix the autosave on windows 10.


#285

there is no way to properly “fix” something if there is no detailed description of the problem and how to recreate the same thing.


#286

Not sure if this is the proper place to post this or not, but it appears that achievements are not linking properly right now for Mega Man X (U) (V1.1). This was the case when I tested both the Windows and Linux builds, using both the Snes9x and Snes9x 2010 cores. Here is the log information I’m seeing:

RetroArch [INFO] :: CHEEVOS testing SNES (8Mb padding) RetroArch [INFO] :: CHEEVOS getting game id for hash 107ec289a82bdd6be00ad5f627f116d3 RetroArch [INFO] :: CHEEVOS got game id 0 RetroArch [INFO] :: CHEEVOS testing NES (discards VROM) RetroArch [INFO] :: CHEEVOS testing Generic (plain content) RetroArch [INFO] :: CHEEVOS getting game id for hash 8998f2d66a84c1d44ab6387db7314efd RetroArch [INFO] :: CHEEVOS got game id 0 RetroArch [INFO] :: CHEEVOS this game doesn’t feature achievements

When using the same ROM file in RASnes9x, the achievements link properly. Other games appear to be working just fine, it’s just Mega Man X that seems to be having trouble for some reason. I have downloaded multiple versions from several different locations of the V1.1 ROM and all have had similar results.

Thanks!


#287

Make sure Settings -> Core -> Enable Hardware Shared Context is set to ‘ON’, and that you have the necessary files put into your system directory.


#288

yeah I noticed this too this week, I have only my shield at hand but I have it failing to get achievements, and/or crashing or printing garbage:

It’s weird, it used to work fine before…


#289

Running Windows Xp 32bit Downloaded RA 1.5 and msvc2010 package, standalone pack as well as only exes.

Here is the thing, RA 1.5 by default gives me “wrong parameter” error. I get the same error with nighties and msvc2010 however. If I use msvc2010 pack from this post , there is manifest file inside. If I take only manifest file and put it into RA root folder with msvc2010 exe’s and rename it to “Retroarch.exe.manifest” I can launch Retroarch 1.5 and actually play it.

The issue is that when doing so I need to disable avast since it will freeze PC trying to scan it, I also have crash when changing shaders or core resolution in game but that might or might not have anything to do with this file. The guy mentioned that wrong manifest might not work with latest retroarch version but I lack knowledge to make a manifest file myself so this will have to suffice for now.

Do you guys plan on supporting xp?


#290

Is there any way to get rumble working with a dinput controller device? I’m trying to use my Dualshock 1 controllers with Beetle PSX HW and it’s not registering. I’ve tried using x360ce to pass it through as a xinput device but that didn’t help.

The controller itself works fine but rumble is the only problem. I use it for Silent Hill speedruns to gauge my health so I don’t waste time opening the menu to check. Rumble works fine in other emulators and PC titles so it’s not my drivers either. I really want to use RA as my main PSX emulator but this is throwing me off if I can’t play as accurately as I normally would.


#291

We don’t have rumble support on dinput.


#292

Oh well I guess that solves my issue :frowning2:

Is it a planned feature or is just impossible to implement altogether?


#293

It’s probably just a couple of lines of code but I don’t think there’s much interest at this point. If I could I would add it.


#294

Hi, I’m posting here because I don’t seem to have the ability to create new posts yet. I saw a couple problems with some of the latest windows builds of the cores:

In all cases I’m using 1.6.0 for win 7 64bit and the latest as of 6/4 versions of the cores.

Mupen64 (non-Parallel): Core loads games but does not show any graphics. Sound is audible so it sounds like a graphics issue. Reverting back to my old July 2016 build of the core fixes the issue so it’s something post then.

Beetle-PSX (non hw) Core freezes and crashes during loading of the bios when you boot a game with the -c command line option to load an external config. Note that all other cores seem to be working fine with -c, I can load psx fine when I don’t use the command line (aka double click icon and load from menus, and that copying over my default config to another location and then using that with -c still causes the issue.

Anyone else having these issues?


#295

mame_libretro.dll

pcsx_rearmed_libretro.dll


#296

mame 32bit does is not working pcsx is not for windows.


#297

wertz works in 64 bits ?


#298

Latest nightlies won’t launch, they say libass-9.dll is missing.


#299

download the new redist package from the buildbot and then copy all of those dlls into your RetroArch directory, overwriting any conflicts.


#300

Are there any tests in input lag comparing the new direct input driver with other ones? I’m using xinput and would like to know if it worth it trying out dinput.