[WiP] Adding Cheat Support to more cores


#81

If it’s a crash upon actually loading the files, I can’t replicate it. Same with hitting the apply button with either cheat file loaded. Granted I don’t have copies of either of those games on me at the moment to test if the cheats apply properly, and I’m testing on a Linux 64-bit build from source. I can test those two games on Windows in a day or two.

You said that it crashes on load, but I need to confirm when exactly this happens. Is it right when you select the file? Is it when you hit the apply button? Or is it when you exit the menu to resume the game? Also, if you do not have “Pause when menu activated” enabled, can you enable it and try again?

If the crash happens when the cheat file is selected, confirm that the file name has no special characters. That shouldn’t cause any issues, but I want to rule it out.

What bothers me is that the only known way cheats can cause an emulator crash is if, on pressing apply and resuming gameplay, the cheat causes the game to crash so spectacularly that it takes the emulator with it. I cross-referenced the cheats in your post and confirmed that they are correct for what they’re named, so I doubt that is what’s happening.


#82

The crash happens right when I select the cheat file. I never even get the chance to hit the apply button. “Pause when menu activated” is enabled on my end when it happened. There are no special characters in the file names. The file names for the two cheats I provided are “Final Fantasy VII.cht” and “Parasite Eve.cht”

Here are the steps to reproduce if they help:

  1. Load the “Beetle PSX HW” core (Though I tested it with other cores, and the same crash happens)

  2. Select “Cheats” under “Quick Menu”

  3. Select “Load Cheat File”

  4. Select and confirm the cheat file to be loaded

I really doubt it’s a problem with the games themselves, since this happens even when loading a cheat without a game playing in Retroarch itself.


#83

Hi there

From what I’ve read so far, cheat support seems to be very much biased towards consoles. What about microcomputers? Many of them had devices which could insert POKEs into memory in order to cheat at games - for instance the Multiface devices for Sinclair/Amstrad computers (https://en.wikipedia.org/wiki/Multiface) - would this sort of thing fall under the cheat system, or am I barking up the wrong tree?

Cheers


#84

Since virtually no cores had cheat support till you stepped in, it’s a safe bet that “whoever” is probably either you or no-one…

:grin:

EDIT: no issues with Beetle PSX HW here - just loaded Crash Bandicoot with cheats and all worked fine (build 815feba). Maybe an issue with your cheat files? Perhaps the encoding (mine are UTF-8).


#85

I updated Retroarch to the latest nightly build, and the cheats now load without any problems! Don’t know what was causing the issue, but it seems to be fixed now. Thanks for the help in looking into it, though.


#86

Hoping Virtual Boy Cheats will also be implemented. I swear there was a VirtualBoy Emulator that was released that had this ability. It had Cheats and they worked. I think it was for the Wii. In case there will be, I have tried taking Cheats from rdragon and using them in RA VB Core, but it crashed on me. Here are all the Codes in the .cht File of rdragon:

{ Title: Galactic Pinball

CT: Infinite Pucks CC: 0-0006F30-0009

CT: Bonus Game CC: 0-0004F80-0005 }

{ Title: Jack Bros

CT: Infinite Time CC: 0-0000112-0046

CT: Invincible, etc. CC: 1-0000150-FFFF }

{ Title: Mario Clash

CT: Select Any Level CC: 2-00E7A26-0063 CC: 2-00E7B02-0063 }

{ Title: Panic Bomber

CT: Debug Mode CC: 3-00006B4-00AC CC: 3-00006B6-9403 CC: 2-000090C-0020 CC: 2-0000958-00A0 CC: 2-00009B6-0040 CC: 3-0000D0A-F8A4 CC: 3-0000D38-F8A4 CC: 3-0000D64-F8A4

CT: Stage Select CC: 3-00006B2-E841 CC: 3-00006B4-02AC CC: 3-00006B6-4C79 CC: 3-0028000-E4D1 CC: 3-0028002-D6A6 CC: 3-0028004-E141 CC: 3-0028006-E4D1 CC: 3-0028008-F8A4 CC: 3-002800A-1F18 }

{ Title: Space Invaders- Virtual Collection

CT: Infinite Lives CC: 3-000D326-4045 }

{ Title: Space Squash

CT: Infinite HP CC: 0-0000130-0004 }

{ Title: Teleroboxer

CT: Infinite Health CC: 0-000477C-007F

CT: 1-Hit Knock Outs CC: 0-0004780-0001 }

{ Title: Vertical Force

CT: Debug Menu CC: 2-000B330-0022 }

{ Title: Virtual Bowling

CT: Debug Menu CC: 2-0003EFA-0041 }

{ Title: Virtual Boy Wario Land

CT: Infinite Time CC: 0-00087AA-00B0

CT: Infinite Lives CC: 0-00087A4-0009 }


#87

@Offline am itching to have cheats in Beetle Saturn now. Would a bounty arouse your interest in implementing them?


#88

My Wishlist would be PC Engine/Turbo Grafix, The Virtual Boy and Maybe Dreamcast.


#89

PC Engine/Turbo Grafix cheat support would be great. Is it worth starting a bounty to try help this happen?


#90

I have put $5 in to a Bounty for cheat support to be added to Beetle PCE Fast:

Links:


#91

pce cheats? in what format? from what i gathered since there was no official cheat device for it, people have been using ips patches. forgot the link but that should be out there…


#92

Mednafen for PCE on windows has cheat support. Not sure if it is using IPS patches or another format.


#93

Thanks for the information does that include cheat support for PC engine CD games as well?I do use IPS Patches I have a guy that makes them for me. I’m just hoping for the future that if it’s supported on Windows not sure why you can’t do it on the Raspberry Pi core?


#94

@offline if you have the time, can you take a look at vba_next? cheats does not work.


#95

Can anyone point me the direction to make these true widescreen cheats work in Mednafen PSX on Retroarch?

The pack comes with tons of TXT cheats with codes like this:

Widescreen hack by El_Patas [España] $SAFEMODE

#Tenchu 2: Birth of the Stealth Assassins [NTSC-U] (SLUS-00939)

GAMESHARK/ACTION REPLAY CODES

//Widescreen 16:9 800CD358 0C00

//Eyefinity //800CD358 0400


#96

Suggest Cheats be added to FBA2012 Cores and ReDream


#97

talk RobLoach to port cheats MAME or kawaks in to retroarch


[Bounty $10] translate mame2003-plus cheat.dat to RetroArch cheats
#98

@Eignar17 - The problem is, the Cheats would not work. They would need to be correctly Adjusted +/- 1-3 Digits. I replied to your Post on the Github Page with my Link. I focused on the Games I have, but you should get the idea of it.

Also, you would have to remove the xFFxxxx from the Code and replace with x00xxxx . The Addresses are also limited, depending on the Game.

For my example, I will use SFA, FBA Cheat File (same thing applies to MAME, CPS2PSP Cheats as well)

cheat “Infinite Time” default 0 0 “Disabled” 1 “Enabled”, 0, 0xFFAE09, 0x63

cheat “Infinite Energy PL1” default 0 0 “Disabled” 1 “Infinite Energy PL1”, 0, 0xFF8441, 0x90 2 “Energy always set to 0 PL1”, 0, 0xFF8441, 0x00

cheat “Infinite Power PL1” default 0 0 “Disabled” 1 “Infinite Power PL1”, 0, 0xFF84BF, 0x90 2 “Drain All Power Now! PL1”, 0, 0xFF84BF, 0x00

Now, here was my results for RA Cheat Search (for the way it is built, I will shorten it)

Inf Time - 00AE08 - Same Values applied

1P Inf Health - 008440 - Same Values applied

1P Inf Super - 0084BE - Same Values applied

Speaking of Arcade, I was also able to get NAOMI Cheats made for a few Games. Good luck finding a few others.


#99

view your interesant code gives an idea on which way to go


#100

@Eignar17 and @Smoker1 I have been inspired by your recent posts to start a bounty to convert mame2003-plus cheats to RetroArch format: