[3.6][pc] Scanning ZX Spectrum Games with FBNeo

I would like to play some of my old ZX Spectrum games but having issues detecting them. I have renamed a couple of my games to “spec_” (removing the extension) and even renamed the folder to “spectrum”. Each time it reports “No valid content detected”. I’m doing this as a manual scan using the Spectrum dat file. Any ideas what I’m doing wrong?


Your romset doesn’t seem to match the DAT file. You need an fbneo romset that’s suitable. The "“FinalBurn Neo ROM set (2021-12-05)” one should work.

FB Neo plays Zx spectrum games? Isn’t that for Neo Geo or am I missing something?

Thanks for the suggestion RealNC. I’ve just downloaded this file (or rather spectrum.zip). These games are in zip format. Is that correct? Having used the dat file (for spectrum), it is reporting that it is in the wrong format.

Should I be using this dat file? I would prefer the friendly name rather than actual filename.


Ok i checked it’s info file and reports it should work with zipped zx spectrum games, so i really missed that. Only thing it should have the spectrum roms inside a folder named fbneo

Yes. Do not extract the game zip files. You probably didn’t download the DAT file correctly. Maybe you used wget to get something from github. This doesn’t work. You need the proper download link. You go here:


And then click the “raw” button. This will give you a proper download link for the DAT file.

I just tried it myself, with the manual scan configured like this:

And it just worked. I now have a spectrum playlist with all games.

Now, with that being said, is fbneo good for Spectrum emulation? There’s a dedicated Spectrum core called “fuse.”

Thanks DariusG. I think the fbneo folder may be for the BIOS files, which the Spectrum has 2 of. Just trying to locate these files.


I’m sure I went back a level from that link, selected spectrum dat and then right-clicked and save as. I didn’t seem to be able to do anything from the raw button. Would I need to select all, copy into notepad and rename?


No. After you open the raw file, you just right-click and do “save page as” in firefox.

1 Like

Bingo! :+1:. My DAT file was 8MB :open_mouth:. Downloaded from Chrome (as you said) and only 8KB. Playlist now created but unable to run any games. This may be because the BIOS files are required.


Yes. Just do “Load Core” to load fbneo without content. Then “Information->Core Information” and you’ll see a list of which BIOS files are missing and which are present.

It is actually very good, but also intentionally inaccurate about the buzzer sound which might not be to everyone’s taste, see my news about it : https://www.libretro.com/index.php/final-burn-neo-1-0-0-02-release/

Spectrum BIOS files now in place and recognized by RetroArch but still not loading anything :(. Have removed anything related to Spectrum in save states/config files but same issue.


No white screen with error message ? Nothing in logs either ?

No white screen or anything useful (warnings or errors) in the logs. Have tried switching off auto save/load states but didn’t make any difference.


You should enable logging in Settings->Logging. On Windows I think this will open a CLI console when you start retroarch that prints log messages.

Logging has been enabled for both frontend and core (both set to info) but doesn’t show any warnings or errors. Oddly, on my main workstation (Ubuntu) using RetroArch (flatpak), FBNeo does show a warning (white screen) using these same roms. Seems to be an issue with each of the roms, although they play fine using Fuse.


It seems there might have been some miscommunication about the main usage of the dat files, please read https://docs.libretro.com/library/fbneo/

Looks like the DAT file is ok. My problem was that I was putting the roms back into my “ZX Spectrum” folder rather than “spectrum”. Games now appearing and most loading ok but my issue now is that I can’t get past the title screen.


Afaik, title screen navigation usually requires keyboard usage on zx spectrum. The keyboard is mapped to player 3 btw, supposedly you can remap keyboard keys to gamepad buttons through retroarch’s menus if that’s what you are using.