Core and Feature Requests

I assume you either did not understand what I’ve said or you do not know what you are talking about. You showed us systems supported, kind of, by RetroAchievements. By what I meant, systems people can develop achievements for. I am talking about completely different thing.

Just to update this topic, I created feature request on retroarch github:

Another request here for Hypseus Singe. Someone earlier mentioned Singe 2, but Hypseus supports all the Daphne, Singe 1 and Singe 2 games now, including the 32bit full overlays, and enhanced games, that Singe 2 introduced.

It would give emulation and simulation of all the available laserdisc games needing only one port.


I think this would be a great core too, we just need to find someone who wants to make it.

In the meantime you could try the WindowCast core to push the output of any window in windows through the retroarch shader pipeline


So I have been using Retro Arch for a while now, and occasionally check to see about an original Xbox console core. I have pretty much every game I own loaded up and play this or that on my computer, but not my Xbox games. Provided there are not many, but I would like to access them without dragging out that box upstairs and digging through whichever one the games are in…is their a core in any progression being worked on for this console?

Many use Retroarch to watch 4:3 videos, I also know that it can be used as an image viewer and music player with the ability to replace in-game music and so on. A great addition to RA’s multimedia capabilities would be to read CBZ, CBR and PDF files. I came across this idea someone posted, it could be used to load manuals, maps and so on.


8 posts were split to a new topic: [Android] core keeps disappearing

There is some work being done for an STEEM SSE libretro core (Atari ST emulator)

There is a core download here


Great. And by Mr. Seagal himself, I hope it gets closer to standalone than the Hatari core.

1 Like

I’m wondering if the dust emulator for DS might be a valid core option, it seems to have wgpu for 3d acceleration, including scaling and I wonder if that might work with libretro

Supermodel would be great if it did happen eventually. I always wondered why it was abandoned. Was it that hard to port compared to all available cores?

Ares is also a very important emulator that needs to be in RetroArch. At least it’s N64 and 32X cores.

I have mentioned this before in the past but i think RA needs a way to automatically enable/disable Freesync/Gsync support when needed.

This is useful for those with multiple monitors. You see, if you have “Sync to exact frame rate” enabled, the scrolling will stutter on a screen that doesn’t support freesync. And if you have it disabled, it will stutter on a screen with a high refresh rate.

So i suggest an option for this to be automatic/manual. But how can RA detect if a monitor supports freesync or not? It doesn’t have to. IMO, it only has to detect the refresh rate. If it detects 120hz or more, chances are this monitor/TV has freesync. So it can enable it automatically. And if it detects the standard 60hz, disable it.

Now, not all high refresh rate monitors support freesync and some 60hz ones do. But i think these are more obscure cases and in the end, you will still be able to disable automatic switching and do it manually as you do now.

Recently, there was a hotkey added for this. But i don’t think it works consistently and you still need to do it manually on a keyboard, which is not great for a couch setup.

Hello, I’m new. I apologize if this was already suggested, but I’m requesting this because SNES performance on the PS Vita could use improvement, especially for games that use special chips.

Could someone on the libretro team please see if it’s possible to compile Supafaust ( to Vita Retroarch (and Piglet too)? The minimum specs noted on the README are a dual-core ARM CPU at 900MHz (the Vita is at max 500), but Supafaust supports more performance on quad-core CPUs. The 4th core on the Vita is normally restricted, however when modded with CapUnlocker, that restriction is removed. Thank you.

where to download latest Libretro cores for arm7 ?


I have a suggestion for the PUAE Amiga emulator. At the moment I consider PUAE by far the best way to play Amiga titles but with the exception of one area and that is it is just about impossible to run a workbench disk and have a hard disk folder attached unless you know how to script a config file (.uae) or compile a WHDLoad file yourself.

While it is rare anyone might need this, especially if you’re using WHDLoad most of the time, there are a few cases where some titles will simply not run without this function as they can only be run from workbench.

This can be done fairly easily in WinUAE, but if course WinUAE doesn’t do CRT emulation the way Retroarch does :wink:

This and the lack of native RTG support (maybe it does support it, but it’s not shown in the core options) are my only gripes about this core - it has an incredible amount of options and compatibility with titles, and just makes the whole process so much easier.

This has about come from trying to find an alternative solution to this request - Libretro-uae 2.6.1 (nee puae) segfault with SCSI

Another possible solution is - but not having much luck with getting it running this way so far.

1 Like

What do you mean “impossible” when there is a core option called “Global Boot HD” designed precisely for that…

1 Like

Tried that multiple times - depending on the title or format, it will present an error message usually xec.library is required, or Not a DOS disk in device BootHD or take you directly to AROS where it waits for media which you can’t load in.

That function isn’t well explained and I haven’t found any guides for it so far, I’m sure some have mastered it, but I’ve not had much luck with putting it to use.

What I am able to do with that is load a workbench.adf with Global Boot HD turned on with Files and it will show Boot HD as a disk but it’s empty and doesn’t allow you to load anything in.

Any tips on how to get that working? Keep in mind the original file doesn’t contain a .slave file.

Could it be possible to set up a .M3U with the workbench adf and perhaps the original zip file or unzipped HD folder? or .uae file? I’ve tried a few things but with little success.

My suggestion for the core is due to not being able to set up multiple files in the core settings. You have add a config file which can be complicated to edit.

It is supposed to be used like with real hardware, as in it simply is a blank hard drive that you must install Workbench into in order to make it usable. Of course there can’t be anything pre-installed. Simply boot with the Workbench install disk while the option is enabled, let it install, and then launch anything else, and it will boot from the HD unless the inserted disk is bootable, which you can always eject. And you can insert floppies via Disc Control even when booting hard drive images.

And AROS has absolutely nothing to do with anything if real Amiga Kickstarts are in place.

What even is the actual exact goal here? Pretty sure you don’t want to run Workbench inside WHDLoad.

It’s for games such as Tales of Gorluth 3. The developer is not producing a WHDLoad, the file does not have a .slave. It’s a zip but not LHA (it doesn’t work even if you convert it to an LHA - tried that). Unzip it, and you find it’s a Hard Disk Folder, not ADF(s) and not a Hard Disk File (HDF).

It doesn’t run unless you load workbench first, and I can do that from an adf, but I can’t then load the folder into that environment. I’ve tried putting it into an LHA so it’s in the same container as the ADF, but I can’t load it as it can’t see the executable only the .info file, which it can’t seem to load from in this case (no slave file). If the title was an ADF I could load it into workbench by disk swapping, but not as a HD Folder.

WinUAE will do what I mentioned above and loads successfully, as you can attach an adf and HD folder and then boot. PUAE won’t do that.

Many titles will run directly from HD Folder in PUAE providing they have all the needed components built in, it’s just that some of them won’t and require workbench.

So that’s the reason for the request. I was hoping to find an easier way to do this.

As an outcome, I’d like to get the title running in PUAE - I think the best way to do that (now) is either is to figure out how to configure a .uae file to run this (adf + HD Folder) or to Frankenstein a Workbench WHDLoad which contains WB3.1 and include the game as part of it’s directory.

I’m not a coder and while I can do a few things and figure a few things out, this has gone beyond my level of expertise and I’m looking for a solution or a guide - perhaps some steps for what to include in a .uae and a template to work off, or some steps on how to build WHDLoad and where to put files in the directory before building it into a LHA file.

Ok, well I’m not buying it for testing it, but I’m pretty pretty sure you can launch it with the method I suggested. Extracted directories can be used as content paths when using CLI, and they will be used as a hard drive. Same thing can be achieved via the menu by launching the directory info file.

There is no need to worry about the format of content, since in the end non-floppies and non-CDs will be seen just as hard drives, and there can be multiple hard drives easily. You can also use a M3U for having multiple hard drive images all inserted at once.

Ok - your not buying it that I tested. Could you describe a situation where someone would detail this without testing, or a reason why anyone would bother to ask otherwise?

I’ll accept the possibility I may be wrong and could have missed something, which is why I’ve asked for some assistance, and also I’m quite happy to share screenshots of the process when I have some time. I haven’t followed a testing script if that’s what you’re implying (and why would I at this point?)

I’m pretty pretty sure you can launch it with the method I suggested

Workbench? - I believe you and that likely works with other titles. But have tried every file in the folder and it will either not see some of the files or won’t load them this time around, so perhaps this is an edge case.

Extracted directories can be used as content paths when using CLI, and they will be used as a hard drive. Same thing can be achieved via the menu by launching the directory info file.

Tried both methods - doesn’t load, I’m sure it might in other cases.

and there can be multiple hard drives easily. You can also use a M3U for having multiple hard drive images all inserted at once.

Ok - how does that work, do you have an example I could work from? I’ve tried setting up an M3U file with an adf and with the folder, and then with the info file but with no success. I have M3U files set up for a few adf’s and they work fine - what needs to be different? Should the M3U be a single format - i.e. Hard Drives only?

Last thing - am I wasting my time here? When was the last time anyone responded well to - I don’t believe you…? You’ve provided some decent insights so far into how this thing works, but will stop posting and go elsewhere if that’s the general tone.