Crt-Royale Kurozumi Edition Help


#222

It’s like hunterk pointed out, basically look at the post from may 4th for reference! If you don’t look close it’s kinda “the glow is missing”, otherwise there’s not much wrong. Personally i prefer cg, but i’m kinda nuts/crazy about the little details :innocent:


#223

Does my picture look OK? In some of the pictures you can see the individual pixels when you get up close (those thin vertical pixels that the PVM is known for). I can’t see those in my version.


#224

Looks like 1080p, right? At that res, you can faintly see them (they just look like jaggies in the blue sky) but they won’t be very visible below 4K res.


#225

1440p actually. But still, definitely not 4k. Is there any setting I could tweak to make them more visible below 4k?

Edit: after reading further, it seems that perhaps lowering 'mask_num_triads_desired = “900.000000” ’ might have the effect I’m looking for? It wouldn’t be as accurate, but it would get the look I’m going for. Maybe I’ll try 800 tonight.


#226

Hi there, sorry for the late answer, pretty busy here.

look for mask_triad_size_desired . Default should be 1, if you bump that up, it’ll look more coarse, until you can see the individual phosphores. At 1440p the value 3 should be the first one, where you can see the individual phospores evenly i guess. But that’s the parameter you are looking for. If the bloom doesn’t work for you on a mask that coarse, try a mask_sample_mode value of 1 instead of 0 .


#227

First of all, thank you to Kurozumi for creating this amazing shader!

Now to my question. I am having difficulties in getting the shader to look like what was shown much earlier in this thread:

I am specifically trying to recreate the vertical lines going through the image, which create a subtle and nice grid th the image. The same poster showed how the real-life PVM looked:

I love how the pixels are broken up vertically. However, I cannot seem to get this result of such a “vertical grid type image” to the Kurozumi shader. Instead, there is only the horizontal scanlines, with no grid coming through (in the normal preset).

I have messed with the settings of “mask_triad_size_desired”, and changing it to 3 is the closest I can get. But this instantly makes the grid too apparent and “too much”, which takes away the original horizontal scanline-effect. Am I trying to achieve the impossible or am I perhaps using the wrong settings somehow? The first image I reposted above does seem to indicate that it should be possible to achieve (but a lot of other images posted in this thread looks just like my results).

I am using both a 4K and a 1440p-screen, with integer scaling on, with no luck on both displays.


#228

mask_triad_size_desired

Make sure you use “interger sacling” in video settings and integer number of mask_triad_size_desired like 2.0 or 3.0.

Moreover, the bigger “mask_triad_size_desired” you use the lower “bloom_underestimate_level” or “levels_contrast” have to be to not overblow the whites.

I would also change “convergence_offset” all back to 0.00.


#229

Hi, I got scanline judders on specific native-resloution games. Say with Mednafen PSX HW core, games like Dead or Alive 1, Tekken 3, when using Kurozumi, the scanlines will juddered on those games; and some other simple/slightly CRT shaders, like crt-aperture it shows ueven scanlines. I tried changing video options, like Integer Scale ON/OFF, Aspect Ratio but nothing helped. So is there any fix around here? Thanks.


#230

Those are interlaced games. The juddering is how 480i content looks as compared with the normal “240p”/doublestrike content that you normally see in old games.


#231

Yep, as hunterk said, the judder your see is exactly what you’ll see on a CRT with 480i interlaced resolutions.
This is yet another very accurate CRT emulation feature CRT-Royale has.


#232

Thanks @hunterk, @James-F. Now I get it.


#233

Thanks for answering the questions @hunterk and @James-F , i’m really busy workwise, not much free time to check forums and stuff right now! :blush:

@Puxirepublic : if a core has the option to force 240p (some n64 f.e.) then you’ll be able do get rid of the jumpy look, if that disturbes you.

@DatMonkey : Try to set “mask_specify_num_triads=1” and set “mask_num_triads_desired=value_you_like” (800-1000 should usually give you a desired look). The problem with this method is kinda, that it can look uneven or break the look sometimes, as it ignores the integer Values of “TV-lines” that will fit into your resolution. Best way to find your value is to use “Preview Shader Parameters” as it will refresh the look in real-time with the value you are changing!

For mask_triad_size desired method: If i recall correctly a value of “1” should be good, if the resolution is <2160p, if it’s 2160p a value of “3” shouldn’t be that far off… General problem is, the displays we usually have (at PCs i guess it’s mostly 1440p right now, if the Monitor is new), is the resolution isn’t high enough yet, to display the TV-Lines in it’s full glory. 2160p is the only resolution you’ll kinda able to see TV-lines/individual phosphores in a BVM kinda look.

Comes time, comes resolution, comes awesome BVM look, 'nuff said! :joy:

:+1:


#234

Thanks @James-F

@Kurozumi : Thanks, I finally got it looking nice after having discovered that Retroarch wasn’t running in 4K resolution because I had set WIndows’ size of text to 200% in WIndows Display Settings (because running at 100% with a 4K screen makes the desktop hard to work with) - however, when I changed this to 100%, Retroarch finally seems to be running at a native resolution 4K. And with mask_triad_size desired of 3 the image is looking very nice indeed :smiley:

I have one more question though, regarding “integer scaling”, “crop overscan” and how to get the “correct” 9x integer resolution - when I run some games, for example Yoshi’s island in BSNES core, the screen doesn’t fill up the entire 4K vertical space leaving some black space under and over the picture - but when I run Super Mario World 1, the screen fills up the entire vertical space. Is this how it is supposed to be? I just want to make sure that I am using the “correct” highest resolution possible in order to get 9x integer scaling to work as it should. Going through all the settings I see that there is a “Crop overscan” option both in Retroarch’s Video Settings AND in the BSNES core options. What is the “correct” combination of these settings to achieve proper 9x integer scaling on a 4K screen? Right now I have “Crop overscan” set to “Off” in Retroarch’s settings and “Crop Overscan” set to “On” in BSNES core options. Also I set the “core provided aspect ratio” to 4:3 instead of “8:7 PAR”. I have measured the image and this gives the correct 4:3 aspect ratio I am looking for. But is this how all these setting should be configured together for true 9x integer on 4K screen?


#235

The crop overscan setting in settings > video is a blunt instrument in that it’s just a toggle. If there’s a core option for it, it typically has finer controls, and the global setting is ignored.

SNES games are able to use 224 height, 240 height, 448 height and 480 height. 4K is a 9x integer multiple of 240, but not 224, so if you have a game that only uses the 224 height and you’re running at 9x integer, there will be small black borders. Games that use the overscan area (i.e., the full 240 height), there will not be borders.


#236

Hello peops sorry to bother my a have a little question about the Kurozumi Slang Shader with my AMD Card?

I have a very strong green tint color when i use the shader with vulkan ¿any ideas no artifacts nothing just the green tint.

I can´t use the Beatle HW Core on GL with my AMD Card Radeon 280 Vapor X GB

Thanks for any help in advance and thanks for the shader lovin it…


#237

Screenshots have their blue and red channels swapped with Vulkan for some reason (longstanding issue), but does it look like that in-game, too?


#238

Hello Hunter thx for the reply again thank you…:blush: To your question yes but not as much like on the picture. It has more like a green tint but very similar… and I have no clue what it could be…

Thanks for the Help

I’m on Win 10 and 1080p screen if it helps


#239

Heh, someone else playing Alundra. I’m about to do my first playthrough thanks to ps1 looking great on retroarch. Although right now I’m just tinkering around with ps1’s 3D games.


#240

So Alundra or at least the .bin has a natural green/blue tint (at least for the boat intro… I haven’t played further because I’m picking shaders for my playthrough). It might be good for a natural or somber atmosphere but I’ve settled on OpenGL (with 1x native gpu resolution and nearest texture filter) + ScaleFx.glslp - then add 2 more shader passes for scanline.glsl and ntsc-colors.glsl (in misc folder).

ntsc.glsl really makes a big difference on color. You can tweak the scanlines and ntsc color strength in the menu shader parameters. If your system can’t handle ScaleFx then try a different scaler, hqx, or xbr.

stronger scanlines


#241

retromaniac, I recreated your problem with Crt-Royal Kurozumi.

When I load crt-royale-kurozumi.glslp I get the additional dark blur. Solution: Go from 12 to 13 passes and hit apply, then go back to 12 passes and hit apply again

Before and After