CyberLab Mega Bezel Death To Pixels Shader Preset Pack

This is similar to what my early gaming setup was like in my youth. @HyperspaceMadness, @TheNamec, @Duimon, @Tromzy, @Neofuuma

Notice the near perfect geometry and orientation of the image on screen despite the obvious bulge and curvature of the picture tube.

4 Likes

The C1702 is one (if not the most) praised Commodore monitor for retrogaming. Despite its age, it offers quite hi quality colors and sharpness.

This was the first monitor I rebuilt for the Mega Bezel Commodore Pack, I LOVE it! :heart_eyes:

4 Likes

I made sure to pick one up as I was buying commodore stuff for my museum. I am proud to own one.

2 Likes

Here’s the preset that I came up with from your RGB Sharp. It’ll have to do until I buy a 4K monitor. It’s pretty funny that the only reason I want a 4K monitor is to play retro games, lol. I’d really like to see your presets in all their glory!

Screenshots

Download: Google Drive

1 Like

Thanks and welcome! Presets can still look very awesome at 1440p and 1080p resolutions with a little tweaking you know but I can understand the feeling!

I’m glad you like my presets.

Nice screenshots!!

What were you getting before cropping just the pink horizontal lines?

Were the gauges detail onscreen before you cropped? If so then perhaps you cropped too much? Only crop if you’re seeing black bars.

If cropping didn’t work, but setting Int. Scale Mode to 1 worked to eliminate your issues then by all means, that’s what you should use. Just cropping the black bars on the top and bottom worked for me in MVSC. Changing the Int. Scale Mode to 1 without cropping also worked for me but that was just one game. I’ll try to test some more games to see how things look.

Just doing a follow-up. Are all of the issues resolved now?

I did some follow up testing and I realize that MVSC2 is a totally different ball game to get exactly right. Without 320 x 240 you get no smoothing of the sprites. With 320 x 240 you don’t have enough pixels to render the fonts properly so they look messed up. Turning on fake scanlines can help reduce the “pixelation” in the sprites but I would prefer a better solution if there is one. This is something I’ll have to work on. I’ll try @HyperspaceMadness special DREZ preset and see how that looks and if it can be tweaked to perfection.

In the meantime, I might change my default Int. Scale Mode to 1 in my presets at some point so any users encountering the pink bands or pink horizontal lines issues you encountered won’t have that problem initially.

The fact that there’s a whole base preset variation dedicated to this game in HSM Mega Bezel Reflection Shader says a lot.

Hmmm…seems like getting this MVSC2 to look perfect is like playing wack-a-mole. There’s always some compromise that has to be made somewhere it seems.

2 Likes

Here are some screenshots of 128 bit cores (Flycast / PCSX2) with my settings for @Cyber’s awesome 1440p preset (open each image in a new tab for full resolution) :

https://imgur.com/a/v18v852

Unfortunately, I cannot post any Dolphin screenshot because for some reason, RetroArch refuses to take any screenshot of Dolphin. :confused: (maybe because it’s using D3D11)

1 Like

Thanks for sharing! These look great!

Do you believe you can get Dreamcast/Naomi/Atomiswave games to look even better than this?! I’ve been busting my brains out trying to get a perfect balance for MVSC2. You can try setting your Int. Scale Mode to 1 to improve scanlines quality and make sure to crop all games that have black borders. You can also try my RGB - Sharp preset!

1 Like

Yeah, I’m not quite satisfied with the settings, yet. Dolphin games look absolutely gorgeous, but that’s probably because I increased resolution to 3x for that core, when Flycast and PCSX2 are running at native console res. I’ll post some screenshots of FLycast / PCSX2 games running at increased resolution too, results are good too I think.

If I set Integer scale to one, the picture shrinks a bit too much.

1 Like

Here are some increased resolution screenshots :

https://imgur.com/a/DsX9JGt

The image on Flycast looks sharper obviously, but it’s a bit too “blocky” I think. I must add that I disable interlacing. For PCSX2 I get weird big scanlines with interlacing disabled, but they disappear when I reenable it (see the 2 GT4 screenshots for comparison).

1 Like

Well that might depend on the game and internal resolution you’re running. When I suggested to set it to 1 it was to actually expand the screen a bit as that helps with the quality of the scanlines. I’m new to 32-bit and beyond emulation so I would need some time to get familiar with the quirks. What I’ve noticed it that increased internal resolution results in vertical gaps in Ryu’s Super Hadoken in MVSC2. There always seems to be something wrong or at least not quite right somewhere if I change something to fix something else. In time I’ll post some updated presets just for Dreamcast/Naomi/Atomiswave and other higher resolution systems now that my 8-bit and 16-bit era stuff is more or less mature.

Another setting that makes a huge difference is the Opposite Dir Multiplyer (Y Downsample for H Scanlines). Default is 100 but 75 and 50 really brings out the scanlines by reducing the number and making them thicker on those higher resolution consoles. The downside is that high res elements like text suffers as well as the scanlines looking not properly aligned depending on the combination of that setting and the internal resolution.

Lastly, I’ve been experimenting with HSM’s special DEREZ base preset because I’m not seeing the same results when I use the STD base preset.

1 Like

Thanks again.

What method do you use to use my presets with Duimon’s overlays?

I know it’s not that difficult but I’m just curious as @Aeoliza was asking previously.

If you’re using an nVIDIA Graphics Card, you can probably press Alt-F1 to take a screenshot. Or look for the Dolphin screenshot hotkey in standalone dolphin and try it and see if it works in RetroArch.

Try 320 x 240 Internal resolution or anything higher than native. You should get better smoothing. You can also adjust the Opp Dir Multiplier to reduce the number of horizontal scanlines while making them thicker. That helps a lot with blockiness.

I just copy one of the presets, lets say “Dreamcast-[STD]-[Guest].slangp” for example, and I just replace the first line “#reference “:/shaders/shaders_slang/bezel/Mega_Bezel/Presets/Base_CRT_Presets/MBZ__2__STD__GDV.slangp”” with my custom Cyber preset.

1 Like

There was no room(black areas) for cropping but since you gave me those cropping values, I just did what you told me to. The black areas are generally present in Mame games from what I’ve seen, but then the color bands happen. As I mentioned before and also shared screenshots, SF3 3rd strike for Dreamcast has black areas too for some odd reason which I cropped but I got the color bands issue. So I had to do both cropping and Int scaling thing on it.

Right now the only workaround seems to be setting Integer scaling the preset settings to 1. But it still remains to be seen if it will work on all games.

1 Like

I will continue working on this. At 4K the same issue that was causing the pink horizontal lines at 1080p was showing up as bands of darker, uneven scanlines. I was able to eliminate this by adjusting the scanline parameters. Basically the more defined and separated the horizontal scanlines are the less likely to have those issues. That’s why lowering the resolution, changing the int. scale mode to 1, cropping the black bars at the top and bottom of the screen and lastly adjusting the scanlines parameters all had the effect of reducing or eliminating those anomalies.

It’s also easy to get less pixelation by lowering the Opp Dir Scanline Pre-Scale setting to 75% or 50%. 75% results in uneven scanline alignment which affects text quite a bit. 50% results in even scanline alignment but the text looks much lower resolution. At least it’s readable and not garbled like when you set internal resolution to 320 x 240. All of this is at 640 x 480 native internal resolution. At this resolution the Scale FX doesn’t really do much to the sprites so most of the smoothing is as a result of the scanlines and mask.

Once you use any resolution other than native the smoothing seems to look better. 1280 x 960 seems to be a good option however, the big issue that remains is once you leave native resolution Ryu’s Super Hadoken has vertical gaps in it.

So as it stands, it is possible to improve the look of things on the Flycast in high resolution games with pixel graphics and even in low res. games. I didn’t want to mention it until I got a fix because once you see something you can’t unsee it but I could see the pink lines in @Tromzy 's last set of screenshots. I think I even saw vertical pink lines. It shouldn’t be like that. I just didn’t want to mention it until I came up with a fix.

If I can’t find a better solution I’ll have to start with the solution that looks both sharp and smooth but leaves Ryu’s Super Hadoken messed up. I don’t think you should have to give up the nice high resolution elements just to get those sprites straightened out though.

Too bad scale FX wasn’t designed to work on hi res elements. I guess the best option might be some sort of SSAA effect.

By the way, I updated to RetroArch 1.9.13 and it seems to be slightly slower than 1.9.12. I also updated my installed cores and guess what? My Flycast core options still show the Cable Type. I think I might revert to 1.9.12 due to the performance regression though.

1 Like

Whenever I try to increase the Internal Resolution in core options above 640x480, it crashes RA. It’s weird, no idea what’s causing this.

Maybe if you do a fresh installation then it won’t show, but Idk for sure.

1 Like

It soft crashes for me sometimes when doing this. Especially if I use the Guide button on my controller to go back to the game. Try increasing the resolution one step at a time and maybe go back to the game using the menu instead of F1 or the Guide button.

1 Like

Oh my bad I didn’t fully explain it. Actually increasing the internal resolution is fine but when I apply the shader, it hard crashes RA. I tried both F1 and Resume through the menu but it still crashes.

1 Like

I can’t say why that’s happening. Perhaps you can try to retrace your steps to when it started happening.

If you list what happens in step by step fashion before the crash maybe I can assist. Or perhaps, @HyperspaceMadness or @Duimon might be able to assist with the help of a log.

1 Like

There is info in the shader thread about this. It has to do with the ScaleFX pass that results in passing too much to the GPU for the buffer to handle.

If you make a copy of the base shader and change it’s reference shader to “MBZ__2__STD__HD-CORE__GDV.slangp” then change Cyber’s reference shader to your copy, it should stop crashing.

The next Mega Bezel version will eliminate the ScaleFX pass from the STD base preset.

2 Likes