CyberLab Mega Bezel Death To Pixels Shader Preset Pack

Hey guys, what would be the best option for pre-rendered background PSX games for 1080p? (I will definetely try each one but would love to see opinions from people that already tried/know this shader preset better)

1 Like

This is all subjective but you can try Composite - Sharp PVM Edition preset first. If you want things to be softer than that, then the Composite - Sharp 1080p edition preset.

Alternatively you can try the Arcade - Sharp PVM Edition, the Arcade - Sharp 1080p or the RGB - Sharp PVM or RGB - Sharp 1080p Edition presets.

Hope this helps. Feel free to post some screenshots if you like the presets and spread the word!

1 Like

These are cellphone camera photos of my 4K IPS TV using my CyberLab Mega Bezel Death To Pixels (Arcade - Sharp PVM Edition) preset!

Hats off to @guest.r and @HyperspaceMadness !!!


I’m using it with just few tweks. Thank you!


Posting this here at @Cyber’s request

Pushing mask strength as high as it can go, here- the sub-pixel detail is amazing. The post-CRT brightness setting and gamma adjustment makes it really easy to compensate for lost brightness without throwing the colors off too much.

Looks acceptable on a 400 nit IPS, really shines on my iPhone with ~600 nits.

(screenshots will appear absurdly dark if not viewed at original size)

Here are the settings.

#reference "shaders_slang/bezel/Mega_Bezel/Presets/Experimental/Nesguy/Nesguy__Aperture__Low-TVL__Mask-7__Dbl-Phosphor-Width__N0.slangp"
HSM_INT_SCALE_MODE = "1.000000"
HSM_NON_INTEGER_SCALE = "100.169739"
HSM_CURVATURE_MODE = "-1.000000"
HSM_GAMMA_OUT_CRT = "1.900001"
g_gamma_out = "2.550000"
g_crtgamut = "0.000000"
g_vignette = "0.000000"
wp_temperature = "6504.000000"
WP = "-100.000000"
glow = "0.005000"
brightboost = "1.000000"
brightboost1 = "1.000000"
gsl = "1.000000"
beam_max = "1.500000"
vertmask = "0.200000"
h_sharp = "4.500000"
shadowMask = "0.000000"
maskstr = "1.000000"
mcut = "1.000000"
masksize = "1.000000"
mask_gamma = "2.399999"
mclip = "0.000000"
decons = "-0.000000"
1 Like

Thanks a mil. I’m sure these settings might help some users who pass through in the future! Why don’t you open a thread with just your personal presets, screenshots and recommendations?

I noticed that the screenshot is 1600 x 1200. Is that the optimal resolution for using these settings?

1 Like

Wow, the non-integer scale scanlines are so good now that I didn’t catch that. Ideally it should be 1494x1120 at 1080p, though.

1 Like

Well I’m too new around these parts of the forum to remember when they didn’t look so good so I’ll take your word for it that they’ve improved quite a bit. Lol

So are you saying that a user should set a custom resolution of 1494 x 1120 in RetroArch while using a screen or desktop resolution of 1080p? I’m not sure I fully understand what you have in mind.

1 Like

Yep, exactly that. This is only true for games/systems that use 224 horizontal lines, though. For games that use 240 lines, a custom resolution of 1600x1200 can be used. The amount that gets cropped in either case is outside of the safe area for CRTs. 5x vertical scale makes a big difference with the scanline beam dynamics.


Wow! Thanks for sharing your knowledge! Great tip!

I’m now wondering what would work for 480p content and also what custom resolution would be best if using a 1440p or 4K screen. I have try to fully understand this.

1 Like

With 480p content you can only go up to a vertical resolution of 960 before you crop way too much (assuming a 1080p screen)

1920 x 1440 works perfectly for 480p content on a 1440p screen.


Noob question: Where can I set this custom resolution and how can I know how many horizontal lines a game/system is using?

1 Like

One way you can see the horizontal resolution a game is using is by going into Shader Parameters and turning on Show Resolution Info. It’s the first parameter.

Custom Resolutions can be set in Settings…Video…Fullscreen Mode

But Windowed Fullscreen Mode would need to be turned off for these settings to have any effect.

1 Like

You’re welcome! I’m glad you’re enjoying my presets. Feel free to share your tweaks and some screenshots!

Thanks, I changed the Resolutions in Fullscreen Mode to 1496x1120 and disabled the Windowed Fullscreen Mode. But now when I try to go fullscreen, it doesn’t cover the whole screen.

1 Like

This is something I don’t interfere with so I don’t have much experience to guide you here but if the custom resolution you set is lower than the resolution of the screen then that might happen.

What Nesguy was suggesting was setting Custom Resolutions which were multiples (for example 2x, 3x, 4x or 5x) of the core resolution but just slightly larger resulting in some of the overscan area being cropped off.

Perhaps @Nesguy or @HyperspaceMadness might be of assistance? Also a little more information might help, for example what core, game, the resolution info and maybe a screenshot and a summary of what you’re trying to accomplish.

On another note, you can launch clones of Mame ROMs easily using LaunchBox. It’s as simple as right clicking and selecting which clone or version of the game you want to play from one entry for all of the clones. You can even set which one you want to be the default. I don’t know if you saw my reply on that.

You can also have the same ROMs setup to use both Mame and Final Burn Neo and easily switch between the 2.

1 Like

Hey, the PVM editions look really cool! Nice job on them. I took the RGB Sharp PVM and modified it like the original RGB Sharp and got a result that’s fitting for my eyeballs. Unlike before, I’ve decided to keep your mask type, but lowered its strength. Looks good in everything from 8-bit to N64. I want to use it in PS1 games with 2x resolution, but unfortunately the scanlines look really odd. I’ll see about finding a solution later. But for now, here are a few screenshots and a download to this preset.

EDIT: Ok, so from my testing, only one PS1 game running at 2x resolution has weird distracting scanlines, and that game is Ghost in the Shell. Setting the Int Scale Mode to 1.00 fixes this, but understandably causes the picture to be smaller. Imo this is a better choice than simply removing the scanlines because removing them causes the picture to be too bright. Scanlines are hardly visible in any game at 2x res. Doesn’t really bother me tho.

1 Like

Many of these CRT scanline shaders fall flat on hires (>240p) content. It’s something that I and others have came across and been working on finding solutions to. If you read some of my previous posts on trying to get Marvel Vs Capcom 2 for Dreamcast to look good. Also things like ScaleFX (which does smoothing don’t work as well on hi-res content and even some low-res looking 2D which uses “bunches of pixes” to render the sprites.

There have been some posts on this and I’ve had some early success in creating presets that provide a good balance. There are always going to be compromises it seems.

HSM Mega Bezel Reflection Shader has some presets to address this called the DREZ presets.

If you run 2x without adjusting the scanlines then that means you would have 2x the scanlines trying to share the same space so that can cause some issues. Separating the scanlines and phosphors more can help. So if use any setting that stretches the image out more it would make things look better. You can also lower the scanline resolution to 50% using the Opposite Dir Multiplier (Y Downsample for H Scanlines) setting. You can also change the mask size to a larger size for higher resolution content.

Thanks! I’m glad you like them!

Now that my 8 - 16bit era and low res 32 and 64-bit era stuff are fairly mature, I’ll probably start to do some more research to see what works best with the higher res stuff. So stay tuned and you can ask people like @HyperspaceMadness about these things since he would definitely know his way around his shaders better than me.

To use the DREZ presets you would have to change my base preset to one of the drez presets. So you can go ahead and try. Some of them add fake scanlines which can help but I don’t like the fake scanlines. I prefer even, pixel aligned scanlines.

Also, I don’t know which Integer Scale Setting you changed but the one you should adjust is not the one in the main RetroArch setting eh. It’s actually the Int. Scale Mode in the Shader Parameters. It’s not too far from the top. You can try changing it from 0 to 1. The effect you want is to see an expansion of the screen not shrinkage. You also have to make sure you crop any black bars on the top and bottom of the screen. This helps quite a bit. Again, this is from within the Shader Parameters.

Take a look at this post:

And also from this post, there are several on this type of issue:

Excellent screenshot album! Looks like you’re having a lot of fun with my presets! You know you can post images and image links directly in your post. The max image size is 4,096KB.

This is what happens when you post an imgur image link for example:

This way it will make it easier for others to see as they scroll through the thread. I used to like it before but I now prefer playing NES Games with ScaleFx Off. That’s why I created my Composite Pure preset. You can give it a try and apply your modifications. I just find NES sprites look a bit too inauthentic when smoothed out. Ironically, I find Atari games look really special using my Composite Sharp or Composite Sharp PVM Edition presets.

I just quickly tried Tmnt2(224p) on Mame current core. At full screen 1496x1120, RA just doesn’t actually go fullscreen but rather looks like a window. I can even see the remaining portion of my desktop.

Also, I have noticed that the blurriness in these Mame games that I mentioned earlier is not actually occurring from increasing the internal resolution, but from using the “MBZ__2__STD__HD-CORE__GDV.slangp” preset.

1 Like

Seems like I’ll have to test these things myself. Thanks for taking me out of my comfort zone and providing me with these scenarios. Lol Final Burn Neo works perfectly with TMNT2 but we’ll get to the bottom of this.

As for the Windowed look if you’re using 1496 x 1120, perhaps @Nesguy can chime in? If you’re on a 1440p screen, then that’s understandable. If you’re on a 1080p screen then I’m not so sure. I have never interfered with custom resolutions in RetroArch before and I run it with Windowed Fullscreen mode On.

You can probable try higher resolutions which are multiple of your native resolution until you find the one that fills the screen. Or maybe it’s some other setting that is being overlooked. Is your system set to scale using the GPU or the Display?

1 Like