[Download] RetroArch 1.7.5 (iOS 11 & iOS 12) ipa + extras (Updated v3)


#1

RetroArch 1.7.7 is out ! Download it here : [Download] RetroArch 1.7.7 + other emulators (iOS)


RetroArch 1.7.5 for iOS 11 and above !

Including the working cores and all the required files to not boot to a black screen or a crash (because of a missing BIOS file)… :smile:

ROMs :

You can use iTunes file sharing — or an app like iFunBox or iExplorer — to add ROMs to the app, or :

To install your ROMs inside the app just using Cydia Impactor, you can unzip the ipa (rename it to .zip), inside the “.app” is an “assets.zip” file, just add your ROMs folder to this zip file…

After that just make a zip of “Payload” and “BundleMetadata.plist” with your ROMs included, and rename it “RetroArch_1.7.5.ipa” — this method works for save states and other stuff too !

Please note that with this method, the ROMs will be extracted at first launch, make sure to have enough space

P.S.: If you first fully unzip the “assets.zip” file, after adding your ROMs folder, do not make a zip of the “assets” folder itself ! Make a zip of the folders inside the assets folder directly, and rename the zip “assets.zip”

Install :

To install on a non-jailbroken device, use Cydia Impactor (http://www.cydiaimpactor.com), you may have to re-install the .ipa every week if using a free account, or every year if using a paid developer account…

To install on a jailbroken device, just unzip the “.ipa” file (rename to “.zip”), and install to “/Applications” via SFTP or Filza (or use iFunbox, iExplorer or similar) — then type “uicache” via SSH…

Included cores :

4do (3DO) — 81 (ZX81) — 2048 (2048 game) — bluemsx (MSX) — bsnes_mercury_accuracy / balanced / performance (Super NES) — cannonball (Out Run engine) — crocods (Amstrad CPC) — desmume (Nintendo DS) — dosbox (MS-DOS) — easyrpg (EasyRPG/Player) — fbalpha (Arcade) — fceumm (NES) — fuse (ZX Spectrum) — gambatte (Game Boy) — genesis_plus_gx (Sega 8/16 bit) — gme (Game Music Emu) — gw (Game & Watch) — handy (Atari Lynx) — hatari (Atari ST/STE/TT/Falcon) — lutro (lua game framework) — mame2003 (Arcade) — mednafen_ngp (NeoGeo Pocket) — mednafen_pcfx (PCFX) — mednafen_psx (Playstation) — mednafen_supergrafx (PC Engine/Turbografx/CD) — mednafen_vb (Virtual Boy) — mednafen_wswan (WonderSwan) — mgba (Game Boy Advance) — mrboom (Bomberman clone) — mu (Palm OS) — nestopia (NES) — nxengine (Cave Story engine) — o2em (Odyssey 2 / VideoPac) — pcsx_rearmed (Playstation) — picodrive (SEGA Mega Drive/Genesis/Master System/32x/CD) — pocketcdg (Karaoke player) — pokemini (Pokémon-Mini) — prboom (DOOM engine) — prosystem (Atari 7800) — px68k (SHARP X68000) — sameboy (Game Boy) — snes9x (Super NES) — stella (Atari 2600) — tgbdual (Game Boy 2 players) — vecx (Vectrex) — vice_x64 (Commodore 64) — vice_x128 (Commodore 128) — vice_xplus4 (Commodore Plus4) — vice_xvic (Commodore VIC-20) — virtualjaguar (Atari Jaguar) — xrick (Rick Dangerous engine)

Cores included have support for :

Consoles : 3DO, Atari 2600, Atari 7800, Atari Jaguar, Atari Lynx, Bandai WonderSwan, Game & Watch, NEC PC Engine/Turbografx/CD, NEC PCFX, Nintendo DS, Nintendo Game Boy, Nintendo Game Boy 2 players, Nintendo Game Boy Advance, Nintendo NES, Nintendo Super NES, Nintendo Virtual Boy, Pokémon-Mini, SEGA 32x, SEGA CD, SEGA Game Gear, SEGA Genesis/Mega Drive, SEGA Master System, Sony Playstation, SNK NeoGeo Pocket, Vectrex

Computers : Amstrad CPC, Atari ST/STE/TT/Falcon, Commodore 64, Commodore 128, Commodore Plus4, Commodore VIC-20, MS-DOS, MSX, Odyssey 2/VideoPac, Palm OS, SHARP X68000, ZX Spectrum, ZX81

Arcade : FinalBurn Alpha, M.A.M.E 2003

Game Engines : Cave Story engine, DOOM engine, EasyRPG/Player, lua game framework, Out Run engine, Rick Dangerous engine

Games : 2048 game, Bomberman clone

Multimedia : Game Music Emu, Karaoke player

I also compiled/linked some complementary emulators for iOS 11, as their RetroArch core counterparts are currently broken on iOS 11 (and added some retro Mac emulators in the mix…)

Links :


RetroArch 1.7.5v3 (iOS 11 & iOS 12) — Including BIOS files

http://www.mediafire.com/file/9lea4y269q8t508/RetroArch_1.7.5v3.ipa/file

I couldn’t compile the latest versions of some included cores, so older ones were used in this case… The shaders are fixed in this release !


Provenance 1.5b2768 (iOS 11 & iOS 12) — N64 emulator core included

https://builds.provenance-emu.com/iOS/Latest/

BIOS files : http://www.mediafire.com/file/c2kxkgm37rdc2px/Provenance_BIOS.zip/file

Now updated to the latest version, N64 is running even smoother now…


PPSSPP 1.6.3 (iOS 11 & iOS 12) — PSP emulator

https://build.ppsspp.org/?page/downloads


uoYabause/yabasanshiro 1.8.1 (iOS 11 & iOS 12) — SEGA Saturn emulator

http://www.uoyabause.org/static_pages/download

It says the IPA is unsigned on the website but it is indeed signed anyway


ScummVM 2.1.0 (iOS 11 & iOS 12) — Point & Click games engine

http://www.mediafire.com/file/skinjwqqis99xmn/ScummVM_2.1.0_%28iOS_11%29.ipa/file

Included is the smart keyboard fix, the arrows on the keyboard fix, and the mt32 emulator which seems to work fine on iOS now… And a corrected icon !


iDOS 2 1.4.1 (iOS 11 & iOS 12) — PC DOS emulator

http://www.mediafire.com/file/4lf4w9jbc65lqzp/iDOS_2_1.4.1.ipa/file

It’s a new version including fixes for the layout on the iPad Pro and iPhone X


Mini vMac 2.3 (iOS 11 & iOS 12) — Mac 68k emulator (Mac OS 1.1 - 7.5.5)


BasiliskII 10/01/2018 (iOS 11 & iOS 12) — Mac 68k emulator (Mac OS 7.0 - 8.1)

http://www.mediafire.com/file/1tdyozg4egjg5ai/BasiliskII_2018.10.01.ipa/file

New version with a fix for iOS 12


Everything on this list is already code-signed so you don’t have to worry about signing again if you’re jailbroken… If not, Cydia Impactor will re-sign everything for you !


Need Assistance with RetroArch iOS
#2

Ios1.75 replace ttf fonts still can not Chinese, how do you solve?


#3

I think you can report the bug…

I just tried to select other languages and I saw all ??? instead of languages with custom fonts requirements…

P.S.: In the Mac version too it has the same bug !


#4

Where do I need to report the error? Is there a fundamental solution?


#5

RetroArch crashes whenever I apply a shader. Do you have that issue?


#6

I have this iusse too, crash when load sheaders


#7

Shaders are now fixed… Links updated in the first post !

Thanks for the heads up @Jeosh @ThisMyBoomStick

The original 1.7.5 release broke the shaders on iOS, they eventually got fixed, but they broke again some time before the latest release… I actually managed to find a release before the shaders got broken again !

The release uploaded is from GitHub commit e99e1c47cb0f11dda23427e2a5fb206fc2a4bb9a — Update Simplified Chinese Localization, but it didn’t fix @qwer1120550606’s problem as far as I can see…

I think the shaders broke again on iOS after some commit trying to fix some shaders issues as there have been many shader-related commits in the past few weeks…

Now if someone could tell me where to actually report these bugs — or report them for me :wink: —, it would be appreciated…

Edit : Oh, and BTW, I compiled the latest Provenance too ! Links updated in the first post…


#8

Awesome. Thanks. When I sideload the new version will it install over the existing RetroArch?


#9

@ThisMyBoomStick Yes, I managed to keep the existing app bundle identifier to “com.libretro.RetroArch”, so if you installed an older of my uploads, it will find it and update over it…


#10

I have a couple of noob questions:

  1. After I resign the app, I can no longer load games from existing playlists. Is there anything I can do to fix this?

  2. I can download thumbnails, but they don’t show up in the playlist. Are thumbnails not available on iOS?

Out of curiosity, what’s the story with RetroArch and N64? It seems like everything works on iOS except that console.


#11

Is there going to be a Documentation created for mu (Palm OS)?


#12

I (wrongly) included a Palm OS “.rom” in the BIOS (system) folder, and everything works fine loading this file like a regular rom !

I tested it, and everything works as it should, but that’s about as far as I went through testing… I didn’t try to synchronize apps or anything with it, but then again, I didn’t bother checking online for more documentation than the libretro core one, and then focused only on required files…

It seemed to me that this is a fairly new emulator, so there may not be much documentation available — but it might have been around for a while and just “new” to being a RetroArch core…


#13

Sorry but I never used playlists in RetroArch, so I have no definitive answer, but your ROMs files might just be in a different location now than the time you created the playlists (in a different subfolder, a differently named folder, or even your rom files themselves may have a different name)…

As for N64 in RetroArch, it actually works quite good on 32-bit iOS (prior to iOS 11…) !

The problem is Apple deliberately removed any 32-bit support altogether on iOS 11, meaning that if an app (or library bundle, like a RetroArch core…) uses even a small portion of 32-bit code, it has to be rewritten to use 64-bit code only !

Many cores have to be rewritten (either partially or completely) for 64-bit processors, or will fail to even compile with the tools we use now to compile for iOS…


#14

Yeah, I got it to work for me, but now, need to figure out how to Load Up and Install Apps.


#15

So it died in 32-bit apocalypse. A good portion of my purchased list is gone thanks to it. Hopefully someone updates the core. The free developer account only allows three apps and I don’t want to use up one for Provenance just for N64.

What you’re saying about the playlists makes sense. I haven’t moved my ROMs or renamed them. They’re in the documents folder within RetroArch. I noticed the documents folder sits inside another folder that’s a long string of numbers and letters. I wonder if that string changes after resigning the app, which would mess up the playlists.


#16

Has anyone launch anything on dreamcast core (reicast core) other than bios?


#17

Provenance is still not ready even for stable n64, but there are “non-official” branches trying to make a complete port of reicast that I could try to compile to see if they load any games…

I’m thinking about this one : https://github.com/JoeMatt/reicast-emulator/commits/feature/arm64

And the other one I may be looking into is : https://github.com/Provenance-Emu/Provenance/tree/new-cores/Dreamcast-Reicast

Edit : Whoops, my bad… It seems like they’re actually the exact same thing (and completely official BTW), and https://github.com/Provenance-Emu/Provenance/tree/new-cores/Dreamcast-Reicast seems like an older fork anyway…


#18

It’s really working (build 2768 at 27.12) on iOS and tvOS too. Only need edit emu.cfg with true values. For example: Dreamcast.Cable = 0 Dreamcast.RTC = 1543278647 Dreamcast.Region = 3 Dynarec.Enabled = 1 Dynarec.idleskip = 1 Dynarec.unstable-opt = 0 aica.LimitFPS = 1 aica.NoBatch = 0 aica.NoSound = 1 aica.OldSyncronousDma = yes bios.UseReios = 0 pvr.MaxThreads = 3 pvr.Subdivide = 0 pvr.SynchronousRendering = 0 pvr.rend = 0 rend.Clipping = 1 rend.UseMipmaps = 1 rend.WideScreen = 1 ta.skip = 0 Freezings, but working. And GDI seems more better than CDI. Soul Caliber and Mortal Kombat Gold can play very comfortable.


#19

I am new here…Not sure how to post a new topic. My question is regarding setting up PPSSPP (Sony PSP) on RetroArch inside MacOs. I have to app installed with PPSSPP core. But I found that I need to copy some files manually. I can’t find the directory on the Mac. Could someone help please…


#20

The BIOS are in your “(Users -> YourName ->)Documents -> RetroArch -> system” folder, and the other files are directly inside the app…

To access the contents of the app, right-click (or ctrl-clic) on the RetroArch app icon, and select “Show Package Contents”, then go to “Contents -> Resources” folder inside…

BTW, this is a post for the iPhone and iPad version of the app… :smile: