HSM Mega Bezel Reflection Shader! - Feedback and Updates

My thought process on why the deconvergence being on makes things seem sharper, is in my experience it accentuates the highlights in the image more, leading to more noticeable contrast separation.

1 Like

I’m not disputing what you’re saying but what I’ve just observed by literally staring at the individual phosphors/subpixels on my screen from an extremely close distance is that they literally looked as if they shifted into a more even alignment. Going back and forth between on and off and you see the mask pattern shifting. For example it looks as if the red overlaps with the blue to some extent in one particular case resulting in some magenta pixels that were just plain red and blue before but now there’s also a distinct black space where they moved from. Yes, individual phosphors are now visible using my presets!

@guest.r, @HyperspaceMadness, @Nesguy Can any of you confirm what is really going on with the subpixels/phosphors/mask when switching deconvergence between on and off with smoothing set to 0.00?

3 Likes

I’m patiently awaiting for the new version to be released. Edit: and I’m too dumb to use GitHub updates. waiting

See “Love forever changes” full album

3 Likes

I reenabled deconvergence and set smoothing down to 0, and I’m not sure what it does exactly, but I like the result, so I’ll use these new settings. Thanks !

1 Like

It makes the image even sharper than just turning deconvergence off. You’re welcome! I’m saving my next preset updates for my new thread so stay tuned!

5 Likes

Well everyone, just passing through to share the link to the new home of the CyberLab Mega Bezel Death To Pixels Shader Preset Pack. Thanks for all of your support in helping me to get to this point. Feel free to drop by and take a download!

2 Likes

I think this might be related to the different luminance of the colors (red & green, vs blue) the blue component of the color is darkest, and the green is the brightest. :thinking:

So I think what might be happening is when the blue moves away from the others maybe it makes that area darker. But really this is only a guess :upside_down_face:.

1 Like

Hello @HyperspaceMadness

First off I really appreciate your work on these cool shaders. I’m a newcomer to Retroarch and only installed it a couple days ago and found out about your shaders and @Cyber’s cool presets based on your shaders.

My first experience is with trying Dreamcast/Naomi/Atomiswave games using the flycast core. The games do look good but I noticed some horizontal lines that don’t look like they should be there.

With Cyber’s Arcade-sharp preset:

With your original MBZ_2_STD_GDV.slangp:

I’m a noob who’s only coming from using simple emulators and never tinkered with any kind of code, so I couldn’t figure out what’s wrong. Could you please look into this?

I’m using, latest Retroarch, latest Flycast core and have done all the necessary changes to settings that you have mentioned, such as turning Aspect ratio to “full”, etc. My native resolution is 1080p.

Thanks!

3 Likes

Go into Flycast Core Options and change your internal resolution to 320 x 240. In my just concluded testing I found My RGB - Sharp preset to be the one I liked the most with this core. I only used MVSC in my testing so far.

You can also set cable type to TV (RGB) and enable Power VR2 Post Processing if you wish. Unfortunately I didn’t remember you were using 1080p desktop resolution or I would have done my testing at that resolution but my findings might still apply. I’ll retest at 1080p to confirm.

My RGB - Sharp Preset looks fine even at 1080p.

2 Likes

Ok, I went to the options where the IR was by default set to 640x480. I changed to 320x240 and the lines do seem to be gone. But then I noticed that a lot of the text is garbled and the overall image quality also went down:

I couldn’t find the Cable type setting. I tried VR2 but it didn’t seem to do any improvement.

2 Likes

Hey, one thing you could try is the SegaDC-MVC2__STD__DEREZ-480p preset in the variations folder, it uses the 640x480 resolution, but then puts fake scanlines on top for a 240p Scanline look without losing resolution on the high res parts

3 Likes

After further testing I realized that the solution to both the pink horizontal lines as well as the uneven scanlines effects I was noticing even after switching internal resolution to 320 x 240 is turning on integer scaling in my shader preset parameters.

With this setting enabled all scanlines anomolies disappear even at 640 x 480 Internal Resolution.

However, if you want the smoothing effects to work, you’re going to have to leave that at 320 x 240.

2 Likes

Gee whiz! @HyperspaceMadness What haven’t you thought of? Lol I’ll give this a try and see how it looks one of these days.

Based on this experience, I’m going to try to turn on Integer Scaling on all of my presets and hope that doesn’t break something else.

Thanks for the assistance. HSM Mega Bezel Reflection Shader is slowly making the rounds across the interwebs. It’s probably one of RetroArch’s best kept secrets!

I’ll look into this. It could be due to the resolution drop or from the MDAPT setting.

You should look again for the Cable Type setting. It’s right below Widescreen Cheats. TV (RGB) should give you an even clearer picture without losing the smoothing effects!

After even more testing, just as I was about to alter my Shader presets unnecessarily. I realized that the real issue with those games is that the vertical axis is a bit squished. That messes up the scanlines and it manifests in different ways at different resolutions. The simplest solution is just to crop the black bars at the top and bottom of the screen. This expands the screen and allows the scanlines to have enough breathing space to look as they should.

So @Aeoliza this is my recommended and final solution to that issue. Not turning on integer scaling. The Cropping Section is near the top of the Shader Parameters in HSM Mega Bezel Reflection Shader. For MVSC I set Crop Top % to 2.30 and Crop Bottom % to 4.20 and voila. All scanlines anomalies gone!

After that, Choose Save then Save Game Preset.

There’s supposed to be a setting to automatically crop black regions but I’ve never tried it. Maybe @HyperspaceMadness or @Duimon can let us know if it’s a reliable and viable option that can be used as well.

Welcome again. I hope you enjoy your new enhanced gaming experience!

One more thing, if you enable Int. Scale Mode 1 or 2 in the shader parameters, in MVSC, you’ll get an even larger playing area as the entire bezel and screen would be expanded slightly.

3 Likes

It looks nice, thanks, though the scanlines are a bit too visible in this one.

Oh wow! This looks to have eliminated them. This setting seems to be it. There are scanlines but they are quite fine and seem to be more noticeable in Mame games

However, is there a catch with removing Integer Scaling? I couldn’t tell the difference, lol. What actually is smoothing and how does it affect the picture quality? Also, I set the setting to 1(ShortAxis). Is this ok or should I set it to 2(BothAxes)?

Two weird cases that I couldn’t figure out. First SF3 3rd strike(DC) that aligns on the top-left and doesn’t cover the full screen. Second Metal Slug 6 which is centered but still leaves a significant amount of space at the top and bottom. Any ideas on what could be causing these?

Oh and I still couldn’t find that Cable Type setting, lol

1 Like

It wasn’t integer scaling I said was needed for smoothing, it was the 320 x 240 Internal resolution in the Core Options.

Look at my above post. The real culprit (in my testing using MVSC) was those black bars at the top and bottom of the screen. Crop them out of your games first before resorting to setting Int. Scale Mode to 2 in the shader preset parameters.

1 Like

Oh sorry, my bad, I edited my post now and asked some questions. Please see my above post. I’ll try the cropping thing.

That would be great. I hope they can help.

2 Likes

Put Int. Scale back the way it was, then get familiar with cropping all your games when you first launch them. Then we’ll see if you’ll still have the same questions. Feel free to ask me the next one over on my new shader preset thread. Don’t forget to download my latest shader preset pack and try my new CyberLab Mega Bezel Death To Pixels (RGB - Sharp 1080p Edition) preset! Optimized just for 1080p users like you who are playing Dreamcast games and more!

If you like it but the scanlines are too strong you can reduce them with the Fake Scanline Opacity this preset is set up to help with the double sized character sprites and if there was increased internal resolution in use.

But it sounds like cropping in the standard presets is helping the scanlines have more pixels to work with and reducing the moire artifacts you are seeing.

I integer scale helps give an equal number of pixels per Scanline which can help with moire artifacts. So if you aren’t having artifacts then you don’t need it. It will also cause the screen size to change depending on the resolution of the game. Usually 1(ShortAxis) is usually what you want because this does its improvement for the scanlines, but keeps your aspect ratio correct, E.G. 4:3

This is usually just what is coming from the game and the way to fix it is to crop the offending areas with the cropping parameters.

In the automatic crop black option you specify what you want as the maximum you want to be cropped, but only if the area is currently black in the game image. It does work, but I personally only apply it sometimes and particularly if the black areas appear and disappear like in the n64 for instance.

2 Likes

That could be because you’re on 1.9.13 Nightly and I’m on 1.9.12 Stable. Perhaps your Flycast is more up to date as a result. I update installed cores regularly. Maybe if I do it now I might end up on the same Flycast version as you or maybe it’s just not available for stable RetroArch versions yet?

I’m really glad you can experience these Bezels and presets. Now go forth into the world and spread the word so that others may have the same opportunity to benefit! Let’s make this thing go viral (cough…cough…inappropriate) mainstream!

Every retrogamer should hear about HSM Mega Bezel Reflection Shader and of course Guest CRT Advanced!

Feel free to post some of your awesome screenshots to my thread!!

2 Likes

@HyperspaceMadness @Cyber

I tried the cropping thing and it’s causing these color bands throughout

Also the gauges detail at the bottom is cut off in MVC2

I tried and it did do the job, but I had to use “Any” because the “black” one didn’t work. But then again, the color bands happened…

Actually 1.9.13 is the current stable build according to this page: https://www.retroarch.com/index.php?page=platforms

And yeah I’ll be sure to spread the word about this great shader.

2 Likes