I can´t run retroarch by linux (Ubuntu 21.10

I believe he meant this:

but please keep it friendly. forums don’t work without courtesy and civility.

1 Like

Yeah and maybe the right place to ask for help is Ubuntu forums. I don’t think this issue is a RetroArch fault.

<Thank you for your advice but I don’t think it will be helpful> [PARAPHRASED FOR CIVILITY]

Moving on. I’ve provide information that may benefit other Ubuntu 21.10 users. If this is an issue because of RetroArch, Vulkan or Wayland is yet to be determined.

Sorry to edit your post like that, but I figured it was better than outright rejecting it. I’ll try to reboot into wayland and see if I can figure out what’s going on this evening.

1 Like

Actually you didn’t save the world, the info is already provided by the OP. This is called a “request”.

And when you request others to do the job, better say the magic word first (please?)

It looks like they’re ready to drop it, so you should drop it, too, please.

please is not be necessary to fight between us , we must keep our community safe and stable

I’m pretty sure of that error by wayland is fix it probably soon as we keep talk

we are humans and we make mistakes even the machine make it sometimes so…

Just a quick test I did on an Ubuntu virtual machine, if you run that command (XDG_RUNTIME_DIR) on a terminal it runs on that session from terminal without sudo, but still not from icon and after restart you have to execute the command again.

I spent some time in Wayland last night and, while the snap package ran just fine, neither the PPA nor a self-compiled build would. I didn’t get the same error on them, though. PPA gave me the 0 B context issue we see above while self-compiled gives an mmap error.

1 Like

It seems that this Wayland thing is a hack that is full of problems. Some hackers created it without any plan and major distributions adopted it for some reason.

heh, i wouldn’t go so far as that. It’s just the new, future-looking replacement for a system that’s stable and functional but antiquated (that is, X). It’s a huge endeavor and the necessarily piecemeal adoption that’s happened means that it’s perpetually in testing/beta.

Wayland’s been around for a number of years but it’s only now reaching a point of stability and functionality that more end-user-focused distros are either defaulting to it or making it so easy to switch to it that regular users are trying it, and that’s bringing a lot of previously ignorable issues to a head.

In the past, “just switch back to X” was a pretty normal way of dealing with things but that’s not as well-received these days, and I think that’s both reasonable and okay, and we’re just going to have to deal with it. :slight_smile:

Yeah but how can someone create something that breaks tons of software (not only RetroArch). Let’s say RetroArch tomorrow decides to introduce something that breaks all cores, shaders and then ask the developers to re-write lol.

Personally I never use Ubuntu, I hate that bar on the left and the UI in general. Everything just works in Mint. I don’t have to reinvent the wheel-fight with the OS :joy:

1 Like

18 posts were split to a new topic: Performance on Lakka with the same hardware

Ay, The snap works ([INFO] RetroArch 1.10.0 (Git b71be7efd2)), but neither PPA/AppImage from the download page, or self built would work.

"[ERROR] [Wayland] [SHM]". mmap failed: Invalid argument

This AppImage does load native on Ubuntu 21.1 (wayland) and it’s from AppImage does not start in version 1.10.1 ( https://github.com/hizzlekizzle/RetroArch-AppImage/releases/tag/Linux_LTS_Nightlies ([INFO] RetroArch 1.9.1 (Git 5ca666acee) and this one gives;

[INFO] [EGL] Found EGL client version >= 1.5, trying eglGetPlatformDisplay
[INFO] [EGL]: EGL version: 1.5

Also using the Libretro runner downloaded from Lutris loads too w/o problems. ([INFO] RetroArch 1.9.13 (Git fca72f67d1)


1 Like

I think we’ve got it pinned down for the most part. It seems to be related to some libdecor changes that were added recently to enable window decorations. Historically, the window has just floated in the air in wayland, but the libdecor stuff lets it act like a normal program window.

This PR fixes the 0 B window issue, apparently: https://github.com/libretro/RetroArch/pull/13759

1 Like

tyvm. Just built it, from this latest merge ("twinaphex merged commit 065fb5a into libretro:master) and it opens! :slight_smile:

[INFO] RetroArch 1.10.1 (Git 065fb5acee)
[ERROR] [Wayland/Vulkan]: Failed to draw splash screen
[INFO] [Vulkan]: Vulkan dynamic library loaded.
[INFO] [Vulkan]: Found vulkan context: "vk_wayland".
[INFO] [Vulkan]: Detecting screen resolution: 1920x1080

w00t, thanks for testing/verifying! That’s great news.

It’ll make it to the testing PPA soon, but I think we’re planning to do another stable this weekend so I’ll hold off on the stable until then.

can someone help me with this please