Intermittent flickering issue with composite/RF-mode shaders

Apologies if this has already been covered in another thread, I’m having a hard time finding others with exact issue I’m running into.

What’s happening is, when I’m playing games with a composite or RF-mode shader preset (crt-royale-ntsc-composite.slangp, or crt-guest-advanced-ntsc.slangp on RF mode for instance) I will encounter a jitter of sorts that comes and goes. I’ve tried changing a handful of settings within the respective shaders to no avail. One thing I’ve noticed is this doesn’t occur when I run the aforementioned shaders in S-Video mode or greater, this seems to affect composite and RF exclusively.

Has anyone else run into this, and if so, is this expected? I don’t recall this being prominent back on my old consumer CRTs. It’s distracting when the screen image is largely static save for a jitter every couple seconds.

Examples demonstrating the intermittent behavior:

Side note, I’m really impressed by the work folks have done to preserve this aesthetic.

Edit: I wanted to add that this jitter persists even while the F1 menu is open in RetroArch, but not when a menu bar dropdown is opened.

1 Like

I use these and I don’t get any jitters.

If possible, try a clean install of RetroArch and make sure your graphics drivers are up to date.

Be sure to follow all installation instructions.

The jitters happen every other frame but shouldn’t be visible if your sync is functioning properly (i.e., no frames dropped/duplicated). You can also use the ‘merge fields’ parameter when the shader is in the ‘custom’ mode to disable it.

1 Like

That makes sense, and now that you mention it I’m noticing when I change between applications on my desktop it almost always causes one or two noticeable jitters. Unfortunately the “NTSC Merge Fields” parameter doesn’t seem to have any effect (I can still see the alternating fields when pausing emulation), but maybe there’s something I can do with regards to dropped/duplicated frames.

1 Like

I spoke too soon, I didn’t realize I had to have use “Custom=-1” for the “NTSC Preset” option before the “NTSC Merge Fields” had any effect. I was hoping I could continue using the presets and just override merge fields specifically.

1 Like

What parameters to have RF and composite signals without jitters?

1 Like

Set the preset to custom, then set the custom fringing and artifacting both to 1.0 for composite or 2.0 for RF and merge fields to 1.0


I turned on the computer and opened RetroArch to test the parameters. Without messing with the settings, the jitter was much smoother, without bothering… Strange, isn’t it?

Even so, I will use the custom settings.

1 Like

This seems close, but not exactly right from what I can see on my end. I’ll likely have to try and pick apart what’s going on within the shader profile itself to find the preset values, but haven’t had time to look into it yet.