Lakka lacks crt support?

Hi guys, i just tried lakka live cd, it’s normal that lakka for standard pc don’t have crtswitchres menù/support?

I believe this is normal, yes. The switchres stuff for standard PCs requires xrandr, which isn’t present in Lakka, as it runs without an X server.

Hi @hunterk ok, right :wink:

But on RPi version is there crtswitchres?

Not in the current Lakka release, but I think in the next one.

ah ok, so i can’t use crtswitchres with lakka… and, do you know aproximately new lakka release date?

I do not, sorry. I’m only tangentially involved in Lakka.

Next version eh? Didn’t know that. So is that next meaning 3.0?

@hunterk just to be sure I got it right, the only way to use crtswitchres (PC or RPi) is without lakka, right?

Currently, yes, AFAIK.

Hello !

Restarting this thread, for a CRT issue. I updated Lakka to 3.0 on Rpi 4, and i can’t seem to boot on the user interface with my adapters and my HDMI timings. I use VGA666 vga adapter and pi2scart, I entered my custom timings in the config.txt and then the distroconfig.txt, but it didn’t work. The startup blocks at the Flower splash screen.

I have no issue when i use the default settings with my pi4 plugged in HDMI to my Tv monitor

Here are my settings : disable_audio_dither=1 dtparam=audio=on dtoverlay=vga666 enable_dpi_lcd=1 display_default_lcd=1 dpi_group=2 dpi_mode=87

hdmi_timings=1920 1 152 247 280 240 1 1 7 14 0 0 0 60 0 40860000 1

Anyone can help ? Thanks a lot !

I’m seeing the same behavior with a Retrotink Ultimate/RPi3B+ on Lakka 3 - it gets stuck at the flower splash screen. I tried both an update from a 2.1.1 Lakka (that was working with the Retrotink) and a full clean install of Lakka v3 (plus config changes needed for Retrotink), but neither worked for the Retrotink output (in my case S-Video) with Lakka v3.

I’d try the command line interface:

Lakka documentation - Accessing Lakka command line interface

Then start Retroarch from the command line:

retroarch --verbose

This should at least give you an error message. I don’t know if it helps, but you could try different values for video_monitor_index in the retroarch.cfg config file.

Are these adapters using the GPIO pins of the RPI to output video? This could require drivers that Lakka does not have.

This is what I get if I run “retroarch --verbose”

Lakka (official): 3.1 (RPi2.arm)
Lakka:~ # retroarch --verbose
[INFO] RetroArch 1.9.4 (Git c226bd87f4)
[INFO] === Build =======================================
[INFO] Capabilities:  NEON VFPv3 VFPv4
[INFO] Built: Jun  3 2021
[INFO] Version: 1.9.4
[INFO] Git: c226bd87f4
[INFO] =================================================
[INFO] [Input]: Found input driver: "udev".
[INFO] [Environ]: SET_PIXEL_FORMAT: RGB565.
[INFO] Version of libretro API: 1
[INFO] Compiled against API: 1
[INFO] [Audio]: Set audio input rate to: 48000.00 Hz.
[INFO] [Video]: Video @ fullscreen
[INFO] [Video]: Starting threaded video driver ...
[ERROR] [KMS]: Couldn't find a suitable DRM device.
[INFO] [GL]: Found GL context: null
[INFO] [GL]: Detecting screen resolution 320x240.
[INFO] [GL]: Vendor: (null), Renderer: (null).
[INFO] [GL]: Version: (null).
Segmentation fault

Note: the Retrotink Ultimate works in Lakka v2, so could this be a video driver compatibility issue that is new in v3 perhaps?

This means that it wasn’t able to find a display device to output to. The same would happen if you were trying to output to an HDMI monitor that you forgot to plug in.

As far as I understand, the video drivers indeed have changed between Lakka 2.3.2 and Lakka 3.0, before it used the Videocore drivers and no KMS, now it uses the generic Mesa driver and KMS. I do not know if the driver that’s responsible for video output over GPIO is compatible with KMS. It would be helpful to consult the vendor of your adapter to know what driver setup is needed. If it only works with the Videocore driver, you’d have to get a custom build of Lakka that is configured to use this driver.

This issue should be fixed on latest stable. Please verify.

1 Like

No it’s not working. (Rpi 3B+, Pi2SCART) Lakka 3.2. It worked on 2.3.2.

config.txt (modified as per http://pi2jamma.info)

disable_audio_dither=1

dtparam=audio=on

dtoverlay=vga666

enable_dpi_lcd=1

display_default_lcd=1

dpi_group=2

dpi_mode=87

hdmi_timings=320 1 16 30 34 240 1 2 3 22 0 0 0 60 0 6400000 1

1 Like

It is also still not working for me in Lakka 3.2 (gets stuck on the flower splashscreen). Rpi 3B+, Retrotink Ultimate. It worked in 2.3.2.

config.txt:

dtparam=audio=on
dtoverlay=dpi24
enable_dpi_lcd=1
display_default_lcd=1
dpi_output_format=519
dpi_group=2
dpi_mode=87
hdmi_timings=2048 1 180 202 300 240 1 3 5 14 0 0 0 60 0 42954545 1

I saw that distroconfig.txt also specifies dtoverlay, so I tried commenting out the “include distroconfig.txt” in config.txt but it did not make a difference.

I tried as well with Rpi 3B, Retrotink Ultimate and Lakka 3.2 and no image either. I really hope this gets sorted.

1 Like

I also am hoping for a fix or solution for this. I’m in the process of setting up a RPi arcade cabinet for RPi4. Saw the video where Bahn Yuki got retrotink working on Lakka, and wanted to give it a try. Well, he used 2.3.1 image (which I can’t find to try). I get stuck at a very narrow flower on my CRT using his settings.

I’m wondering if there is a retroarch setting that can be tinkered with in order to prevent its segmentation fault. I tried setting the interface to rgui but that didn’t make any difference. I’m looking in the filesystem for the retroarch.cfg, but the only one I found was the placeholder in /etc, and I can’t figure out how to remount /etc as rw to edit it.

I’ve got a backup Rpi3b+ with retropie which works with the retrotink, so I’m not totally sunk, but it would be nice to have the added power from Pi4. Most of my experience is with RetroPie, so I’m a little lost with how to operate Lakka. Still want to make it work.

EDIT: So I played with some config settings in retroarch. I changed the viewport to 720x480 instead of the default 1200x900. I turned threaded video and vsync off. And this time when I ran retroarch I didn’t segfault. I didn’t get a full launch either, but I didn’t segfault, so thats some progress. Here’s the verbose output log.

INFO] RetroArch 1.9.5 (Git 6738fa57aa) [INFO] === Build ======================================= [INFO] Capabilities: ASIMD [INFO] Built: Jun 18 2021 [INFO] Version: 1.9.5 [INFO] Git: 6738fa57aa [INFO] ================================================= [INFO] [Input]: Found input driver: “udev”. [INFO] [Environ]: SET_PIXEL_FORMAT: RGB565. [INFO] Version of libretro API: 1 [INFO] Compiled against API: 1 [INFO] [Audio]: Set audio input rate to: 48000.00 Hz. [INFO] [Video]: Video @ fullscreen [ERROR] [KMS]: Couldn’t find a suitable DRM device. [INFO] [GL]: Found GL context: null [INFO] [GL]: Detecting screen resolution 320x240. [INFO] [GL]: Vendor: (null), Renderer: (null). [INFO] [GL]: Version: (null). [ERROR] [Video]: Cannot open video driver … Exiting … [ERROR] Fatal error received in: “init_video()” [INFO] [Core]: Content ran for a total of: 00 hours, 00 minutes, 00 seconds. [INFO] [Core]: Unloading core… [INFO] [Core]: Unloading core symbols… [INFO] [Video]: Does not have enough samples for monitor refresh rate estimation. Requires to run for at least 4096 frames.

I think I might play with the video driver next and see if I get any headway.

EDIT2: Vulkan had some unusual output on the console, but nothing to write home about. Null video driver obviously works but results in, well, no video.

Guys, I did it. Sortof. I changed dtoverlay to fake kms and retroarch launched into the gui with GL driver.

Downside is that it is SUPER squished horizonally with my hdmi timings, which are

hdmi_timings=3840 1 109 343 343 224 1 19 3 16 0 0 0 60 0 72925291 1

So squished that its illegible/unusable. I saw this same behavior inside of retroarch on retropie on Rpi3 and retrotink. I think I will play with some settings more, but if anyone has any suggestions on timing settings to get less squished, that would be helpful. I tried changing 3840 to 1920, but that resulted in no picture (blue input screen which vibrated) on my TV. So I’m sure its just a matter of tweaking. Hope this helps someone else.

1 Like