Latest Lakka stopped working on my CRT with Rpi3

Hello there. Since Lakka 2.3.2 I use my Sony Wega CRT along with my Raspberry Pi 3, with Retrotink Ultimate hat via component. However, as of version 3,0, all I get is a blank screen, even with the HDMI timings from before. Anyone have any idea about how can I get lakka working again with the latest version? BTW, The current timings I´m using on my config.txt are: hdmi_timings=2048 1 180 202 300 240 1 3 5 14 0 0 0 60 0 42954545 1

I don’t have a solution, but there’s more info here: Lakka lacks crt support?

As suggested in the thread that is linked above, the issue is probably that the display driver does not support KMS with video output over GPIO. Also, the config.txt commands that enable video output over GPIO are probably missing. This is how it looks currently:

Lakka-LibreELEC/distroconfig.txt at Lakka-v3.x · libretro/Lakka-LibreELEC (github.com)

There are probably some settings missing. Please post your old config.txt from your working setup here. Maybe it helps to change dtoverlay=vc4-kms-v3d to dtoverlay=vc4-fkms-v3d, but you probably need the other missing values as well.

If it turns out that the display driver cannot be configured to use the GPIO video out with KMS, you will need to compile your own version of Lakka, specifically, you would need to revert the changes that have been made to all video driver related settings (switch back to bcm2835-driver, compile Retroarch with the old VideoCore settings).

Here is an example commit for the changes you’d have to make: GPiCase: Switch back to BCM2835-driver (#1346) · libretro/[email protected] (github.com)

These code changes are for the GPiCase, but it should be very similar for the RPI2/RPI3.