List of S905 and S905X Android boxes that support Lakka

lakka
s905
s905x

#1

Have you successfully installed Lakka to one of these boxes?

If so please post as much of the following information as you can:

  • Which S905(X) device/model you used
  • Which version of Lakka
  • Which TDB file

Some S905(x) boxes come locked down, making them unusuable. It can also be hard (or just tedious) to figure out which TDB is necessary to flash Lakka to S905(X) devices. I’m hoping that this thread can serve as a reliable way to help folks get their Lakka builds starting out on the right foot.

There is a thread in the LibreELEC forums that can be helpful, although it too has a broader focus: https://forum.libreelec.tv/thread/9759-choosing-a-s905-s905x-s905d-s905w-s912-box-guide/

S905X Boxes (Model – LakkaVer – TDB)

  • Bqeel M9Cmax 2G/16G – Lakka 2.1 – Unknown TDB
  • T95m – Lakka 2.1 RC2 – Unknown TDB (source thread)
  • NexBox 905X A95X-B7N 2G/16G – Unknown Lakka ver – Unknown TDB (source thread)
  • Libre Computer AML-S905X-CC (Le Potato) - Lakka 2.1 - Unknown TDB (source: Lakka dev gouchi)

S905 Boxes (Model – LakkaVer – TDB)


#2

I’ve started out by adding the Bqeel M9Cmax to the list. I’ve successfully installed Lakka 2.1 to one of these in December, but alas I didn’t log which TDB I used and it’s been damaged since then.


#3

Don’t know if this topic is just about linking other threads, but ETA Prime got Lakka running on Le Potato and did a video review of it. If someone is interested.

If my post sounds off-topic or advertising, feel free to edit/erase it :slight_smile:


#4

That’s perfect. Please feel free post in this thread as well as posting links to other threads or resources like that.


#6

Work with tanix tx3 mini and correct dtb file :slight_smile: S905W soc


#7

I just received my NexBox A5 and flashed LAKKA.TV directly to internal memory. It works like a charm. All Hardware components are working fine, even wifi and bluetooth work out of the box. The Box is fast enough to run n64 emulation with Parallel (especially oot). Games with expansion pack seem to work a little choppy on Paralle, but i’m sure its all about configuration (or using mupen64)

NEXBOX A5 4K, TV-Box Amlogic-S905X, 1GB, DDR3 + 16GB, eMMC, Android 6,0, BT4.0


#8

Which DTB file did you use?


#9

Sorry, my fault. Its the Lakka.tv image 2.1 and i used the dtb files from the FAQ

http://www.lakka.tv/doc/S905/

https://sx05.eu/s905/8.2/device_trees/S905X/gxl_p212_1g.dtb


#10

Perfect, thank you for contributing!


#11

Hey Mark. Another device.

Got a T6(https://www.banggood.com/pt/T6-Amlogic-S905X-2GB-RAM-16GB-ROM-TV-Box-p-1125931.html) AMLogic S905X, 2GB DDR3 + 16GB eMMC from a friend and it booted. Couldn’t test further cause i have no wired controller, but using the keyboard, what i got so far:

  • Randomness of FPS and performance at the main menu. Sometimes, it starts and stay 60fps, sometimes 40. Not a issue at all, pretty usable.
  • HDMI recognized, but with no sound.
  • Wireless and Wired network working great
  • Some N64 games:
    • Goldeneye 007 started at 57 FPS, sometimes drops to 30, but is pretty playable
    • Killer Instinct Gold floats between 47 and 55 FPS
    • Super Mario 64 runs great, with 59 FPS almost all time.
  • Forgot to say: Lakka 2.1-Release was the version i used.

Steps to install and boot

  • Burn lakka to a usb drive.
  • Get gxl_p212_2g.dtb and rename it to dtb.img. Place it at /boot
  • Plug the usb disk on USB-2 port. USB-1 does not seems to boot other OSes.
  • Wait for about 40seconds to boot. Takes more time than the eMMC installed OS to pass bootloader screen.
  • Wait for lakka to finish disk increase and reboot.

#12

Hey everyone; looking to understand whether or not my board is compatible with Lakka, as I’m fairly new to the single board computers in general, and my first one (Raspberry Pi 3B/RetroPie) was a fairly straightforward process.

I picked up a Le Potato (AML-S905X-CC) from their official website, and handled all of the instructions fairly easily. Downloaded the image they list right on their website (https://libre.computer/products/boards/aml-s905x-cc/) and flashed it to a Samsung EVO 32GB memory card (it’s yellow, for those not familiar with the specific names of SS memory cards). Plugged the memory card into the unit and looked to see if it would unpack, but unfortunately, I get nothing but a black screen.

The website could have an outdated version of LAKKA on it, or maybe I’m missing a step in between, but thought I’d post here to see if anyone has had any success getting this up and running successfully with this specific board. I’ve browsed the forums (as well as the general internet), but I haven’t found any “how-to’s” that talk about this board and LAKKA.

Any assistance/links pointing me in a general direction would be greatly appreciated, and thank you!


#13

I loaded the latest Lakka (Lakka-S905.arm-2.0-rc3.img) onto a S905 MXQ Pro+ 4K

Here are the steps I took to load it:

  1. Used the LibreElec SD card creator and selected Lakka-S905.arm-2.0-rc3.img.gz as the image to write
  2. Copied the dtb file gxbb_p201_2G.dtb from here, renamed it to dtb.img and overwrite the existing dtb.img on the SD card
  3. Start the Android Box without the SD card inserted
  4. Using the onboard Android OS (which is garbage on this box) I chose the Backup and Update App, and pointed it to a dummy (empty) zip file.
  5. Plug in the Lakka SD card
  6. Press the update button in the Backup and Update App. The android box will then reboot and attempt to update, but since it’s an empty/dummy file it will default to boot from the SD card

Wireless and bluetooth work just fine. It recognizes my PS3 controller without issue. Most cores seem to work better than an RPi. N64 works pretty well if the resolution and gfx settings are set to low. Cant really complain for a 30USD box.

I will say that the heat sink on the CPU in this box was not good (just a block of metal stickied on). I opened the box up and installed my own and that seems to have really helped with the heat this thing generates.


#14

I have a s905x that won’t boot from sd card so i tried the update mthod from dummy zip and it got stuck, this is what the log said w try mount /dev/block/sda sucessful mount I: 1 keys loaded from /res/keys verifing update package E:footer is wrong I:verify_file returned 1 E:signiture verification failed installation aborted

Any idea’s might not have the right dtb?


#15

Someone can help configure it the PHICOMM n1?

the following configuration: processor : amlogic s905d cortex - a53 ram+rom : 2g+ 8g usb 2.0*2

At the Forum,i just find S905-K1dtb.img , but no PHICOMM n1 use P230-2S so plese Someone can help configure it the PHICOMM n1?

thx a lot!!!

at present

n1 can use volumio ,CoreELEC,and the Armbian linux


#16

Thanks for sharing this. I have an MXV+ box, it won’t boot from sd. I’m going to try your technique. Love Lakka got an MXV box running fine.


#17

Can confirm Sunvell T95X 1GB is working great with lakka 2.0. Every subsequent build seems to be broken for me. Latest 2.1.1 build broke wifi (external bluetooth works fine though). In 2.1 i was experiencing lag when browsing thru menus

Since 2.0 is working great for me the only feature i’m missing is favorites option. Any chance for adding this feature to 2.0 base while keeping everything else the same ?


#18

Resurrecting this thread. Tested Lakka 2.2 on the same device and

  • Main menu no longer suffers from random performance drop
  • HDMI has sound
  • Nintendo 64 games remain the same as my last report.

:slight_smile: