Mega Bezel Reflection Shader! - Feedback and Updates

@JHorbach1, Ok what is going on is the auto mask size is doubling the size when you are at the full 4k width.

So to fix this set the mask size to 1 instead of 0 (Auto)

I’m considering that perhaps the mask size should be 1 by default instead of 0. Then we would not have an inconsistency between Guest’s standalone shader and the one inside the Mega Bezel.

Note: I should probably also change the auto mode to check the vertical height of the viewport rather than taking into account the width.


I tried changing the size to one before, did it again, no good, same strange pattern (it changes a little bit, but still looks ugly, and changing to 4:3 “fix” it).

P.S.: I always use mask size one with the non NTSC version, it looks fine.

I suppose it can be a problem with my setup…


Do note that there’s also a second Slot Mask Size setting in addition to the CRT Mask Size Setting that will also affect the appearance of your slot mask pattern.

Sounds like one or both of them are on Auto or at least one is on 2. Check both Mask Size settings.

I see that your posted parameters contain neither setting specified. You might want to try setting the CRT Mask Size to 2 and the Slot Mask size to 1. If that doesn’t look the way you want then Set the CRT Mask Size to 1 and see see if the Slot Mask setting of 1 or 2 is what you want.

Also, is your computer outputting 4K at RGB 4:4:4? That could explain why the colours look strange at lower mask sizes or with certain mask sizes. In addition to that, the Mask Layout needs to be toggled to match your particular display.

1 Like

I’ll check on a 4k screen, perhaps there’s something wrong with the logic choosing auto accidentally.

Basically if you have mask size set to 1 it is never supposed to change size, regardless of the viewport size/aspect ratio. So since it is there must be something broken.

1 Like

Very good point @Cyber this is true I forgot about the second one, so make sure both are set to 1

I’ll be changing the defaults to 1 so we can avoid inconsistencies like this in the future

1 Like

Remember there’s also a Slot Mask Size option that can be set to Auto as well.

I’m not seeing a fixed CRT Mask Size nor Slot Mask Size Setting in his posted settings.

Good thing I recently started making Slot Mask presets! Lol …And to think I used to think it was impossible to get a decent looking, somewhat accurate Slot Mask CRT Shader effect. My first attempts were abysmal so I left it on the back burner for a while until I eventually tried it again! Now I use them almost exclusively while playing, I still love my aperture grill for NES though!

Just give us the heads up when you’re ready so we can make the necessary adjustments to our presets.

By “changing the defaults to 1” does that mean the behaviour of Auto will remain the same but the base preset settings for both CRT Mask Size and Slot Mask Size will be set to 1?

Or does that mean the base preset will remain set to Auto but the behaviour of Auto will be changed to select 1 by default at 4K resolution?

That did the trick! Thank you both! @Cyber and @HyperspaceMadness.

Oh, and my TV is a LG OLED C1 which Mask Layout would work better to me? I know nothing about subpixels.


You’re welcome @JHorbach1! Glad I could be of assistance!

I use an LG OLED E6P with the default Mask Layout. Due to the strange nature of current OLED TV subpixels even if I try the flipped layout, it still looks decent. It’s not the same as when the incorrect layout is used on a standard RGB or BGR LCD panel.

So don’t be afraid to toggle it if at anytime, your colours look off, particularly at the finer Mask Sizes. Let your eyes be the judge.


So it would be set to 1 by default which means a fixed mask size of 1 no matter what the resolution is.

The auto option would still be there if someone wants to use it, but they would have to explicitly set it themselves.

If you want your presets to use the auto option then could set the mask sizes to 0 inside your presets to avoid any impact when it changes.


Understood. Thanks for the clarification!

I shouldn’t be negatively impacted since I already use either the Auto (0) setting or various fixed settings in all of my presets.

Sometimes I go back and change settings to Auto for increased compatibility once I test and am satisfied that Auto is giving me intended results.

Sorry to bother again, but now I’m facing problems with crop overscan in the NTSC version, it creates some kind of reflection in game. Super Mario 64, for example, the UI reflects itself whenever I use the crop option.


Could you post a screenshot?


Sure can!

1 Like

at 4k on an OLED C9 and HDR I like this look:

mask_bloom = "0.750000"
shadowMask = "12.000000"
masksize = "1.000000"
maskstr = "1.000000"

As for the N64 picture, try saving your preset and posting it here.


@HyperspaceMadness, I think I found another problem. When I change the Crop Top % setting the bottom is cropped and vice versa.

I should also mention that the weirdest thing happened with the Frame Noise. The Frame Noise is now independent from the Bezel Noise all together. It stays the same even if Independent Frame Color is 0 or 1.

1 Like

I’ll check it out :slight_smile:

So this something I did on purpose, in my testing it seemed that even if you were sharing the base color across the bezel and frame that the frame always looked better with a lower amount of noise. So given this I made it always independent. Maybe I can add a note in with the parameter name to point this out.

I’ve looked into this and fixed it locally, it was the halation/glow not being affected by the crop properly.

Note: The fixes are committed to my Github if you want to get it from there. Even if you are not setup with git you can always download a zip:


I am thinking putting the Noise settings in with Bezel and Frame General would be good.


I agree that would solve the confusion, good idea! :smile:


Hey guys, how would I go about fine-tuning the ScaleFX settings to get more smooth curves/edges? Like, this is the default look of the MBZ__0__SMOOTH-ADV preset:

However, the MBZ__0__SMOOTH-ADV__LCD-GRID preset looks much sharper out of the box, with much finer pixellation around curves and edges. For instance, you can see the difference on Yoshi’s nose.

If I want the lovely scanlines of the MBZ__0__SMOOTH-ADV preset with the sharp and smooth look of the MBZ__0__SMOOTH-ADV__LCD-GRID, which settings are the best to tweak (assuming I use the former preset)?