Mounting NFS/Samba on RPi

Hello everyone,

Lakka is working fine for me on RPi3, only thing I haven’t been able to get working is to play ROMs I have stored on my Synology NAS. I tried multiple suggestions from both this forum and other places, none seem to work and the errors I get are rather vague. So I’m hoping someone can help me, I have the feeling I’m overlooking something obvious.

Setup: Synology NAS with both NFS & Samba enabled. RaspberryPi 3 with latest version of Lakka. Connected through wired LAN. I work with Putty on Windows to SSH.

First I tried the official way as described here. The result in the /storage/.config/system.d/storage-roms-nas.mount file is this:

[Unit] Description=cifs mount script Requires=network-online.service After=network-online.service Before=retroarch.service

[Mount] What=//192.168.0.xxx/media/emulation/roms Where=/storage/roms/nas Options=username=xxx,password=xxx,rw Type=cifs

[Install] WantedBy=multi-user.target

When I try to start it through systemtcl I get this error:

Job for storage-roms-nas.mount failed. See “systemctl status storage-roms-nas.mount” and “journalctl -xe” for details.

journalctl gives me this log:

Jan 02 15:16:12 Lakka systemd[1]: Mounting cifs mount script… Jan 02 15:16:12 Lakka systemd[1]: storage-roms-nas.mount: Mount process exited, code=exited status=255 Jan 02 15:16:12 Lakka systemd[1]: Failed to mount cifs mount script. Jan 02 15:16:12 Lakka systemd[1]: storage-roms-nas.mount: Unit entered failed state.

When I try to mount it regularly through the mount command I get this error:

Lakka:~ # mount -t cifs -o username=xxx,password=xxx,rw //192.168.0.xxx/Media/Emulation/Roms /storage/roms/nas

mount: mounting //192.168.0.xxx/Media/Emulation/Roms on /storage/roms/nas failed : Operation not supported

Any help would be greatly appreciated!

For security reasons, there have been changes to samba, particularly for LibreELEC (Lakka’s base), see these release notes.

I have no way of testing but some googling (ref.) suggests that adding:

-o vers=1.0

to the mount command (or some other protocol version, depends on your NAS) might fix it.

2 Likes

Whilst I haven’t tried it in the latest Lakka v2.1 yet on my RPi3, I got similar and/or related errors with the previous releases. Whilst I was able to mount the share, RetroArch failed to scan the files. Here’s some info on this, perhaps you can find useful hints that work for you:

https://forums.libretro.com/t/nfs-doesnt-work-when-mount-in-synology-nas/

Thanks metchebe and beherit for your help. I just tried it this morning and mounting now works again thanks to the suggestion from metchebe. The method described in the official Lakka documentation now works properly after adding ,ver=1.0 to the Options part of the .mount file.

So all in all my file looks like this:

[Unit] Description=cifs mount script Requires=network-online.service After=network-online.service Before=retroarch.service

[Mount] What=//192.168.0.31/roms Where=/storage/roms/nas Options=username=myusername,password=mypassword,rw,ver=1.0 Type=cifs

[Install] WantedBy=multi-user.target

I’m new to Lakka and this community, but maybe someone with access to the documentation could change this for new users? In the meantime I hope this thread helps them solve this issue as well. Thanks again for the help.

2 Likes

Great! You’re welcome :slight_smile:

1 Like

Thank you for writing down your final Options value, that helped me a lot. Though, I noticed that there’s a missing ‘s’ and the Type=cifs should be on a new line. Options=username=myusername,password=mypassword,rw,vers=1.0 Type=cifs

I tried the method above on a Time Capsule but it doesn’t work. how can I mount a Time Capsule Drive? pls help thank you