Serving ROMs from a NAS is not currently working

Hello guys, I’m a Lakka newbie, I saw how cool of a system it is and I setup it up on my Raspberry Pie 2

I want to setup roms via a SMB share since all my roms are on a Windows 10 Machine.

So I started out reading several post on how to get this done: Here

However it did not work. So I began searching for other people have been dealing with the same issue: Here is the article I found and tried their suggested fixes for the issue. Here

Here is my current storage-roms-nas.mount file:

[Unit]
Description=cifs mount script
Requires=network-online.service
After=network-online.service
Before=retroarch.service

[Mount]
What=//10.0.0.110/roms
Where=/storage/roms/nas
Options=username=Gpx45,password=Pa11word,rw,vers=3.0
Type=cifs

[Install]
WantedBy=multi-user.target

I’ve tried switching the vers to 1.0, 1.2, and 2.0 as well but it did not work. I have also tried without the option vers as well

I noticed if I remove the vers option and try mounting manually each time with the following command: systemctl start storage-roms-nas.mount

It will mount perfectly fine, so I have a feeling that on the Windows side, the SMB service and firewalls are working properly.

However it will not work automatically.

Here is what I found when exploring the kernel logs from journalctl

I have tried to find a solution to this issue but I was not able to find anything that would remedy it. If anyone could spare some time and knowlege I’d be grateful for any tips.

Thank you in advance. Gpx45

I’m sorry guys I have found a solution that has worked for me.

Here is a reply to an article that resolve the issue for me.