Neko Project II kai (PC-9801) core (different nekop2, meowPC98)


#81

Is it possible for this core to run .nfd files?


#82

Thanks for your report.

It is degrade miss.
I fixed this again.


#83

Nice, confirmed working on my end. You’re welcome and and thank you as well.


#84

I’m playing New 3D Golf Simulation: Haruka Naru Augusta 遥かなるオーガスタ

It works on Nintendo N3DS (but downscaled graphics are too difficult to use, speed is also slow)

On Mac, RetroArch crashes when I select content.

Using same date nightly builds from buildbot.


#86

To matt.

I could play the game on Linux and Windows.
I don’t have Mac, then I’ll take a time to check on Mac.


edit: I heard that it can’t use F12 menu with mouse on Mac.
Then you may can’t set ‘course disk’ to FDD2 slot.


#87

Thanks I could launch some of them. :slight_smile:

I was trying to launch a lot of games to take pictures for a database, but I’ll probably just skip fdd for now as it’s too much work if I need to convert them all.


#88

text cannot be diaplayed. please help me


#89

do you have all the bios’s setup correctly?


#90

I have the font.bmp, but I don’t know which floder is the right one. please help me


#91

The location is system/np2/font.bmp

Everything is written in the core info file:
load core->np2kai then go to information->core info.


#92

Tatsuya79,

Two questions, first, do you know if it will cause problems to have only a FONT.ROM with no font.bmp? I updated recently after a while out and I can’t seem to get NP2K working correctly anymore (windows I’m missing fonts no matter what but it does seem to be finding my bios, Mac it doesn’t seem to find anything no matter where I place it. MeowPC vanilla is working fine though). Also, is it workable to just rename FONT.ROM to font.bmp and be done with it or do I need a real font.bmp?

Second (ok technically third), I’ve been trying to work up the energy to redo the keyboard mapping in NP2K to make it a little more adaptable and while I was doing some code diving I noticed you explicitly disabled keyboard support if joystick mapping is enabled in your patch to add joystick functionality. Could you walk me through why you went that way?

I was thinking of re-allowing both keyboard and joystick at the same time as there are a number of games that are completely playable with the joystick save for a “Are you over 20? Y/N” screen, but I don’t want to cause any other issues or get in your way.


#93

Thanks, text can be displayed now.

l’m very happy


#94

I’m not sure why there’s both font.rom and font.bmp, Azo234 will know better than me.
But they’re not the same size. You can get the rom in Mame standard rom set, pc9821 or pc9801 series of bios.

I had issues when trying to get joy2key + keyboard working together. Like it worked in dos moving a cursor to select a Touhou game, but as soon as the game launched nothing worked any more. :face_with_raised_eyebrow:

Anyway, we have a new system for mapping keyboard keys to the gamepad, it’s already working in dosbox, bluemsx or px68k.
It just needs the core to have the input descriptor so you can have the “Keyboard” in Quickmenu “Controls”. (see commit here)
When your input device is on “Keyboard” you can then make a remap on any gamepad key with a keyboard key of your choice.

Problem is Radius tried to add it and couldn’t get it working in Np2kai.
I also tried myself and always got the core to crash on start… :expressionless:


#95

Oh badass. That’s definitely something to look forward to once working. Does it require a nightly build to test the other cores?


#96

Yes, you need to use updated versions of retroarch and the cores.


#97

FONT.ROM is data dumped from genuine PC-98.
FONT.BMP will be rendered using the OS font when there is no FONT.ROM.
(I’m worried that Western users own Japanese fonts.:u55b6:)
If it is either FONT.ROM or FONT.BMP, it should work.

Generation of FONT.BMP has not been confirmed to work on Mac.
Mac port is not able to verify other than being able to build. Even operation. :scream:

Thanks to reporter and answerer.
(Thank you for your quick answer, Tetsuya79.:wink:)


#98

Here is an other problem load core->np2kai then go to information->core info. but only the np2kai’s core info cann’t be displayed other cores haven’t this problem

Yesterday the np2kai’s core info can be displayed but now it is cann’t be displayed.This is a strange thing! please help me


#99

Go to “online updater” and do “update core info files”.
It’s working fine here.


#100

Now the np2kai’s core info is auto displayed. everything back to normal Thank you very much.


#101

Thanks! I got New 3D Golf Simulation to work.

I was trying using .FDD disk images, which result in crash. I converted my disk images to .FDI and now my copy runs on Mac.

F12 Mouse is indeed a problem on Mac, which makes mouse controlled games like Alaskan Malamute G.C. (another golf game) pretty much impossible to play right now.

It would be cool if touch screen could be used (devices like 3DS, Vita) as Mouse control?