Neko Project II kai (PC-9801) core (different nekop2, meowPC98)


#123

For individual switches can’t a short detail be added nest to each switch saying that it does?

I think so too.
I think that it should be able to be executed in the same procedure as the actual machine of PC-98.
If other procedures are added, it will be nested.
However, if safety and comfort can be provided, I agree to implement it.

I do not consider compatibility with other NP2.
NP2kai should be used exclusively with other NP2.


#124

is it possible for np2kai to pick the correct sound board based on the year of release of the chosen game? either from filename Haruka Naru Augusta (1991).hdi or from a libretro-database (if one were to be created?)

also, is there an update on getting the mouse to work on macOS? it is still very much needed.


#125

How do I press GRPH/GRAPH key? I’m using gamepad.


#126

You can use right Alt key as PC98’s GRPH/GRAPH key.


#127

[Notice]

I changed BIOS/system directory name, ‘np2’ to ‘np2kai’.
Please rename to use.

Thanks.


#129

I’m using the armhf version and it loads up until the title screen. the emulated core crashes and displays only A>op. Ive tried adjusting some of the configs. Emulated model and ram but still crashes, any help?


#130

NP2kai’s configuration file is located in system directory of RetroArch.
Not only core options but also many setting items are included.

Can you delete NP2kai’s configuration file once?


#132

Does it support pc88 games? I saw d88 format support in core info.


#133

@AZO234 Hello

i downloaded buildbot version np2kai_libretro.so for raspberry. linux > armhf > 2018-04-02_cores

I tested m3u files but without success : Cuty Cop (1994)(ICE).m3u

/recalbox/share/roms/pc98/Cuty Cop (1994)(ICE)(Disk 1 of 2).fdd
/recalbox/share/roms/pc98/Cuty Cop (1994)(ICE)(Disk 2 of 2).fdd

single game (fdi, hdi) work perfectely but with m3u files nothing. and when I tried to launch Cuty Cop (1994)(ICE)(Disk 1 of 2).fdd and I used np2kai menu (L2) TO add disk 2 I open FDD2 and I do not see my files.

FDD1

FDD2

I use only gamepad controller.


#134

I checked loading with .m3u file. (not Cuty Cop)
I couldn’t see you saying.

I started with .m3u (2 FDD images load), FDD2 file selector’s path is right.

However, I started with FDD1 only,
FDD2 file selector’s path is ‘BIOS/np2kai’.

Please you check .m3u loading or FDD1 image loading.
Otherwise, 1 FDD image file only is written in .m3u file?

Regard.


#135

Hello @AZO234

what is the content of your m3u file ?

this is my np2kai.cfg

Is there something missing?

[NekoProjectIIkai]
FDfolder = /recalbox/share/roms/pc98/
HDfolder = /recalbox/share/roms/pc98/
bmap_Dir = 
bmap_Num = 0
fontfile = /recalbox/share/bios/np2kai/font.bmp
hdrvroot = 
hdrv_acc = 0
use_hdrv = true
hdrvroot = 
hdrv_acc = 0
pc_model = VX
clk_base = 2457600
clk_mult = 4
DIPswtch = 3e f3 7b 
MEMswtch = 48 05 04 00 01 00 00 6e 
ExMemory = 7
HDD1FILE = 
HDD2FILE = 
IDERWAIT = 0
IDEWWAIT = 0
IDEMWAIT = 0
SampleHz = 44100
Latencys = 0
SNDboard = 4
BEEP_vol = 3
SND14vol = 0c 0c 08 06 03 0c 
opt26BRD = d1
opt86BRD = 7f
optSPBRD = d1
optSPBVR = 0
optSPBVL = 0
optSPB_X = true
optMPU98 = 82
optMPUAT = false
opt118io = 188
opt118id = 80
opt118dm = 3
opt118if = 12
opt118ip = 12
opt118im = 255
optwssid = 70
optwssdm = 1
optwssip = 3
optsb16p = d2
optsb16d = 3
optsb16i = 5
volume_F = 64
volume_S = 64
volume_A = 64
volume_P = 64
volume_R = 64
DAVOLUME = 128
USEFMGEN = true
Seek_Snd = false
Seek_Vol = 80
btnRAPID = false
btn_MODE = false
MS_RAPID = false
VRAMwait = 01 01 06 01 08 01 
DispSync = true
Real_Pal = false
RPal_tim = 32
uPD72020 = false
GRCG_EGC = 3
color16b = true
skipline = true
skplight = 255
LCD_MODE = 0
pc9861_e = false
pc9861_s = 17 04 1f 
pc9861_j = 0c 0c 02 10 3f 3f 
calendar = false
USE144FD = false
NP2NETTAP = 
NP2NETPMM = false
USELGY98 = false
LGY98_IO = 4304
LGY98IRQ = 5
LGY98MAC = 00 40 26 12 34 56 
WAB_ANSW = 1
USE_CLGD = false
CLGDTYPE = 91
CLGDFCUR = false
TIMERFIX = true
WINNTFIX = false
SYSIOMSK = ff00
MEMCHKMX = 0
SBEEPLEN = 0
SBEEPLEN = false
cpu_vend = 
cpu_fami = 6
cpu_mode = 3
cpu_step = 3
cpu_feat = 1808011
cpu_f_ex = 0
FPU_TYPE = 0
keyboard = 106
mpu98map = 
mpu98min = 
mpu98mdl = 
mpu98def = 
e_resume = false
sounddrv = nosound
s_NOWAIT = false
SkpFrame = 0
jast_snd = false

/bios/np2kai (Bios)

2608_RIM.WAV
2608_SD.WAV
2608_TOM.WAV
2608_TOP.WAV
BIOS.ROM
FONT.ROM
SOUND.ROM
2608_BD.WAV
2608_HH.WAV
font.tmp
ITF.ROM
np2kai.cfg

when I launch only FDD disk 1 file (same game)

Powering on HDMI with explicit settings (CEA mode 4)
Powering on HDMI with preferred settings
/usr/bin/retroarch -L /usr/lib/libretro/np2kai_libretro.so --config /recalbox/share/system/configs/retroarch/retroarchcustom.cfg /recalbox/share/roms/pc98/Cuty Cop (1994)(ICE)(Disk 1 of 2).fdd
arg_0:np2kai
arg_1:/recalbox/share/roms/pc98/Cuty Cop (1994)(ICE)(Disk 1 of 2).fdd
Samples:782
INIT done

#136

FD file image’s path is not recorded in config file.

I checked Cuty Cop FDD images.
Initially, it seems that those FDD image files does not started.
I set Cuty Cop dick1 FDD image to FDD1, NP2kai could not read.
Can those FDD files can start any other PC98 core?


#137

I have not tested other cores. I CONVERT fdd in fdi with virtual floppy image I tested several convert games in multidisk fdi format with neko project II for computer, it works

like Girls Paradise (1989)(Great)(Disk 1 of 2)(Disk A).fdi

but in raspberry , no luck. Doesn’t work, I will try tomorrow morning.


#138

@AZO234

I tried a game (with only 1 disk) with one file into m3u file. It doesn’t work i tred few games with 2 disk , same.

How many file ?


#139

That screen is BASIC mode. Floppies are ejected.

Probably, NP2kai cannot read .FDD image files correctly.
I do not know much about Floppy, sorry.

If you can correctly play games using .FDI image conversion, please rely on conversion.


#140

For ordinary PC/AT, PC-98 floppy disk can not be backed up properly.
I think that many failed floppy disk image files are included in the list.

Also, even though the extension is the same, many internal files have different structures.

First of all, please check whether it is an floppy disk image created with the correct 3-mode floppy disk drive and Windows 2000 older.
And try converting file format using VFIC etc.

VFIC (Virtual Floppy Image Converter)
https://www.vector.co.jp/soft/win95/util/se151106.html


#141

@AZO234

i USE vfic TO convert somes games (multidisk)

Girls Paradise (1989)(Great)(Disk 1 of 2)(Disk A).fdd to Girls Paradise (1989)(Great)(Disk 1 of 2)(Disk A).FDI
Cuty Cop (1994)(ICE)(Disk 1 of 2).fdd to Cuty Cop (1994)(ICE)(Disk 1 of 2).FDI
Ys 2 - Ancient Ys Vanished - The Final Chapter (19xx)(Falcom)(Disk 1 of 2)(Program Disk).FDD to Ys 2 - Ancient Ys Vanished - The Final Chapter (19xx)(Falcom)(Disk 1 of 2)(Program Disk).D88

I Have few games in FDI : Metal Orange (1991)(Custom)(Disk 1 of 2)(Disk A).FDI (NO CONVERTION)

All multi disc with/without m3u.files don’t work.

I dont load the second disk in np2kai menu.

all my game are in USB Key (Exfat)

Edit : I moved few multidisc game in microsd , and np2kai menu, fdd2 is available (open in np2kai bios folder instead of the folder roms games. :Z

not when game are in usb key.

m3u does not work anyway in this case (microsd)

IT’S A big problem. I can not load the disc on removable media can you fix it ?


#142

Has removal media have the correct access right?

NP2kai core just call fopen() when it reads file.


#143

@AZO234 removal media have the correct access. All folder are in chmod 777 i haven’t no problem with others cores like px68k and m3u files work fine.

I have only one problem with your core.


#145

We are investigating the problem that the m3u file can not be opened correctly.
Processing of NP2kai is transplanted from px68k by copy and paste.

Even in NP2kai or px68k, if you try to open m3u file RetroArch will kill.

Attempt to read LBA 16, >= LBA 0
CDIF Raw Read error
terminate called after throwing an instance of 'MDFN_Error'

There may be problems with the process of opening core m3u,
but I think there is a problem with RetroArch as well.