Neko Project II kai (PC-9801) core (different nekop2, meowPC98)


#146

(There is no confirmation)
When m3u file is selected,
It seems to be activating another core on memory, not NP2kai core.

RA calls core’s retro_init() and retro_load_game().
I set printf() to see notices in NP2kai core when these functions are called.

I used the debugger to monitor the stack,
RA calls retro function, but stdout output is none.


#147

MDFN_Error is typically from a Mednafen/Beetle emulator, probably Saturn or PSX.
Unless the m3u code kept a mednafen logging style?

I never used m3u so can’t tell you anything, perhaps open a detailed issue report in RetroArch repository?


#148

Thanks Tatuya.

I tell to RA issue.


#149

I wondered why I had not seen any of the recent changes.

np2kai core is missing from Nintendo 3DS builds in 1.7.1 and 1.7.2

It was last present in 1.7.0


#150

rev.16 np2kai core currently crashing on macOS

rev.15 I did not try

rev.14 works OK, I restored it from a backup

is there an archive of old versions?


#151

Just a note to save somebody wasting time like I have done.

Joypad to Keyboard Mapping = ON

will prevent you from using keyboard with game. Game Focus mode and Enable Hotkeys will not work properly, only the keys that are defined as controls will “punch through”.

In Game Ficus mode, ALT will act as GRAPH key :slight_smile:


#152

about Nintendo 3DS builds.

There are build recipes remaining in Libretro/super.
(NP2kai was omitted release plan for comfort?)


#153

about on macOS.

I don’t have Mac, so It will take time to confirm.


#154

about Joypad to Keyboard.

Yes. As you say, you can not enter from the keyboard.
This is to avoid confusing the ‘press’ and ‘release’ status of the keyboard.


#155

I could boot NP2kai rev.16 by Mac.

Is there ‘np2’ directory in system directory?
You must rename it ‘np2kai’.


#156

Very strange. It will not boot for me, even if I start core without any content. Not even on a fresh Guest account.

I have np2kai folder, and also a zip of my old np2 folder with same contents.
I even tried to delete my np2.cfg, retroarch.cfg and retroarch-core-options.cfg files.

After crash, new file temp_.sxx of zero bytes is created in np2kai folder?


#157

I setup RetroArch to clean macOS 13.
Then BIOS files are located to ‘np2kai’ directory in system directory.
Then I run RetroArch, download np2kai core, select core, select content (.nhd file).

Did you try without ‘bios.rom’ ?


#158

Interesting…

If I delete the whole np2kai folder then core boots OK and I can play a game!? (but with no fonts)

Next, if I put an empty np2kai folder then it will not boot and crashes?
Similarly, if I put my full np2kai folder, it also crashes.

Why?


#159

I tried on Guest account (I activated a preset account). And worked correctly.
I put files to User/Shared/RetroArch. (system/np2kai too)
Naturally, Access rights of the files/dirs were changed to everyone/rw.


#160

It is strange…

I have an Intel HD 4000 GPU. Maybe related?

And my system uses APFS filesystem (default version = not case sensitive).

I have a working setup, with two bios directories:

  • np2 (with np2.cfg, for rev.14)
  • np2kai (with np2kai.cfg, for rev.16)

The only thing changed is the core. rev.16 crashes, rev.14 works.

I am back to using rev.14 …for now.


#162

OK, I deleted retroarch.cfg and the core loaded.

So I went through my old retroarch.cfg and found the line causing the problem:

rewind_enable = "true"

Please confirm.

Of course np2kai does not support rewind. But what changed between r14 and r16 that causes this config setting to crash everything?


#163

Now I am getting another, different crash! Even deleting retroarch.cfg does not help.

Using:

  • stable 1.7.3 or nightly
  • latest build of n2paki core (downloaded inside fresh RetroArch)

here are the verbose logs:

Seems to fail just before: [INFO] Environ SET_DISK_CONTROL_INTERFACE.


#164

Hello

I upgrade on my recalbox with retroarch 1.7.3 and uploaded last core on buildbot.libretro.com when i tried to use FDD2 to charge disk 2 , not possible folder it’s not the good…

1522675341-np2kai02.png - envoi d'image avec NoelShack


#165

Hello.

Is it possible to remap the Joy2Key configuration at all, even if through manually creating a configuration file? I want to get a Joypad button mapped to Left Shift for playing Touhou games that use it.

Using Neko Project II kai ver .0.86 kai rev. 16 on Android.


#166

@AZO234 Just saw your twitter message about your health problems and that you’re stopping Np2Kai development for now.

I’d like to thank you for all you’ve done on that program, bringing the FM sound and all the other improvements we wouldn’t have without your work.

いろいろありがとうございました。体に気をつけて。