No Audio 3.5 MM Jack

I managed to install Lakka 4.2 on an Sd card for my RP3B+.

After install I have to add “display_auto_detect=1” into the config.txt file so the display comes up on the 7inch Pi screen that’s connected via the dedicated Pi ribbon cable.

So that works great and got some games played for trial but I had no audio, so I went to figure out how to get the audio to work, my main reference was this YT vid: Enable 3.5mm Audio in Retroarch / Lakka. Analogue sound Raspberry Pi 4. - YouTube

So I ran.

nano /storage/.config/autostart.sh

amixer cset numid=3 1

exited it out saved and rebooted.

Which was very helpful, only thing was my audio still didn’t work, I noticed in the video the presenter was able to change the selected device (by what I’m assuming is left n right arrow keys?) and was able to select a different device. I however seem to get nothing under the device area, even after adding that line above and rebooting. So I enabled SSH, and ran “aplay -L”


Lakka:~ # aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
default
    Default Audio Device
sysdefault
    Default Audio Device
default:CARD=vc4hdmi
    vc4-hdmi, MAI PCM i2s-hifi-0
    Default Audio Device
sysdefault:CARD=vc4hdmi
    vc4-hdmi, MAI PCM i2s-hifi-0
    Default Audio Device
hdmi:CARD=vc4hdmi,DEV=0
    vc4-hdmi, MAI PCM i2s-hifi-0
    HDMI Audio Output
default:CARD=Headphones
    bcm2835 Headphones, bcm2835 Headphones
    Default Audio Device
sysdefault:CARD=Headphones
    bcm2835 Headphones, bcm2835 Headphones
    Default Audio Device

Since I was unable to select a device, I attempted adding sysdefault:CARD=Headphones manuallly via entering it via keyboard inputs and the audio device setting in lakka, rebooting and it shows to save the entery, but I stilll don’t get audio…

I found this thread with the same problem and the same solutions: https://raspberrypi.stackexchange.com/questions/68024/audio-over-speaker-jack-in-lakka

One other option there I tried as well, added “hdmi_ignore_edid_audio=1” to config.txt, powered and and, ughhh no audio. (I’m not using HDMI, I’m using the display ribbon cable, but figured it was worth a shot)

I found one other post: Lakka no audio

where retro_relax, said to set audio device to “hw:0,0”. I entered that manually under lakka audio device, but still no audio.

As I was writing this up, I found the original lakka guide showing the same device change in the audio settings: http://www.lakka.tv/doc/Audio-settings/#switching-audio-device-from-the-gui

I added "audio_device = “default:CARD=Headphones” to config.txt. powered up lakka, still no audio.

As a last ditch efforted I manually entered “default:CARD=Headphones” in the audio device setting area of lakka rebooted, and audio finally worked!!! I was going to just delete this thread creation, but figured, maybe it can help someone who faces the same problem. :slight_smile: