RPi3 no Headphones option for sound output

I just installed Lakka 4.3 on a SD for use in RPi3. I had sound coming from my TV, but when I move to HDMI monitor and minijack, I get no sound.

I found a similar thread, but my aplay output doesn’t include Headphones:

Lakka:~ # aplay -L
    Discard all samples (playback) or generate zero samples (capture)
    Default Audio Device
    Default Audio Device
    vc4-hdmi, MAI PCM i2s-hifi-0
    Default Audio Device
    vc4-hdmi, MAI PCM i2s-hifi-0
    Default Audio Device
    vc4-hdmi, MAI PCM i2s-hifi-0
    HDMI Audio Output

How can I get the system to detect Headphones as a choice?

I’ve tried putting “amixer cset numid=3 1” in /storage/.config/autostart.sh but it didn’t change aplay output after reboot.

I’ve tried putting "hdmi_ignore_edid_audio=1” in /boot/config.txt … I’m not exactly sure whre config.txt should go. It didn’t work in /storage/ either. aplay output is the same.

I changed software to RetroPie 5.10.103-v7+

Then just added this to /boot/config.txt hdmi_ignore_edid_audio=1

Now sound is working on my Pi. Hope this helps someone.

Thank you for the feedback.

We have some documentation about RPi and how to edit bootloader configuration, if needed.