No audio device detected

I recently build an am1 system for lakka so I could play my old games. Got it installed, but am not getting any audio.I can’t select any option in the audio devices option in the menu. None of the audioports work either. I’m a complete noob at linux and command stuff. Any help would be appreciated

There are a bunch of threads on this subforum about getting audio working. Have you looked at any of them?

Are you trying to get audio over HDMI?

I’ve seen a few threads… but none that didn’t have any audio selection option. That was a recent adition to lakka I think. I’d be happy with any sound but hdmi is prefered.

Can you try to provide a log (You need to access lakka command line interface first) ?

and get the ouput of :

lsmod | grep snd
aplay -l

Thank you.

Lakka:~ # aplay -l **** List of PLAYBACK Hardware Devices **** card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: HDMI [HDA ATI HDMI], device 7: HDMI 1 [HDMI 1] Subdevices: 1/1 Subdevice #0: subdevice #0 card 1: Generic [HD-Audio Generic], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog] Subdevices: 1/1 Subdevice #0: subdevice #0

Lakka:~ # lsmod | grep snd snd_hda_codec_realtek 50348 1 snd_hda_codec_generic 44198 1 snd_hda_codec_realtek snd_hda_codec_hdmi 32374 1 snd_hda_intel 20011 0 snd_hda_codec 70522 4 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel snd_hda_core 28411 5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel snd_hwdep 4947 1 snd_hda_codec snd_pcm 61557 4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core

Cant seem to get the log though… or is this what you meant?

Your forgot to provide the output of log.txt.

But can you try to type :

 echo "options snd_hda_intel index=-2" > /storage/.config/modprobe.d/snd_intel_hda.conf

And reboot to see if it solves your issue.

I’ll try that… many thanks for your help. I didn’t forget the log. Just wasn’t able to get it. Nooberd 'n all

No problem :wink:

You can use FileZilla (port 22) to transfer your file from Lakka to your PC.

You should be able to change audio device with right or left key via Settings Tab > Audio > Audio Device

The sound now works… youi my friend are some kind of wizard

So I wasnt able to acces lakka files through ethernet and reinstalled. I can now add roms through ethernet BUT… Now when I try to add audio through the lakka command line on my linux mint machine I get a weird message. Iḿ not greeted with the question for root but get this message instead

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @ @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY! Someone could be eavesdropping on you right now (man-in-the-middle attack)! It is also possible that a host key has just been changed. The fingerprint for the ECDSA key sent by the remote host is 43:7d:8c:83:01:41:50:41:f3:1c:6b:b1:39:3c:67:8b. Please contact your system administrator. Add correct host key in /home/rokompol/.ssh/known_hosts to get rid of this message. Offending ECDSA key in /home/rokompol/.ssh/known_hosts:1 remove with: ssh-keygen -f “/home/rokompol/.ssh/known_hosts” -R ECDSA host key for has changed and you have requested strict checking. Host key verification failed.

Iḿ so close to actually using my lakka pc build. Just this audio thing again. and I can start loading my roms on it Any help would be appreciated.


BTw I did have a shorttime install of antergoslinux on the lakka pc ( was trying lakka on usb stick instead since I couldn add it through ethernet… the roms that is.)

As you updated Lakka ssh fingerprint changed so you need to remove the old one as the message told you (ssh-keygen -f “/home/rokompol/.ssh/known_hosts” -R

That worked. Sound is there but cracking. Could be the game… Iĺl try with another. The documentation states if you hear crackling in the audio to change the KHZ to 44,1. When inside the lakka gui. it states it has 48khz but I can seem to change that either. The game plays though.

Tried adjusting sound latency, to about 80. That fixed the audio crackling somewhat. Seems the sound quality is linked to that.