Pcsx2 trouble games not loading

I got the bios folder in the right place. I can’t figure out why the game won’t load though. Provided is my log file. Please help me figure out what I’m not doing correctly

[INFO] [Core]: Using content: “/storage/roms/Hibiki/ROMs/ps2/Mega Man X8 (USA).iso”.

[INFO] [Core]: Content ran for a total of: 00 hours, 00 minutes, 00 seconds.

[INFO] [Core]: Unloading core…

[INFO] [Core]: Unloading core symbols…

[INFO] Threaded video stats: Frames pushed: 4923, Frames dropped: 0.

[INFO] RetroArch 1.10.3 (Git 9b282aa)`

[INFO] === Build =======================================

[INFO] CPU Model Name: AMD FX™-8320 Eight-Core Processor

[INFO] Capabilities: MMX MMXEXT SSE SSE2 SSE3 SSSE3 SSE4 SSE4.2 AES AVX

[INFO] Built: Apr 25 2022

[INFO] Version: 1.10.3

[INFO] Git: 9b282aa

[INFO] =================================================

[INFO] [Input]: Found input driver: “udev”.

[INFO] [Core]: Loading dynamic libretro core from: “/tmp/cores/pcsx2_libretro.so”

[INFO] [Overrides]: No core-specific overrides found at “/storage/.config/retroarch/config/pcsx2 (alpha)/pcsx2 (alpha).cfg”.

[INFO] [Overrides]: No content-dir-specific overrides found at “/storage/.config/retroarch/config/pcsx2 (alpha)/ps2.cfg”.

[INFO] [Overrides]: No game-specific overrides found at “/storage/.config/retroarch/config/pcsx2 (alpha)/Mega Man X8 (USA).cfg”.

[INFO] [Environ]: SET_SUPPORT_NO_GAME: yes.

[INFO] [Remaps]: Remap directory: “/storage/remappings”.

[INFO] [Overrides]: Redirecting save file to “/storage/roms/RANMA/retropie-mount/Savefiles/Mega Man X8 (USA).srm”.

[INFO] [Overrides]: Redirecting save state to “/storage/savestates/Mega Man X8 (USA).state”.

[INFO] [Environ]: SET_PIXEL_FORMAT: XRGB8888.

[INFO] [Environ]: GET_LOG_INTERFACE.

[INFO] [Environ]: GET_MESSAGE_INTERFACE_VERSION.

[INFO] [Environ]: SYSTEM_DIRECTORY: “/storage/roms/Hibiki/BIOS”.

[INFO] [Environ]: GET_SAVE_DIRECTORY.

[libretro INFO] Bios Found: USA v01.60(07/02/2002) Console

[libretro INFO] Bios Found: USA v02.20(10/02/2006) Console

[libretro INFO] Bios Found: USA v02.00(14/06/2004) Console

[INFO] [Environ]: GET_CORE_OPTIONS_VERSION.

[INFO] [Environ]: GET_LANGUAGE: “0”.

[INFO] [Environ]: RETRO_ENVIRONMENT_SET_CORE_OPTIONS_V2_INTL.

1 Like

there should be a lot more to that log. It does corroborate that your BIOS is present and recognized, though, which is good news.

That’s all that populates in the log. Lakka will reboot when attempting to load the game. Tried it again and got the same log. I’m using Lakka 4.2 on x64 PC

[INFO] [Core]: Using content: “/storage/roms/Hibiki/ROMs/ps2/Mega Man X8 (USA).iso”.

[INFO] [Core]: Content ran for a total of: 00 hours, 00 minutes, 00 seconds.

[INFO] [Core]: Unloading core…

[INFO] [Core]: Unloading core symbols…

[INFO] Threaded video stats: Frames pushed: 2423, Frames dropped: 0.

[INFO] RetroArch 1.10.3 (Git 9b282aa)

[INFO] === Build =======================================

[INFO] CPU Model Name: AMD FX™-8320 Eight-Core Processor

[INFO] Capabilities: MMX MMXEXT SSE SSE2 SSE3 SSSE3 SSE4 SSE4.2 AES AVX

[INFO] Built: Apr 25 2022

[INFO] Version: 1.10.3

[INFO] Git: 9b282aa

[INFO] =================================================

[INFO] [Input]: Found input driver: “udev”.

[INFO] [Core]: Loading dynamic libretro core from: “/tmp/cores/pcsx2_libretro.so”

[INFO] [Overrides]: No core-specific overrides found at “/storage/.config/retroarch/config/pcsx2 (alpha)/pcsx2 (alpha).cfg”.

[INFO] [Overrides]: No content-dir-specific overrides found at “/storage/.config/retroarch/config/pcsx2 (alpha)/ps2.cfg”.

[INFO] [Overrides]: No game-specific overrides found at “/storage/.config/retroarch/config/pcsx2 (alpha)/Mega Man X8 (USA).cfg”.

[INFO] [Environ]: SET_SUPPORT_NO_GAME: yes.

[INFO] [Remaps]: Remap directory: “/storage/remappings”.

[INFO] [Overrides]: Redirecting save file to “/storage/roms/RANMA/retropie-mount/Savefiles/Mega Man X8 (USA).srm”.

[INFO] [Overrides]: Redirecting save state to “/storage/savestates/Mega Man X8 (USA).state”.

[INFO] [Environ]: SET_PIXEL_FORMAT: XRGB8888.

[INFO] [Environ]: GET_LOG_INTERFACE.

[INFO] [Environ]: GET_MESSAGE_INTERFACE_VERSION.

[INFO] [Environ]: SYSTEM_DIRECTORY: “/storage/roms/Hibiki/BIOS”.

[INFO] [Environ]: GET_SAVE_DIRECTORY.

[libretro INFO] Bios Found: USA v01.60(07/02/2002) Console

[libretro INFO] Bios Found: USA v02.20(10/02/2006) Console

[libretro INFO] Bios Found: USA v02.00(14/06/2004) Console

[INFO] [Environ]: GET_CORE_OPTIONS_VERSION.

[INFO] [Environ]: GET_LANGUAGE: “0”.

[INFO] [Environ]: RETRO_ENVIRONMENT_SET_CORE_OPTIONS_V2_INTL.

Okay so found out that PCSX2 will load my ps2 games in retroarch on my windows pc so that’s hopeful. Just got to figure out how to translate those settings to the Lakka OS x64 version of it.

I was mistaken concerning the PCSX2 core for windows. It seems go to the boot menu and then freezes. Anyway I was able to get more detailed log files and hopefully this will be more helpful. The log before it crashes and the log of where it reboots

Starting PS2 game Pastebin.com

Log after PCSX2 Core Crash in LAKKA - Pastebin.com

I hope this helps with debugging

I checked the system requirements for PCSX2, and it has a minimum single-threaded score of 1600. Your CPU is 1492. It’s not going to run it.

1 Like

Crap. Alright thank you. I thought I checked that but I was probably going off of memory that I was able to run it when I had windows installed on it. Thank you again for getting back to me

PCSX2 doesn’t check you minimum single threaded cpu score. You can run low demanding games fine with a lower score with standalone at least. Edit: In fact

From https://pcsx2.net/guides/basic-setup/

  • Note: Recommended Single Thread Performance is based on moderately complex games. Games that pushed the PS2 hardware to its limits will struggle on CPUs at this level. Some release titles and 2D games which underutilized the PS2 hardware may run on CPUs rated as low as 1200.

The 1200 number has to be taken with a grain of salt as well.
Bottom line is, the issue of PCSX2 not booting is likely something else.

1 Like

Keep in mind the logs s/he provided usually would provide the segmentation fault if indeed the PS2 games would be loading and crashing. It doesn’t. There’s more than the actual number behind it. There’s the instruction set the CPU is executing that it is capable of running. PCSX2 requires that number and other requirements as well. BUT…

S/he provided his logs and I looked over them specifically looking for the segmentation fault which would provide the developers (usually @gouchi since he’s the one usually fixing things for Lakka) the clue needed in order to track the instruction execution failure. It’s not there. Windows, and other OSes, have other instructions that execute as a layer in between the hardware and software which affect the compatibility. Lakka has no such overhead as it is programmed differently.

Edit: My apologies for the mistake. My bad.

Not trying to be that person but I’m a she. Again thank you though for offering your guidance on how to proceed concerning PS2 emulation though. I may want to hold off on implementing it in my set up

My bad. Sorry about that! Check post for corrections! :slight_smile:

According to the documentation your bios should be in pcsx2/bios in the system directory :

   └── pcsx2/
        ├── bios/
        ├── cheats/
        ├── cheats_ws/
        └── memcards/   (optional)

If it is still not working you may try to test nightly build.

Thank you.

1 Like

Hi guys, I’m having the almost the same problem. In the end of my log it says “Illegal instruction” I’m on Intel® Core™ i7-3540M CPU @ 3.00GHz which supports MMX MMXEXT SSE SSE2 SSE3 SSSE3 SSE4 SSE4.2 AES AVX.

I noted it doesn’t support AVX2, maybe this core is using ONLY AVX2?

Is there any way of configuring the core to use SSE4 instead? (As I read in the PCSX2, it runs on SSE4.2 and AVX2) Here are my logs: Log Lakka PCSX2 - Pastebin.com

Thanks in advance