Player 2 controls Player 1 Simultaneously! Help!


#1

Before I get into it I’ve searched all over for this and I’ve only found one instance of this. In which no one replied. But then again I don’t even know what to call this. I don’t know if it’s a bug or just some missed setting on my part!

The issue is that when playing a two player game, Player 1 (w/ 8bitdo FC30 Pro) works just fine on its own. But if a 2nd player joins in (w/ 8bitdo SF30) and all of a sudden everything that P2 does, P1 does as well. But still if P1 makes a move separately from P2 it registers just fine. Is there anything I’m missing? Thanks!


#2

Are the controller’s Device Index separate from each other? For instance the FC30 Pro is Port #0, and SF30 is Port #1? Also, have you ever manually mapped the SF30 to User 1 before in the past? The last thing I would look into if the same behavior occurs if the controllers are swapped. For example, when the SF30 is Player 1, and the FC30 Pro is Player 2. Does this also happen across all games and cores?


#3

Thanks so much! I went down the list and double checked everything you said. Now it’s working! Scratch that :frowning:


#4

Hello @TimO how you exactly solved this? thanks


#5

It actually seems like I was wrong because it’s back.

@Get_Rext It came back when I tried to play Mortal Kombat 2 on SNES and continued on in most fighting games. When this happened I remembered that’s exactly how it started the other day, with Mortal Kombat 2. So it seems I’m back at square one with nothing really solving anything. :frowning:


#6

It sounds like a issue with MK2 on the SNES since the problem came back while loading that game. Have you ever manually mapped controls for that game. I dunno how similar Lakka is to Retroarch, but if you go into the root of Retroarch’s folder to config folder, there should be a remaps folder in their. Are there any files in that folder? if there are, I would rename them as “backup” or something, then load up MK2 and see if the problem presists. Best of luck.


#7

There were no files in that folder and I’ve tried looking up how to manually map controls for a specific game but found only this…

How would I go about doing what you suggested? I apologize for being noobish.

That said, I can’t imagine going into what seems like the tip of an iceberg of games and remapping them all. I started playing around with even more games and run into even more issues, all controller based and different every time. But with clayfighter it seems all button inputs on both controllers were discarded except for A and Start. Keep in mind though, this is all wireless and everything works fine when plugged in via USB. Other issues with other games include disconnecting one or both controllers and swapping more inputs. So it seems P2 controlling P1 is only one of many things going on.


#8

No apologies, I’m fairly new to Retroarch myself. I’m learning new things about it as I go along, and with the help of the fourms, users, and Google lol. You shouldn’t have to remap every single game, that would be a major pain and it shouldn’t even result to that. My guess is it could just be an issue as to how the OS detects controller profiles while they’re wireless, since you mentioned that plugged them in wired resolves these issues, or I could be wrong. Have you tried with other wireless controllers by any chance? Like the PS4 or Xbox 360/One? I’m not familiar with the 8-bitdo devices, never got around to getting one myself. Hopefully some of the devs with more knowledge can help assist you.


#9

That’s pretty much what I’ve been doing as well haha. I haven’t tried DS or XB1 but that’s a good idea. I’ll try that now and update in a moment.

Yeah, hopefully someone like @Kivutar might be able to help! Thanks for trying though @Get_Rext, I appreciate it!


#10

hello! afaik bluetooth is bugged and the team is working on it, just one really noob question: are you using 2 bt dongles?


#11

Thanks! That’s good to know. Is there a related thread that I can look at regarding this issue?

Nope, no dongle. Just the 8bitdo controllers paired with Raspberry Pi 3!


#12

yes ofcourse! have a look here:

sorry i forgot about bluetooth included in RPI3 :slight_smile: could you try to add a second bt dongle and pair one controller with internal rpi3 bt and another controller to the added bt dongle? maybe there are some conflicts using only one bt receiver… how’s the latency using two controllers paired with only one receiver?


#13

Ah, so the bluetooth issues @kivutar was talking about was for odroid, and not necessarily Pi3?

I don’t have a BT dongle to try that out unfortunately. But the latency is fine, I haven’t really played much but from what I did I haven’t had any issues.


#14

Any progress on this? I love retro arch but am being forced to move away from it due to controller conflicts!