PPSSPP crashing at launch

since that problem seems to relate to the psp cores behavour on my setup your reply had some logic and made some sense but i tried applying that advice but it didnt work (but that is fine because you were referring to the dolphin core). Do you have ideas for why the psp core crashes retroarch while loading game and how to fix it? thanks for any help. if you want you can split this post and make it a topic of its own

Which video driver are you using?

Have you place the required PPSSPP files in the RetroArch system folder as outlined here: https://docs.libretro.com/library/ppsspp/? I had a similar problem until I found this documentation.

@hunterk

the drivers setting is set to open gl i also tried vulkan too i am currently using the latest version of retroarch but i have noticed this happening on earlier versions of retroarch too.

i have the newest version standalone version of ppsspp installed and that works fine with good speed too. i just curious as to why it does not work on retroarch as other cores work very well on it

@mlurie

i downloaded the archive, there is more than one assets folder, as i am using android do i use assets folder from the ppsspp-master\android\assets directory?

In the …/RetroArch/system directory create a new folder called PPSSPP. Extract only the contents of the “assets” folder from the archive you downloaded from GitHub to the PPSSPP folder. The directory structure should be …/RetroArch/system/PPSSPP/.

thanks for the advice but i tried it and the same problem occurs

Please try the assets from: https://github.com/libretro/ppsspp/tree/master/assets (not the ones in the android folder)

(!) PPSSPP requires the asset files, lang folder, and flash0 folder inside the ‘system\PPSSPP’ directory.

Thanks tried the ones from that link, but still the same problem

take a look at PPSSPP - Can't ever get this to work

I turned off rewind and it worked for me too.

rewind didnt work for me but i discovered that if you load the core first then use the online updater to download and extract the retroarch assets.zip… any game will load up no problem… there seems to be an issue with retroarch assets, something must be happening when restarting retroarch

1 Like

Tried that but Still Crashes for me

.

Did that but Crashes but when I get rid of the Assets it Runs Fine

Tried that and it Worked…

Though you should not need to do that really