Remove curvature


I’m wondering what settings I have to change to remove the curvature and round borders from a shader included in the Analog Shader Pack 3. Here are the settings:


It looks like the crt-geom pass already has the curvature disabled, but the lottes pass is adding its own curvature, which is these lines:

warpX = "0.041000"
warpY = "0.081000"


I thought it was that too, and maybe it is, I’m not sure I can’t tell because - and this is the thing that annoys me the most - it has these huge rounded borders, which I’d like to remove completely. I’ve tried removing maybe every line on the shader but they’re still there. Maybe it’s getting it from one of the .cg shaders referenced? I don’t really understand how this works, but if so, which one may it be and what setting should I be looking for inside?


That’s from crt-geom’s “cornersize” parameter. You can change it to 0.001 to get rid of them.


Does that mean I should change GEOM_CORNER_SIZE = “0.000000” to GEOM_CORNER_SIZE = “0.001”? When I do that the screen gets a lot darker, and the corners remain :sweat:


That’s why those shaders aren’t in the official repos and aren’t supported. They look nice, but they’re a bit of a mess, codewise, with a bunch of redundant, conflicting options stacked on top of each other, not to mention changes to the shaders themselves that may or may not make sense.

Anyway, you would want GEOM_CORNER_SIZE to be the same for both instances at 0.001. If the rounded corners remain, you’ll just have to keep looking for more options that do the same thing.


Hmm, that’s too bad. Thanks a lot for the help. For reference, on crt_easymode-halation I find the following line: #pragma parameter GEOM_CORNER_SIZE "Geom Corner Size" 0.0 0.0 0.1 0.01 not sure what’s up with the multiple parameters but if I change the values to just 0.001, the screen gets clearer again, though still rounded. I’ll keep changing stuff and see what I can find

Are there any 70s CRT TV shaders on the official repo? Something like the NTSC ones… but worse.