Retroarch displays corrupted graphics in full screen, Win10


#1

I’m on a 1070 GTX and i7 8700k. Playing on 4k, Win10, mainly on Vulkan. other video drivers completely crash retroarch. Windowed works fine (reasonably fine, my configurations are constantly resetting, but that isn’t new). Happens with all cores, even without a core.

Rolling back Nvidia drivers didn’t help. Could it have been the fall creators update? Think it started around 1.6.7’s release. Not really sure why it suddenly started doing this a couple weeks ago, was working well until then. When it goes fullscreen, it flashes corrupted graphics (remember missingno from pokemon? Looks like that all over the screen) or goes black with laggy sound playing behind it.

Alt-tabbing to another program makes the visuals reappear, but clicking back to retroarch corrupts them again. Anyone have any ideas on how to fix this? I’m at wit’s end :confused:


#2

I haven’t heard any other reports of this. If you move your entire config file somewhere else (that is, so RetroArch creates a new one for you fresh), does the problem persist? If you download an older version of RetroArch, does it make a difference?


#3

Thanks for the reply! It doesn’t seem like deleting/moving the config file makes a difference. Starting fresh each time still causes the issue in fullscreen.

And it seems like the issue is also persisting in older Retroarch versions, all the way back to 1.3.4 . . . oddly enough, changing the resolution of the Display OCCASIONALLY fixes the issue. I say occasionally because it works roughly 25% of the time, which makes no sense to me at all. I’ll switch it to 1920 x 1080, and a quarter of the time the corruption goes away, 75% it stays, then switch back to 4k, 1/4th it goes away, 3/4ths it stays . . . it’s seriously weird and driving me nuts.

It makes me really believe it has to do with the Windows update or Nvidia, but I can’t pinpoint anything. Would a screencapture video of the issue help diagnose it?


#4

If it’s doing it even with very old versions, then yeah, I’m suspecting something else is afoot, probably Windows/Nvidia-related.


#5

Alright, did some research with the idea that the 1709 Win10 update might be the issue, and found a very telling response on their own forums: https://answers.microsoft.com/en-us/windows/forum/windows_10-performance/my-screen-is-flickering-after-upgrading-to-the/94fd7fe8-ce57-4dee-9bbe-c5a3779eb8e4

A lot of users seems to be having identical issues as I am with a nearly identical system, but not just on Retroarch (so maybe I’m actually lucky in that respect.) One says:

Same problem here. Using nvidia geforce 1070 with the latest drivers. During the update when windows restarts and is at 30% updated, the screen starts to flicker at a high rate. When the update is done, the screen is almost unreadable, pixleated, flickering, and the color completely messed up.

Changing the resolution to something other than recommended and then back sometimes fixes it temporarily, but it randomly reverts back to broken. Reboot doesn’t help, just puts it back to messed up.

Running on a Asus Z270 motherboard and an intel i7-7700k processor. Recovering windows to the previous version fixes it. Tried it twice, same result each time.

This is frustrating, as there are things in this update I want. I’ve paused updates, but I’m concerned that Windows will eventually force the update on me without fixing this issue, rendering my computer unusable.

For anyone else out there dealing with this issue, it appears that rolling back the update is the only fix at this moment. This issue is on Microsoft’s lap and until they fix it on their end, we’re SOL.

EDIT: More testing after rolling back the Win10 update shows a new issue: my video output completely stops for as long as Retroarch remains fullscreen. So now it’s a complete blackscreen with no sound or anything, as if the HDMI itself is no longer receiving any signal.

TEMPORARY FIX: Change the “size of text, apps, and other items” in Windows settings to LESS than the recommended. Upon restarting your system, the issue will be back, though. So you’ll have to change it again every time you restart the computer.

Really, really, REALLY odd. But at least now I can get it in fullscreen at all.


#6

This issue is still on going with my setup as well. I have 4k TV, GTX 1080Ti, Windows 10 Pro Ver.1709. For my 4K TV, recommended resolution is 1920 x 1080. Everything works fine except Retroarch. Every games I have works fine without any issue. Only way to stop flickering issue is either I have to be in windowed mode (which I never prefer to play games) or change my TV resolution to 3840 x 2160. But since this is not recommended resolution, it slows down PC a bit. So, could you tell us any other workaround without changing resolution?


#7

Have you updated to the latest Retroarch nightly? They recently fixed some major vulkan issues on nvidia cards.


#8

Yes, still the same black screen with glitches and flickering. I’ve tested with latest version: Nightly Windows x86_64 2018-02-11_RetroArch

Like @shadowblind mentioned, it’s nothing to do with config file either since everything works normal when I switch screen resolution to 3840 x 2160.


#9

Just to give you an update. This issue is fixed now. No more glitches and flickering on screen with 1920x1080 resolution. I updated windows 10 to latest also Nvidia drivers. I’m not sure which fixed the issue but it works fine with Retroarch 1.7.1.


#10

Anyone find a solution to this? On Win 10, GTX 1050, Ryzen 5 on a 4ktv (3840x2160) screen flickering and massive slowdowns on 8/16 bit cores. I’ve updated everything, tried 1080p resolution, downgraded retroarch and I still have this issue.


#11

Roll back your Nvidia drivers to 411.63: https://www.reddit.com/r/RetroArch/comments/9okky6/horizontal_lines_jumping_in_full_screen_mode_only/


#12

Rolling back fixed the screen tearing issue but the cores still run super slow

Edit: Found this and will try it when I get home. Goto Settings --> Audio --> Audio Device (note this is typically set to 1) I changed mine to 2 presumably the NVIDIA audio device a boom full speed gameplay…

Re edit: nope doest work. Retroarch still slow and choppy :unamused:


#13

FWIW, my girlfriends laptop exhibited this same behavior when running RA. Win10 x64, 4K GTX 1050 and i7.

What fixed this is an Nvidia driver update right from Lenovo’s website. (Her laptop is Lenovo) Now getting normal speed in RA.


#14

So how would that work with a desktop?


#15

probably the reason it works is that laptop OEM drivers are usually based on older driver revisions than the GPU vendor’s, so it’s similar to just rolling back to an earlier driver version


#16

Since my black screen issue was fixed and I kind of deviated from this thread in regards to my slowdown issues, I have opened up a new topic here:


#17

I have the same problem. 4k Monitor (3840x2160), Geforce RTX 2080Ti (417.01), GL Driver.

The problem occurs only with the GL driver and only in full screen.