Rom Scanning / final solution

Hey guys I had a silly thought.

So according to some of the stuff I was reading… the older versions of lakka could just make a playlist from whatever folder you scanned. Right? And now it needs to be games from the NO-intro collection… I believe this is a smart feature and ensures the quality of the whole situation, but I would really love to get my MAME stuff going and that is proving to be troubling.

What I was thinking is …

  1. Is there an older version of lakka that I can download and scan the directories for mame roms to generate playlist?

  2. Can I then just drag and drop the .lpl ?? (into the new version of lakka)

Please tell me this is possible guys. Please!!! I got a splitting headache i wanna finish this box before christmas.

P.s. I know the concept of playlist script has been flung about but my brain hurts and i dont think I want to dive into that as I’m working with alot of weird variables. Just want an easy simple solution!!


Older versions of Lakka didn’t create .LPL files, so your idea won’t work unfortunately.

You can try the script OR just manually edit the LPL files yourself. Lakka alphabetises the entries in the file for you, so forget about getting the order right. Just get the format right, do some epic copy and pasting, and you’ll be good to go.

Aww crud. I guess thats how its gonna have to be.

All the time I spent trying to get around doing it it would have been finished by now…

I even tried to open a bunch of games and copy the .lpl from the recent games list after renaming it . lol

It would be nice if the “no-intro” database requirement could be disabled. I had tried a version of Lakka earlier this year and was able to scan and play my Atari 2600 roms no problem. When I actually got around to building a Lakka system, I naturally used the latest-available version of Lakka - one that has the “no-into” database limitation.

Thus I couldn’t scan my Atari 2600 roms. I spent a few days trying to figure out what I must have done wrong, only eventually stumbling upon information regarding scanning against the “no-intro” databases.

while I’m sure this integrity-scanning is considered a feature, from the point of view of a new user, it’s a limitation that gets in the way of the systmem “just working”. I’d love to be able to disable it.

I’d love to be able to disable the “no-intro” database requirement. I had tried a version of Lakka earlier in the year where I could easily scan and play my Atari 2600 roms. When I finally got around to building a Lakka system, I naturally used the latest-available version of Lakka, one that has the “no-intro” database limitation. So the scanner wouldn’t recognize my Atari 2600 roms, and didn’t provide any feedback about why.

I spent a few days trying to figure out what I must be doing wrong, because I couldn’t generate a playlist for my seemingly-valid roms. I only accidentally stumbled upon information regarding “no-intro” database usage during rom scanning, and after some help on the forums, was able to build a playlist “manually” (I wrote a script and posted it in the forums).

It would have been enough hassle to turn-off most new users or inexperienced Linux folks.

It would be nice to be able to turn off the no-intro database scanning, at least for rom-types for which there is no “no-intro” database.

I got the playlist setup with the use of the hotkey scripts, then replaced all the paths to the roms so that lakka would read them…

It shows up in lakka but does not launch the games or give any hint of loading a core…

Where are the cores located in lakka?? or retroarch I should say. I have triple checked the whole drive and cant seem to find anything that looks close to a standalone core file.

I was thinking maybe downloading a core and placing it in a folder by itself… then instructing lakka to use it to launch…

This is getting aggravating. But then again I am learning alot of stuff i didnt know so its not too bad :slight_smile:

Go into your settings > directories and look for whatever you core directory is set to. That’s where your cores live.

Thanks hunterk I was able to figure out where the core lies… But still not loading the games correctly. I can load content and select core and it works but not on the playlist.

Heres how my .lpl is looking

/storage/roms/MAME1/ 005 /tmp/cores/ DETECT 000001|CRC /storage/roms/MAME1/ 1941 Counter Attack (World 900227) /tmp/cores/ DETECT 000002|CRC /storage/roms/MAME1/ 1941 Counter Attack (Japan) /tmp/cores/ DETECT 000003|CRC /storage/roms/MAME1/ 1942 (Revision B) /tmp/cores/ DETECT 000004|CRC /storage/roms/MAME1/ 1942 (Revision A) /tmp/cores/ DETECT 000005|CRC

and so on. Maybe someone can point out what is wrong with the layout.

I have also tried variations on the core file of just “” to no avail…

Maybe i dont have to have the “/” (forward slash) when I begin to name the path…

Mind you I am working on a live usb so that might be another issue… Also what us that CRC line about. Maybe its conflicting with another playlist??

Thanks again for all the help guys

The leading fwd-slash is necessary if that’s what the path is. / means the very top-level directory, so /tmp/cores/ is an absolute path. Starting with ./ or …/ would be relative pathing.

I think the CRC needs to match that of the file you’re trying to load. EDIT: guess not, according to this thread:

Im at my wits end. I have tried it amillion different ways. Slightly changing this and that.

Now I will play some super mario world 2 and cry myself to sleep like baby mario … :smiley:

1 Like

I’m working on a dumb (as in, doesn’t check against databases, etc.) scanning script for you:


echo "Enter the absolute path to your core"
read core

echo "Enter the absolute path to the directory you want to scan"
echo "(exclude trailing slashes)"
read content

echo "Enter the name of the playlist"
read name

for i in $content/*; do
echo "$i" >> $name
echo "$i" | sed 's=.*/==' >> $name
echo "$core" >> $name
echo "$core" | sed 's=.*/==' >> $name
echo "$COUNTER|crc" >> $name
echo "" >> $name

It will ask you some questions and then generate a playlist based on the answers.

I am going to try and add some magic to provide less-ugly names for the core and filename, if anyone more competent at bash scripting cares to pitch in. I just need to delete $content from the beginning of $i, presumably with some sed magic.

As it is, it will already create the playlist and launch files from it, the names are just mostly unreadable since they include the full path.

EDIT: and the sed magic is in, so now it just shows the filename and not the entire path.

why don’t you guys load the games manually. you don’t have to load from playlist

That would be amazing hunterk!! Ask me anything. Im like so near the end here I just wanna see it done and feel proud.

This bash script would need to be run inside a linux environment I am guessing? I would have to hit tab in the beggining before liveboot and get into command line… Or something like this correct?

Yes I can load the games manually, but I want to make it foolproof since I am going to be handing it out to friends and family members. My mom can press left+right to start an arcade game, but load content+select and find core+roms+playlist+ etc… might get confusing as she is a simple lady

Okay so I boot the usb, hit tab, edit the cmd “tty retroarch=0” and then hit ctrl+tab+f3… and it pulls up the terminal…

from here where do i go to run this script? I also have acces to the file system using slitaz. It is how I added the roms and bios.

Do I have to have a premade text file and then “invoke it” using the terminal???

Please keep in mind I am no pro at this stuff in the least bit

You’ll need to copy that script to a file, make it executable and then run it, like this (from your playlists directory): nano dumb-scan [copy all of that crap into it, probably best to do the whole thing over ssh from another machine…; exit with ctrl+x and then ‘y’ to save] chmod +x dumb-scan ./dumb-scan

I still haven’t figured out a good way to clean up those names yet :frowning: , would this help? check the downloadable xml

Ok, I got the script fixed up (edited in the previous post). It only lists the filename now instead of the entire path.

Okay so I have lakka on a usb for pc* and all my roms and settings are on there… it boots live onto any machine with compatible hardware (so far only one machine had no audio, but it was some weird sound card). it is AWESOME

now, I have direct access to files on the usb by booting into a linux environment and then pluggin in the lakka flash drive and reading/writing/browsing filesystem etc

This script you have written Hunterk I am not totally sure how to implement.

In windows autohotkey script (the one floating around) you save the text file… then run it and it creates an lpl…

So I figured I would copy the text you have written… save the file as .sh?? in playlist folder. Then check permissions are good to go and right click and press execute right??

I got a message

““failed to execute child process “/media/disk/playlists/” (No such file or directory)”” is what I named the file…

Does any of this sound correct?

You need to run it from a command line, as it will ask you questions there.

So I finally figured out I needed to type in this stuff directly in the command line. it opened up some interface i typed in the stuff… saved it.

opened it with the “chmod etc” then opened the file it asked me the questions. I answered and then it said something about “line 21 error.”

opened lakka and it did create a playlist but the entries had abusrd symbols and letters… Maybe i typed something wrong.

I will try again when I have the will to go at it.

I might just have to wait for the pros to take care of my problems…

Just reading about absolute to relative paths for the last hour has brought me to my mental limits. And I still dont fully understand…haha

Thanks hunterk for all your help. This one might be beyond me.

1 Like