RPI 4 8gb aarch64 Lakka Nightly Builds Sound and Bluetooth Controllers

Hello All, New to the Game Here but found some interesting things and figured I would share.

  1. Sound: If you have a PI4 8gb and installed the latest aarch64 nightly build you will probably notice that it has no sound. This is because the sound is being outputted on HDMI0 instead of HDMI1 which is where your cable is. Not to fear. Go to Settings/Audio/Output/Device and enter this hdmi:CARD=vc4hdmi1,DEV=0 as the device and back out and restart Retroarch. You should now have sound. If this doesnt work for you then you will need to SSH into your PI4 which can be done from windows 10 using Powershell. protip: connect your pi4 to the same wifi as your pc before trying this Open powershell and type ssh [email protected]your pi’s IP Address Here default password is root. Then once its connected type aplay -L to list the audio devices. Look for the one with “hdmi1” and the word CARD. Write that down and enter it into the audio device settings I described above and reboot Retroarch and you should have sound.

  2. Bluetooth: This one is a little more tricky. You will have to SSH into the PI4 to do this one hands down. So as instructed above open powershell and login. Once logged into the pi4 type this nano /etc/modprobe.d/bluetooth.conf in the newly created file the only thing you need to type is this options bluetooth disable_ertm=Y then save and exit. Reboot your PI4 and go to bluetooth. Set your controller into pairing mode then search for Bluetooth devices in Retroarch once it finds your controller select it and it will connect. Then its up to you to go to input settings and change input 1 to the wireless controller and your off to the races.

I hope this helps everyone. It took me a bit to find the workarounds for these issues let me know if you have a better or easier way of making them work as I am always open to feedback.

2 Likes