Stuck at first time boot screen (infinite reboot loop)

guide

#1

hello, i decided to turn my old net book to a retro machine with lakka, i installed with a usb the OS in netbook’s harddrive and i take off the usb and reboot as said at the instructions.After this it shows me the flower flashing after several seconds.my netbook is asus aspire one d255 series, thank you


#2

Can you try to make a test with Lakka 2.1 rc1 booting in live mode ?

If it still doesn’t work, please try to provide some Lakka system log and graphic logs.

Thank you.


#3

I’m getting the same thing on an Asus EEEPC with 2.1 rc4. It boots once from the USB and shows messages about “resizing partitions,” then it reboots and then gets stuck in an infinite loop with the flower screen.

I have seen the same thing happen on a 2006-era MacBook as well.

Both machines can install and run the Lakka-Generic.i386-devel-20161221183352-r21729-g274b40f.img.gz version with no problem.

I am not sure how to get system log or graphic log since the machine doesn’t boot far enough to allow ssh.

Thank you!


#4

@houtside : you can try to enter live ssh in the boot prompt. It will allow you to have ssh access.


#5

System Logs: https://pastebin.com/CjzH6wHz Graphic Logs: https://pastebin.com/hGxrWHz6 Audio Device Logs: https://pastebin.com/N3QdnY1h USB: https://pastebin.com/jnv9ekQQ dmesg: https://pastebin.com/FGUzCvd6


#6

I have the same problem too…


Stuck on the flower screen
#7

@hotoutside : it seems you get a crash. Can you try to change the configuration file with

menu_shader_pipeline = "0"

If it still doesn’t work you will have to use rgui driver with

menu_driver = "rgui"

Nano editor shortcuts (CTRL+w to search, CTRL+o to save, CTRL+x to quit).

@tasdim20 : As you see on the thread, please provide some logs. Thank you.


#8

Can you please elaborate? If you cant boot lakka how do you edit/access the config file? There is a circular explanation in the documentation.

To edit the config file you need to access command line

  • Cant access command line via SSH if Lakka wont boot
  • Cant access command line via Serial if Lakka wont boot
  • To access command line Directly need to edit cmdline using command line (CIRCULAR ARGUMENT)

Can you please help?


#9

Just because you can’t see Lakka doesn’t mean the necessary information isn’t present. If you can see the flower, actually, you CAN access Lakka, but not in the traditional means you may be thinking.

Which is why hotoutside was able to generate the logs by following gouchi’s advice. He posted it above.


#10

Thanks @Shockwave. I figured out how to access the config file. However, the solution by @gouchi didn’t solve my problem. My log file is here


#11

You’ve got a segmentation fault. Not much you can do there, bud. It seems to be caused by an input device you have connected to your Lakka machine. What are you using for a controller or input device connected to the ports of your machine, if I may ask?


#12

It’s just an old Dell Inspiron Laptop. No inputs. I am running Lakka off of thumb drive I found lying around. I tried to solve the problem by adding a USB keyboard with no change.


#13

Your Dell hardware is probably faulty (maybe).


#14

Try to boot with

live textmode

Then try to change your configuration file with those options.

Thank you.


#15

@gouchi I was able to change the configuration file to the previously mentioned options using

live ssh

However, it did not solve the problem. I don’t think I am getting the same error as @hotoutside. See log file. Although, @hotoutside was also getting a Segmentation Fault.

It seems like it has something to do with the history files which lead to this error and ultimately the seg fault

Unable to find target for this triple (no targets are registered)

@HarfTarf The computer boots to windows fine, albeit slowly. What specifically do you think is faulty?


#16

@WahooSalty So you tried to change the configuration file and even with rgui menu driver, it is not working ??

You got the same error when you are using rgui menu driver ?


#17

@gouchi Correct. I get the same reboot loop with

menu_driver = “rgui”

and with

menu_driver = default option (don’t remember the setting)

However, I am not sure if the errors are the same. I’ll have to check later.

The log file I showed previously is for rgui menu driver.


#18

@gouchi These are the log files under two configurations of the configuration file.

Default setting log

menu_driver = 'xmb'
menu_shader_pipeline = "2"

Modified setting log

menu_driver = 'rgui'
menu_shader_pipeline = "0"

It seems that the error is the same regardless of the setting I’ve changed. Also, note that the error is different than @hotoutside

I found another forum topic that discusses a similar error in another context. However, I’m not sure if the solution can be implemented in this case.


#19

I don’t know but we are using llvm 3.9.0 which is enabled for R300 ATI graphic cards.


#20

@gouchi You don’t know what? Are you saying this should work? Are you saying I am using the R300 card?