Trying to get Dreamcast games to work

I’m slowly going through each of the emulator/ROM sets that I’m having trouble with, so please bear with me :). I’ve managed to get my Atari Lynx and Playstation games to work (though I’m sure I’ll run into a few hitches with the odd game here and there). So now I’m after the Sega Dreamcast games.

If I go the Load Content > Select File and Detect Core route, I can see the BIN files for the Dreamcast. However, when I try to play them via the Dreamcast (Reicast), it just kicks me back to the main lakka menu. Doing some experimenting, I’ve found that one of my choices here, specifically “Sega MS/GG/MD/CD (Genesis Plus GX)” selection works with my Dreamcast files.

So here is what I’d like to know:

Is something going on with the Dreamcast (Reicast) selection that I need to know about?

Should I just go with that Genesis Plus GX core for the Dreamcast games? If so, is there a way for me to point to that core from within lakka without having to manually do it via a playlist?

I’ve added the BIOS files in system/dc as per this page:

And thanks again to those who have been very helpful with my other issues and thanks in advance for any help here :).

genplusgx won’t load dreamcast games. It’s just showing as an available core because people used to use the *.bin file extension for genesis/mega drive games.

For Reicast, you’ll need to load the cue sheet rather than the bin itself. I’ve had good luck with GDI images, IIRC.

Also, make sure you have read/write access to your system/bios directory (e.g., I had problems because my BIOS all live in a read-only network share) because Reicast needs to write things in there.

Ok. I’ll be able to check the system/bios directory tomorrow.

As far as the Genesis Plug GX, when I selected that core, it played every Dreamcast I tried with it.

What is the cue sheet? Is it the same as the cue file that goes with Playstation games?

lolwut?? something very strange must be going on, then, since that core contains zero Dreamcast emulation code.


I can’t explain it either. I have a folder with some Dreamcast ROMs in it and while experimenting around a bit trying to get them to work yesterday, I noticed they worked with that Genesis Plug GX. Perhaps they aren’t really Dreamcast ROMs but are just labeled that way. I’ll double-check the game titles and see what I can find. I’ll look into trying a couple CUE files and see what happens :).

Yep, that’s what the problem was! They are regular Sega Genesis games labeled as Dreamcast. Ok, one mystery solved LOL. Sorry for the confusion :).

lol no problem.

I can start my own thread if needed, but Im having trouble with dreamcast. I put the bios files where they should be. The files are .cdi. Lakka wont scan them and display them like the other roms I have. Also, when I try load core, Reicast, then load content and select the .cdi file it just goes to the lakka flower screen and sits. Any ideas?

Hi there, I also have problems to load dreamcast roms (CDI) using Reicast, it keep saying “Failed to open libretro core”. I do have Dreamcast BIOSes (dc_bios.bin and dc_flash.bin) in folder system\dc with RWX rights set for all on it (folder + files).

@slkzi We’ll need a log to know anything.

Hi hunterk,

here is the log URL :

The problem seems to come from core wrong file or version : RetroArch [ERROR] :: Failed to open libretro core: “/tmp/cores/” RetroArch [ERROR] :: Error(s): /tmp/cores/ wrong ELF class: ELFCLASS64

I’m running Lakka on a RPi3 and I found the core in the Libretro nightly URL repository :

I did not found any armhf suitable core file so I though the x86_64 should be fine.


OK, first off, no running x86 64-bit instructions on ARM architecture for you. In other words, you’re not running Intel/AMD processor instructions on a Raspberry Pi board. Go get the RPi2 version of the nightly (it’s compatible with RPi3 as well).

Second, do you have the Dreamcast BIOS files? Without them, even if you have the Dreamcast emulator, it won’t work. Lakka also requires them to have a certain MD5 hashtag. Check here: Google is your friend.

1 Like

Hi Shockwave,

thanks for your reply. I did a trial and fail test. I do undersand that so far there is no Dreamcast core for ARM based board ? I’m already running the lastest nighly build of Lakka (Lakka-RPi2.arm-devel-20161106232944-r21640-ge218f0f) but I will keep having a look on it from time to time. BIOSes are already set, I guess I need to wait for a Dreamcast core release.

Many thanks for you help.

1 Like

hi im having this problem and dont know what to do can anyone help

i keep getting failed to load content

Missing BIOS, wrong CD image?
Are you trying to load NAOMI/ATOMISWAVE mame roms (*.zip) or BIN/CUE BIN/GDI CD images?

Can you post a log:
Settings - User Interface - Show Advanced Settings = ON
Settings - Logging - Logging Verbosity = ON
Settings - Logging - Frontend Logging Level = 0 (Debug)
Settings - Logging - Core Logging Level = 0 (Debug)
Settings - Logging - Log To File = ON

The logfile should be in /storage/.config/retroarch/logs/retroarch.log

P.S. and please don’t cross-post the same question in different threads :slight_smile:

1 Like

Try downloading the Nightlies. I’ve been testing the cores for the N64, Dreamcast and PSP and they’ve been running great.

Hi, new to Libretro and messing around with my RPi4 with lakka. I’m also running having the problem of Dreamcast games not running. Bios are installed. Everyone seems to mention reicast being the core but I only have flycast available and it won’t run. Wondering also what you meant by Nightlies in the link you posted and how they may help the situation. Forgive me I’m super inexperienced and have only been doing this for the past 2 weeks and can start a new thread if nessessry.

The latest version of the Lakka nightly doesn’t need the BIOS in order to run Dreamcast (I’ve tested it). It runs great (Crazy Taxi’s performance is pretty acceptable in my book, even if it is below 60fps). That, is at stock clocks (no overclock).

Hmmmm so how might I go about troubleshooting this issue? Everytime I load a dreamcast game in just get “failure to load content.”